Testbuilds for SlimTV using TVServer+MPExtended - Updated for 2.2 (2018-10-09)! (1 Viewer)

crankshaft

Portal Member
December 27, 2012
19
2
41
Great Britain (UK) Great Britain (UK)
Country flag
Pls navigate to the red "X" on right top. This is a message about something wrong in the system. Need to see what's written there.
I can prove that by clicking on Multi TV Guide it looks like you want it:
View attachment 149193
I never even noticed that! It says:

The skin resource for screen 'SlimTvClient-fullguide' seems to be broken
 

crankshaft

Portal Member
December 27, 2012
19
2
41
Great Britain (UK) Great Britain (UK)
Country flag
PS I've removed all references to mp2 from registry, program data and program files. And reinstalled[DOUBLEPOST=1398031911][/DOUBLEPOST]
So best is to reinstall SlimTV Plugin to get skin files fixed.
You can try the plugin I've uploaded. It's the one I'm using with success. You can find it here:
https://forum.team-mediaportal.com/...versary-edition-released.125516/#post-1076364
Bang! Your the man! Works perfect now. Thanks

For reference this is where I got the plugin from originally: https://www.team-mediaportal.com/extensions/mp2-plugins/slimtv-mpextended

Now off to work out how to use my Hauppauge remote...
 
Last edited:

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,084
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Oh, that plugin really is outdated. We definitely need to remove it there.

    The remote should be working with IRSS (just a hint)...
     

    crankshaft

    Portal Member
    December 27, 2012
    19
    2
    41
    Great Britain (UK) Great Britain (UK)
    Country flag
    Hi.
    Oh, that plugin really is outdated. We definitely need to remove it there.

    The remote should be working with IRSS (just a hint)...
    Lol! I don't feel so bad now!

    Just been looking at irss.

    Thanks for the help guys
     

    scrappy.doo

    Portal Pro
    September 5, 2005
    51
    0
    I'm having troubles getting IPTV working via the new SlimTV service. I've setup an iptv2rtsp proxy so I should be able to access the channels using rtsp (this is confirmed to work using vlc)
    Initially I didn't even see any IPTV tuners when running the setup.exe. It required registering the MPIPTVSource.ax manually using regsvr32. However now I see the following error in the ServerError.log when initiating a channel scan:
    [2014-07-31 18:48:00,415] [1641299] [64 ] [DEBUG] - TvCardBase: free subchannel, ID = 0, subchannel count = 1
    [2014-07-31 18:48:00,416] [1641300] [64 ] [DEBUG] - TvCardBase: subchannel 0 update decrypt list, mode = Disabled, update action = Last
    [2014-07-31 18:48:00,417] [1641301] [64 ] [DEBUG] - TvCardBase: service is not encrypted
    [2014-07-31 18:48:00,417] [1641301] [64 ] [DEBUG] - BaseSubChannel: subchannel 0 decompose
    [2014-07-31 18:48:00,419] [1641303] [64 ] [DEBUG] - TvCardBase: configure PID filter, mode = Auto
    [2014-07-31 18:48:00,419] [1641303] [64 ] [DEBUG] - TvCardBase: no subchannels
    [2014-07-31 18:48:00,420] [1641304] [64 ] [DEBUG] - TvCardBase: no subchannels present, stopping device
    [2014-07-31 18:48:00,421] [1641305] [64 ] [DEBUG] - TvCardBase: stop, idle mode = Stop
    [2014-07-31 18:48:00,421] [1641305] [64 ] [INFO ] - tvcard:FreeAllSubChannels
    [2014-07-31 18:48:00,422] [1641306] [64 ] [DEBUG] - TvCardBase: perform device action, action = Stop
    [2014-07-31 18:48:00,423] [1641307] [64 ] [DEBUG] - TvCardBase: set graph state, state = Stopped
    [2014-07-31 18:48:00,423] [1641307] [64 ] [DEBUG] - current state = Stopped
    [2014-07-31 18:48:00,424] [1641308] [64 ] [DEBUG] - TvCardBase: graph already in required state
    [2014-07-31 18:48:00,425] [1641309] [64 ] [DEBUG] - TvCardBase: action succeeded
    [2014-07-31 18:48:00,425] [1641309] [64 ] [DEBUG] - TvCardDvbIp: remove source filter
    [2014-07-31 18:48:00,427] [1641311] [64 ] [DEBUG] - TvCardDvbIp: add source filter
    [2014-07-31 18:48:00,430] [1641314] [64 ] [DEBUG] - TvCardDvbIp: result = success
    [2014-07-31 18:48:00,430] [1641314] [64 ] [ERROR] -
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Mediaportal.TV.Server.TVLibrary.Interfaces.HResult.GetDXErrorString(Int32 hresult)
    at Mediaportal.TV.Server.TVLibrary.Implementations.TvCardBase.SetGraphState(FilterState state)
    at Mediaportal.TV.Server.TVLibrary.Implementations.TvCardBase.Tune(Int32 subChannelId, IChannel channel)
    at Mediaportal.TV.Server.TVLibrary.Implementations.TvCardBase.Scan(Int32 subChannelId, IChannel channel)
    at Mediaportal.TV.Server.TVLibrary.Implementations.DVB.Graphs.DvbBaseScanning.Scan(IChannel channel, ScanParameters settings)
    at Mediaportal.TV.Server.TVLibrary.CardManagement.CardHandler.ChannelScanning.Scan(IChannel channel, ScanParameters settings)

    Any idea what's going on???
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    ClientError.log
    There is no \Users\Oxan
    C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.TVAccessService\TVAccessService.cs:line 724
    [2014-01-26 07:57:59,952] [51373 ] [InputMgr ] [ERROR] - localhost: Object reference not set to an instance of an object.
    System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Object reference not set to an instance of an object. (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
    System.NullReferenceException: Object reference not set to an instance of an object.
    at MPExtended.Services.TVAccessService.TVAccessService.SwitchTVServerToChannelAndGetTimeshiftFilename(String userName, Int32 channelId) in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.TVAccessService\TVAccessService.cs:line 724
    at SyncInvokeSwitchTVServerToChannelAndGetTimeshiftFilename(Object , Object[] , Object[] )
    at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
    at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc)
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc&...).
    Hello!
    Could you solve that problem? I am seeing the same. :(

    EDIT:
    Had nothing to do with MPExtended or SlimTV, was a MP1 TV Server issue. Update helped. All working now. :)
     
    Last edited:

    MaxMan23

    MP Donator
  • Premium Supporter
  • September 8, 2007
    380
    48
    Germany Germany
    Hi i got a error with the last version. When i try to start MP2 i got this:

    [2015-02-17 15:52:30,232] [867 ] [Main ] [ERROR] - ScreenManager: Error applying skin 'default', theme 'default'
    MediaPortal.Utilities.Exceptions.EnvironmentException: Error loading style resource 'H:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SlimTv.Client\Skin\default\themes\default\styles\SlimTvStyles.xaml' ---> MediaPortal.UI.SkinEngine.Xaml.Exceptions.XamlLoadException: XAML loader: Error parsing file 'H:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SlimTv.Client\Skin\default\themes\default\styles\SlimTvStyles.xaml' ---> System.TypeLoadException: Die Methode "OnKeyPressed" im Typ "MediaPortal.Plugins.SlimTv.Client.Controls.EpgGrid" der Assembly "SlimTv.Client, Version=2.0.0.1409, Culture=neutral, PublicKeyToken=null" überschreibt eine Methode, die in dieser Assembly nicht sichtbar ist.......

    What could it be? Bevor i try to use mpextended, i used the native one. (But i clear all the plugins bevor i try this)
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,399
    6,970
    Germany Germany
    Country flag
    Please only use the SlimTV plugin which is contained in the Weekly build!

    I recommend to:
    • Reinstall Weekly build
    • remove SlimTv.NativeTV plugin from MP2-Client\Plugin
    • add the SlimTV.MPExtended plugin from Weekly dowload thread
    Important: Keep the SlimTV.Client plugin as it is! Older versions from this thread or also download on homepage are not compatible.

    You also can wait till friday for a new build ;)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    morpheus_xx Interest in a DVBLink / TV Mosaic SlimTV provider? MediaPortal 2 18
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    toricred [solved] Configuring TV Server to use NAS General 5
    vvulture Using Windows 10 MediaPortal 1 Talk 8
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    Megane Too much RAM used (over 2 GB). General Support 18
    doskabouter 1.23.0 MatroskaTagInfo uses the wrong casing for tags Bugreports 27
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    D I just installed MP 1.23. Which version of Schedules Direct should I use, where do I obtain it from Newcomers Forum 6
    M Can i use my Vu+ Zero 4k Tuner for Mediaportal? General 0
    benicehavefun Using MePo TV Server 1.23 via MPExtended/WebMediaPortal as a Backend for Plex MPExtended 4
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    1gkar Use Alternative Sites to Scrape Series Info My TVSeries 5
    T Can Emprex 3009ARF III MCE Remote Control be used to toggle Fullscreen/Windowed mode?? Remotes 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    N [Proposal] Make text input using remote control easier MediaPortal 2 4
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    erika jandova Using SD and MediaPortal 1 Newcomers Forum 4
    D Large xml database in My Movies Management. I remain unclear on use My Films as bridge to MP2.2 General 9
    N [solved] When MP2-Client is trying to register credentials, it uses the wrong machine name MediaPortal 2 7
    high [Help Me!] Atlassian Fisheye/Crucible still used? Team Lounge 8
    D [solved] HID remote for mp2 and w10 64 bit? using all tools: sony, cisco, homeworkx ng General 2
    Symphy Still being used? ASIO music player 0
    P no signal when scanning for channels using antenna and dual hd General Support 2
    Similar threads

























    Top Bottom