TSWriter deadlock potential fix. (1 Viewer)

mcraenz

MP Donator
  • Premium Supporter
  • July 28, 2007
    647
    46
    Auckland
    New Zealand New Zealand
    I was getting, All cards busy after a few days. Couldn't stop TVService, couldn't even kill the process. Had to reboot.
    Have applied the patched TVLibrary.dll, TVService.exe and tswriter.ax. I'll report back.
     
    Last edited:

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    It looks for me like as there are no bad side effects atleast :)
    I didn't had the deadlock on my HTPC (at least I didn't noticed it) and nothing changed with the patch :)

    The HTPC from my Dad looks better, sometimes there were cards blocked, but at the moment it is looking good ;)
     

    Quarter

    MP Donator
  • Premium Supporter
  • June 21, 2010
    722
    138
    Queenstown
    New Zealand New Zealand
    Country flag
    Hi Guys I have been following this thread thinking I'm glad I don't have this problem. But now I have issues I would like to check my problems with the issues this thread was started for. Could we have the first post updated to include the bugs this fix is being created for. cheers
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello mate :)

    Could we have the first post updated to include the bugs this fix is being created for. cheers
    It is difficult to do that because this issue results in a variety of symptoms. I ask people to post log files and I'm able to quickly determine whether they're seeing this issue.

    What more can I say...
    Fundamentally, to experience this bug you must have the idle EPG grabber enabled.
    When the bug strikes you'll lose access to one or more tuners... which may mean that you see "no free card" messages... or when you try to view/record a channel MediaPortal and/or TV Server lock up.
    One final characteristic: the TV service process becomes unstoppable. You can't stop it via the manual control section in TV Server configuration or via Windows service manager, and you can't kill it via task manager.

    Does that help?
    mm
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    ...or maybe you were referring to Owlsroost's TsWriter?

    https://issues.team-mediaportal.com/browse/MP1-3224 (TsWriter deadlock) - note this affects more than just the TsWriter code
    https://issues.team-mediaportal.com/browse/MP1-4203 (PacketSync fragmentation handling)
    https://issues.team-mediaportal.com/browse/MP1-4216 (Add PCR hunt capability)
    https://issues.team-mediaportal.com/browse/MP1-4217 (Fix for Dish network scanning and SDT 'otherMux' handling)
    https://issues.team-mediaportal.com/browse/MP1-2357 (TsWriter part - adds filter version info)
    https://issues.team-mediaportal.com/browse/MP1-4221 (Convert to async logging and revise log formatting)
     

    mcraenz

    MP Donator
  • Premium Supporter
  • July 28, 2007
    647
    46
    Auckland
    New Zealand New Zealand
    What's the likelihood that this bug could have something to do with a BSOD with a reference to TBS6984 quad tuner driver? Thought I had a bad card but just replaced it with a TBS6985 and problem still occurs.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    What's the likelihood that this bug could have something to do with a BSOD with a reference to TBS6984 quad tuner driver? Thought I had a bad card but just replaced it with a TBS6985 and problem still occurs.
    I think it is probably unlikely... but with no context, that is a bit of an impossible question.
    Of course I understand it is difficult to grab logs with a BSOD, but are you able to provide any additional information?

    [edit: ...having said that, you've got absolutely nothing to lose by trying this patch...]
     

    mcraenz

    MP Donator
  • Premium Supporter
  • July 28, 2007
    647
    46
    Auckland
    New Zealand New Zealand
    Yeah I have been running the patches for a couple of days but it looks like the fault has occurred again for me. Logs attached. Notice at 17:56:52 when I tried to tune Nat Geo the first card failed to get reservation and it moved on to the next card. Eventually all cards end up in this state. I also tried to stop the service which failed. And can't kill process. Will need reboot.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    N Tswriter Watch / Listen Media 51
    doskabouter No guide info added due to a MYSQL deadlock Electronic Program Guide 1
    Similar threads


    Top Bottom