UMTS - kein Standby mit StreamedMP

Discussion in 'Ruhezustand/Standby' started by Azarath, January 31, 2011.

  1. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    MediaPortal Version: 1.1.2 + 1.2.0 (zum Testen)
    MediaPortal Skin: StreamedMP (aktueller stable)
    Windows Version: Win7 x64
    CPU Type: AMD Athlon 64 X2 5200+
    HDD: 500GB Barracuda / 1000GB Spinpoint f1
    Memory: 4GB (4*1GB) DDR2-800
    Motherboard: AsRock MicroATX A785GMH/128M
    Video Card: Radeon HD 4200 onboard + Sapphire Radeon HD 5570 512MB GDDR5 Arctic Cooling
    Video Card Driver: ccc 11.1
    Sound Card: onboard VIA
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Hauppauge WINTV hvr 2200
    1. TV Card Type: DualHybrid DVB-T/Analog (nur analog genutzt)
    1. TV Card Driver: 7.9.1.28162
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: Microsoft
    MPEG2 Audio Codec: none (noch im Testmodus)
    h.264 Video Codec: none (noch im Testmodus)
    Satelite/CableTV Provider: Kabel Deutschland Analog
    HTPC Case: Antec Fusion v2 silber
    Cooling: Scythe Shuriken
    Power Supply: built-in Antec Powersupply
    Remote: MCE der TV-Karte
    TV: Toshiba 42RV555D
    TV - HTPC Connection: HDMI 1.3

    Hallo, Community!

    Ich habe das Probelm, meinen Rechner nicht in den S3/S4/S3+S4 versetzen zu können:

    Nach vielen Stunden Testen (erst unsystematisch, dann etwas systematischer) konnte folgendes festgestellt werden:

    Der Versursacher aller Probleme ist die Kombination: StreamedMP (wohl eines der Plugins - denke ich) + UMTS Stick (incl. mwconn 5.7). Ist der Stick abgezogen, fährt der Rechner normal in HybridS3 (und alles andere, was ich will) und wacht normal wieder auf (reinit der TV-Karte über Powerscheduler++ funktioniert - hier muss ich noch testen, ob das überhaupt notwendig ist).

    Läuft mwconn (und Opera) aber nicht MP mit StreamedMP, geht der Rechner ebenfalls in den Ruhezustand/Standby.

    Läuft mwconn (und Opera) und MP aber OHNE StreamedMP, geht der Rechner ebenfalls in den Ruhezustand und wacht funktionsfähig wieder auf.

    Läuft mwconn und MP mit StreamedMP wird der Ruhezustand/Standby zwar eingeleitet, aber der Vorgang durch den Stick unterbrochen. Der Rechner wacht noch im Prozess wieder auf und die TV-Karte (und manchmal die Oberfläche von MP) reagieren nicht mehr.

    Folgendes wurde unternommen: Im Gerätemanager den COM-Ports des UMTS-Sticks sowie dem 3G-Modem das Recht entzogen, aus Standby/Ruhezustand aufzuwecken (wird ignoriert + Häkchen erscheinen nach Neustart immer wieder), auf Board Wake-on -USB-PS2 weggejumpert (keine Veränderung - Copyright des Worts "weggejumpert" bei mir!), Rechner kann Huawei-Modem ausschalten um Energie zu sparen angeschaltet (kein Effekt), in mwconn "Bei PC Standby beenden" enabled (kein Effekt).

    Bei allen Tests wurde der Standby/Hybrid/Ruhezustand mittels MP im Menü ausgelöst.

    Hat noch jemand diese Kombination und kann das Problem bestätigen? Kennt jemand einen Workaround? MP vor Standby beenden und Neustarten nach Resume sollte das letzte Mittel sein.

    Ich werde diesen Thread auch noch in einem StreamedMP-Forum öffnen, falls ich ein solches finde, um die Chancen zu erhöhen.

    Grüße



    Azarath
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Ponyriemen
    • Premium Supporter

    Ponyriemen MP Donator

    Joined:
    July 9, 2007
    Messages:
    2,570
    Likes Received:
    111
    Gender:
    Male
    Location:
    /root/home
    Ratings:
    +111 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    im BIOS mal geschaut? Kann sein, dass Du da sowas wie "wake on USB" oder sowas findest, das auch mal deaktivieren, dann sollte es gehen.

    P.S.: "weggejumpert". lol
     
  4. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    Danke, aber njet, gibbet nich bei AsRock (neuestes Bios 1.30)... Besser als mit dem Jumper kanns ja eh nicht eingestellt werden - das Problem scheint zu sein, dass er gar nicht ganz ausgeht - da weckt ihn StreamedMP mit irgendeiner Anfrage an den Stick schon wieder...

    Grüße

    Azarath
     
  5. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    Update: Nun wird's komisch!

    Nachdem ich die Wake-Up-Funktion des Sticks mithilfe Power Options and Sleep Mode Problems - Vista Forums STEP5 deaktivieren konnte (cmd als Admin - wusste gar nicht, dass das geht...).

    Ergebnisse: Der Rechner geht in den Standby/Ruhezustand, genau wie er soll und wacht auch daraus auf... Aber "Keine freie TV-Karte verfügbar"!

    Workouts: MP und/oder TVS beenden/restarten, Erkennen der TV-Karte hochgesetzt, reinit TVS... Kein Erfolg. Nach dem Wake-Up ist UND bleibt die TV-Karte weg...

    ABER: Wenn der UMTS-Stick nicht dran ist, funktioniert alles problemlos! Sogar ohne Einstellungen ala "Beenden/Neustarten/reinit/etc."!

    Die Logs sind (für mich als Nichtfachmann) sauber.

    Seltsam: Hat MePo kein Internet, juckt das nach dem Standby anscheinend nicht und alles funktioniert. Hat MePo kein Internet (mwconn lädt nicht neu - werde ich testweise mal per Win7-Taskplanung aktivieren) ABER einen UMTS-Stick, findet er die TV-Karte nicht (Logs von MePo und TVS sauber)!

    Ist dieses Verhalten bekannt? Ich find's absurd... Riecht am ehesten nach nem Bug einer der TVS-Komponenten - würde auf MySQL tippen...

    Kann jemand helfen?

    Grüße

    Azarath
     
  6. Ponyriemen
    • Premium Supporter

    Ponyriemen MP Donator

    Joined:
    July 9, 2007
    Messages:
    2,570
    Likes Received:
    111
    Gender:
    Male
    Location:
    /root/home
    Ratings:
    +111 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    das ist tatsächlich sehr seltsam. Hast Du ne Möglichkeit den Stick mal über nen "Umweg" anzuschliessen per Hub oder USB-Karte oder so? Anderen Port schonmal probiert? Klingt komisch, aber wundern würde mich jetzt gar nichts mehr. ;)
     
  7. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    Ich werd's mal testen, glaube aber nich, dass es daran liegt... Wirklich etwas absurdes Verhalten...

    Btw., Deiner Anleitung in der Sig entnehme ich, dass Du 4TR nutzt!?! Könnte das meine Probleme umgehen? Gibt's da Erfahrungen mit AnalogTV aus ner Hauppauge mit HW-Encoder? (Is' doch richtig - das ersetzt den TVS; auch wenn man das ganze Online-Gedöns ala Webclient nicht will?!?)

    Grüße

    Azarath
     
  8. Ponyriemen
    • Premium Supporter

    Ponyriemen MP Donator

    Joined:
    July 9, 2007
    Messages:
    2,570
    Likes Received:
    111
    Gender:
    Male
    Location:
    /root/home
    Ratings:
    +111 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    im Moment nutz ich das nicht mehr, aber ja, kommt auf den versuch an.
     
  9. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    So, nach ewigem Test und Image-Aufspielen bis nachts um 2:

    Reproduzierbar ist folgendes Verhalten: Hat MePo vor dem Stnadby keinen Internetzugang durch eine per mwconn eingerichtete Verbindung, kommt die Karte und MePo problemfrei aus allen Energiesparzuständen.
    Wird mwconn auf den Power-Troubleshooter mit einem Delay von 1 Minute getriggert (nach Standby/Ruhezustand/Hybrid, bei dem vorher KEINE Internetverbindung bestand) und bekommt dann sozusagen "im Betrieb" spontan Internet, verrichtet es weiter normal seine Arbeit und zeigt zusätzlich das Wetter und die voreingestellten RSS-Feeds an.
    Hatte MePo jedoch vor dem Standby Internet per mwconn und ist dieses nach dem Wake-Up nicht verfügbar, wird keine TV-Karte gefunden.
    In keinem der Fälle wurde MP neu gestartet; nur die TV-Karte wurde neu initialisiert.

    Zusammenfassend: Hatte MePo vor Suspend Internet und nach Wake-Up keines mehr, kommt die Meldung "Keine freie TV-Karte verfügbar" oder hängt sich auf. Hatte es vor Suspend kein Internet und nach Wake-Up kein Internet, funktioniert alles einwandfrei. Bekommt MePo im Betrieb irgendwann (egal, ob nach einem Suspend oder nach einem Neustart) eine Internetverbindung funktioniert alles tadellos und die "neue" Verbindung wird genutzt.

    Ist dieses Verhalten bekannt? Da ich nur die Möglichkeit des UMTS-Sticks habe, bin ich leider auf eine Lösung angewiesen (ja, auch auf das Internet als solches bin ich angewiesen). Kann jemand helfen, bzw. weiß jemand, wie man dieses Problem (dass bei steigender Verbreitung von mobilen Internetzugängen noch zunehmen wird) direkt einem Dev meldet/als Bug identifizieren kann (jemand müsste ne Gegenprobe -auch ohne mwconn, einfach vor Wake-Up mal Router ausschalten/Kabel ziehen- machen [man könnte so auch verifizieren, dass es kein UMTS-eigenes Problem ala IP-Vergabe etc.ist])/oder direkt in den Bugtracker aufnehmen?

    Btw., Grundlage der Tests war MP 1.2.0, StreamedMP-1.4.10.2499, mwconn 5.7, CCC 11.1, MySQL.

    Grüße

    Azarath
     
  10. Azarath

    Azarath Portal Member

    Joined:
    January 17, 2011
    Messages:
    47
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    AW: UMTS - kein Standby mit StreamedMP

    So, ich gebe auf...:mad: Ewiges Basteln hat nichts gebracht; das Problem konnte aber eindeutig als fehlende Netzwerkverbindung nach dem Standby identifiziert werden... Den UMTS-Stick kann man nun mal nicht schneller initialisieren...

    Habe TP-Link TL-MR3420 Netzwerk WLAN Router: Amazon.de: Computer & Zubehör erworben und hoffe, das Problem damit zu lösen... Muss die SSD noch warten...

    Grüße

    Azarath

    Btw.; Schade, dass es so wenig Feedback gab! Hat hier niemand einen UMTS-Anschluss?
     
  11. diskeeper

    diskeeper Portal Pro

    Joined:
    January 5, 2007
    Messages:
    6,109
    Likes Received:
    400
    Gender:
    Male
    Location:
    Dortmund
    Ratings:
    +417 / 0
    Home Country:
    Germany Germany
    Show System Specs
    AW: UMTS - kein Standby mit StreamedMP

    probiere doch mal folgendes,
    installiere den ms-loopback-adapter, Loopback Adapter und Media Sense unter Windows XP einrichten :: network lab
    und stell in der mp-config u. der tvserver-config die ip des loopback als feste ip ein.

    könnte mir vorstellen das dir das bei deinem problem weiterhilft da durch den adapter eine pseudo-netzwerkkarte
    bzw. verbindung für mp erstellt wird. die eigentliche internetanbindung wird davon nicht beinträchtigt.

    ps: unter win7 funktioniert das einrichten genauso, wenn ich das richtig in erinnerung habe.:rolleyes:
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!