Version 0.2.0.1 beta 2 | Page 2

Discussion in 'ASIO music player' started by Symphy, October 18, 2008.

  1. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Symphy,

    I am getting crazy now with MediaPortal.

    At the moment, I am not getting any sound at all from the PureAudio plugin.
    I do not have any clue what is causing this.
    When I use the WinAmp plugin, everything works fine. All my flac files work
    fine.

    The strange thing is that my AC3Filter, which I use for DVDs does not work
    for PCM audio as well. AC3 and DTS are played well, but when a DVD has
    PCM Audio, there is no sound from the speakers. In AC3Filter, there is
    an option to convert PCM Audio to AC3. When I select this option there
    is sound.

    It looks like there is some "internal" problem with PCM Audio. However,
    Winamp is playing it well!!!

    Any suggestions what could be causing this?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hello Mark!

    Please send your Logfiles and fill out your Systemspecifications. Then it's much easier to help!

    @ Symphy

    Problem is the Receiver!

    Yamaha Manual

    Best Regards
    Helios
     
  4. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
  5. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yep you're right... not much that can be done about that, except buy a new one :D
    Resampling to 48k is not a perfect solution, but the best we can do at the moment!
     
  6. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Don't see anything unusual in the log, MP plays normally...

    The device used is "Digital Output Device (SPDIF) (2- High Definition Audio Device)" over directx.
    You sure you use the same one in winamp? The device mentioned is probably not windows default device, so winamp may use another if nothing particular has been selected.
    Why this spdif device is silent, i dont know, but i'm sure its a setting or connection somewhere. volume? mute?
     
  7. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Symphy,

    Indeed, the PureAudio plugin used to work on my system. Somehow, something has
    changed and that's the reason why it is not working anymore. It's very strange and
    I do not know what it is. The only thing I do know is that Winamp is able to get sound
    over SPDIFF. I've checked the volume and mute settings. But that's not it.
    I think Winamp uses another API call to control the SPDIFF.

    In Winamp, the output is configured as:

    NullSoft DirectSound Output v2.48 [out_ds.dll]


    The output which I can select in PureAudio is:

    1. Default Sound Device
    2. Digital Output Device (SPDIF) (2- High Definition Audio Device)

    Both of these outputs don't work (anymore).

    Perhaps you can add a third output: DirectSound (which is DirectShow???)
     
  8. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Both devices you see there in pureaudio are DirectSound. (DirectSound is the audio 'department' of DirectX, DirectShow the video stuff)

    The "Default Sound Device" is not a device in itself but refers to the device that is selected through the windows control panel (Sounds and Audiodevices), so you may want to have a look there.

    This means that the spdif thing is the only actual device that is seen by pureaudio. I'm pretty sure there must be another one, somewhere!

    What devices can be selected at (on XP) Control Panel -> Sounds and Audiodevices -> Audio tab -> Default device?
     
  9. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Symphy,

    In Vista, I have the following devices:

    1. Speakers
    Status: Not plugged in
    2. Headphones
    Status: Not plugged in
    3. Digital Output Device (SPDIFF)
    Status: Working
    This is also the default
    4. Digital Output Device (HDMI)
    Status: Disabled
     
  10. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Ok that explains why only spdif is listed in pureaudio. Funny thing is that winamp is probably using that same one too....

    I don't know whats going on there! I would try to figure out what has changed on your system when it stopped working. Or maybe reinstall/update drivers, never know.
     
  11. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    I think (hope) next year! :D

    Thank you for this great Plugin!

    Best Regards
    Helios
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!