Version 0.2.0.1 beta 2 (1 Viewer)

edterbak

Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Netherlands Netherlands
    Country flag
    Symphy, Just to let you know. Im very happy with the plugin right now. Its working perfectly now. :)
     

    mikeyko

    Retired Team Member
  • Premium Supporter
  • February 14, 2008
    194
    49
    Slovakia Slovakia
    Symphy,

    I just bought ATI Radeon 4670 graphics card with 5.1 LPCM support through HDMI. I have ASIO4ALL. I used your plugin before with no problems. I have multichannel FLAC files with music and ASIO playback with your plugin is not working properly.

    Example: 4 channel FLAC file with front and surround channels is playing from front speakers and center. Surrounds are quiet. With foobar2000 ASIO playback works as it should.

    Next problem is, that I can play music only right after I started MediaPortal. After I press stop and then I press play again, I have no sound. It is very strange.

    I will test it more with 5.0 and 5.1 FLAC files, but definitely 4.0 is not working

    Thank's for help!
     

    Symphy

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    150
    Groningen
    Netherlands Netherlands
    Country flag
    Symphy,

    I just bought ATI Radeon 4670 graphics card with 5.1 LPCM support through HDMI. I have ASIO4ALL. I used your plugin before with no problems. I have multichannel FLAC files with music and ASIO playback with your plugin is not working properly.

    Example: 4 channel FLAC file with front and surround channels is playing from front speakers and center. Surrounds are quiet. With foobar2000 ASIO playback works as it should.
    Upmixing from 4.0 to 5.1 is not (yet) supported. (never has though). It will put the surround channels on LFE and center...
    I'll see if i can add 4.0 -> 5.1 upmixing support.
    Next problem is, that I can play music only right after I started MediaPortal. After I press stop and then I press play again, I have no sound. It is very strange.
    Try disabling the skin sound effects (in MP config - General). Many ppl have reported something similar, and it looks like its caused by the skin soundeffect preventing asio4all to get exclusive access to the device. Have not found a good solution for this yet.
     

    mikeyko

    Retired Team Member
  • Premium Supporter
  • February 14, 2008
    194
    49
    Slovakia Slovakia
    Upmixing from 4.0 to 5.1 is not (yet) supported. (never has though). It will put the surround channels on LFE and center...
    I'll see if i can add 4.0 -> 5.1 upmixing support.
    Thank you for your response! I am not sure what you mean by upmixing, I only want correct input channels played in correct output channels. So, with 4.0 FLAC, FL - FL, FR - FR, Center - quiet, LFE - quiet, SL - SL, SR - SR. And please, check 5.0 FLACs too, I suspect Center and LFE are swapped there.

    I can send FLAC examples to you if you wish...
     

    Symphy

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    150
    Groningen
    Netherlands Netherlands
    Country flag
    Thank you for your response! I am not sure what you mean by upmixing, I only want correct input channels played in correct output channels. So, with 4.0 FLAC, FL - FL, FR - FR, Center - quiet, LFE - quiet, SL - SL, SR - SR. And please, check 5.0 FLACs too, I suspect Center and LFE are swapped there.
    Hmm, so no left/right mix on center and LFE? Unless your device or equipment attached to it has its own bassmanagement, you wont have any playback on the subwoofer.

    Adding the channelmapping as you describe is not a problem though.
    I can send FLAC examples to you if you wish...
    Will be helpfull! Don't have 4.0 and 5.0 material available here. Please use some fileshare site and pm me the download link.
     

    Symphy

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    150
    Groningen
    Netherlands Netherlands
    Country flag
    Will be helpfull! Don't have 4.0 and 5.0 material available here. Please use some fileshare site and pm me the download link.
    I sent you PM
    :D
    Have been looking at them. Supporting all these channelmappings properly can be done, but wil require quite some work alltogether. So it won't be in the 0.2.0.1, but i will schedule it for one of the next versions.
     

    mikeyko

    Retired Team Member
  • Premium Supporter
  • February 14, 2008
    194
    49
    Slovakia Slovakia
    Have been looking at them. Supporting all these channelmappings properly can be done, but wil require quite some work alltogether. So it won't be in the 0.2.0.1, but i will schedule it for one of the next versions.
    Thank's Symphy! I will wait for it. Today I can use foobar2000.
    :D
     

    cmbe

    Portal Pro
    March 7, 2008
    59
    1
    Portugal Portugal
    I have been searching for something like this for sooo long, it works like a charm.

    Many thanks for such a great plugin :D
     

    jacc1234

    Portal Pro
    April 11, 2008
    167
    7
    I would like to second the request for multi-channel flac files. During playout I only get stereo but I am able to play DTS wav files correctly. If you need any more 5 channel flac files let me know. Also mikeyko if you could explain how I could use foobar to play them properly for the time being I would appreciate it.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 6
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    caveman [solved] Cannot download new version My TVSeries 5
    ajs [Help Us!] MP1 X64 Version MediaPortal 1 20
    RoChess Splashscreen MePo version Titan Skin Feedback 8
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    D How to switch versions of Schedules Direct Newcomers Forum 2
    D I just installed MP 1.23. Which version of Schedules Direct should I use, where do I obtain it from Newcomers Forum 6
    Z TV-Service in falscher Version Installationsprobleme? 9
    T Neue Treiber Version 3 für TV-Karte Digital Devices Cine C/C2/T/T2 V7 TV / Streaming 6
    M Version numbers MediaPortal 1 Talk 7
    framug LAVFilter 0.74.1 incorrect version Skins and Plugins Installer (MPEI) 8
    A Problem Windows 10 64 bit prof. Update auf Version 1903(gelöst) Installationsprobleme? 0
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    N [Question] How come when I build WIP_2.2.1 the logged version number is 2.1.1711.10774? MediaPortal 2 1
    Lehmden MP2 client for Windows 10 ARM, possible? Maybe an UWP version could do the trick... MediaPortal 2 11
    Symphy Version 0.2.8.5 for MP 1.21 ASIO music player 18
    doskabouter [Question] Versions of subsystems MediaPortal 1 2
    G Best version of mp so far General 4
    T Cross reference version documents General 1
    M.Hulot Moving pictures startet nur im hintergrund und falscher version Allgemeines Supportforum 5
    J Things I noticed with MP2.2 almost within minutes after upgrading it over the 2.13 version General 6
    J New .NET version? General Development (no feature request here!) 0
    Similar threads

























    Top Bottom