[6.0.3] Trakt for MediaPortal [2020-01-01] (1 Viewer)

ajs

Development Group
  • Team MediaPortal
  • February 29, 2008
    11,883
    6,725
    Kyiv
    Ukraine Ukraine
    Country flag
    You already have it enabled, I saw from one of your logs:
    2018-03-04 17:14:14.844 [INFO] [Sync][06]: My Videos Starting Library Sync
    2018-03-04 17:14:15.014 [INFO] [Sync][06]: There are 0 unwatched movies since the last sync with trakt.tv
    2018-03-04 17:14:15.016 [INFO] [Sync][06]: Getting current user watched movies from trakt
    2018-03-04 17:14:15.019 [INFO] [Sync][06]: There are 2532 watched movies in trakt.tv library
    2018-03-04 17:14:15.022 [INFO] [Sync][06]: Getting current user collected movies from trakt
    2018-03-04 17:14:15.025 [INFO] [Sync][06]: There are 992 collected movies in trakt.tv library
    2018-03-04 17:14:15.028 [INFO] [Sync][06]: Getting current user rated movies from trakt
    2018-03-04 17:14:15.031 [INFO] [Sync][06]: There are 2287 rated movies in trakt.tv library
    2018-03-04 17:14:15.051 [INFO] [Sync][06]: Found 17 movies available to sync in My Videos database
    2018-03-04 17:14:15.054 [INFO] [Sync][06]: Found 15 watched movies available to sync in My Videos database
    2018-03-04 17:14:15.057 [INFO] [Sync][06]: Found 15 rated movies available to sync in My Videos database
    2018-03-04 17:14:15.250 [INFO] [Sync][06]: Finding movies to add to trakt.tv watched history
    2018-03-04 17:14:15.264 [INFO] [Sync][06]: Adding 0 movies to trakt.tv watched history
    2018-03-04 17:14:15.268 [INFO] [Sync][06]: Finding movies to add to trakt.tv collection
    2018-03-04 17:14:15.277 [INFO] [Sync][06]: Adding 0 movies to trakt.tv collection
    2018-03-04 17:14:15.280 [INFO] [Sync][06]: Finding movies to add to trakt.tv ratings
    2018-03-04 17:14:15.286 [INFO] [Sync][06]: Adding 0 movies to trakt.tv ratings

    2018-03-04 17:14:15.291 [INFO] [Sync][06]: My Videos Library Sync Completed
    strange, maybe this is some kind of a test version? you did not give me for testing? I did not include anything :) but it is not important. the main thing is that it was in the new version.

    --
    WBR, ajs :):whistle::coffee:
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,697
    7,081
    Sydney
    Australia Australia
    Country flag
    Its available in the official release. The setting that enables it has been there for years, as its used for tvseries and movpics rating sync as well. I can't remember what release, but I implemented for My Videos. Just make sure the following checkbox is enabled as seen in screenshot.
     

    Attachments

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,697
    7,081
    Sydney
    Australia Australia
    Country flag
    New release available:

    v6.0.2
    • Added new Audio codecs (DTS-X, ATMOS, DD+) to MovingPictures collection sync. Requires updated MovingPictures to support sending new codecs;
    • Added support to view Comments on Lists;
    • Added support for Liked Lists (see Titan skin);
    • Added support for Trending and Popular Lists (see Titan skin);
    • Added 'CommentCount' property to Movie, Show and Episode objects;
    • Updated Titan skin to support Liked, Trending and Popular Lists;
    • Fixed Cast and Crew context menu items not working from Custom Lists;
    • Fixed issues with thread safety in image download handling, should resolve any related crashes;
    • Fixed skins incorrectly showing page related properties when leaving window and entering another which does not support paging;
    • Fixed a few issues when copying lists;
    • Fixed issue where My Videos watched sync did not set the correct watched date in the database;
    • Fixed rate dialog opening before directshow graph is released after playing back fullscreen video. This lead to a MP freeze in some situations. Thanks to Sebastiii for patch.
     

    MrGrymReaper

    MP Donator
  • Premium Supporter
  • July 28, 2009
    25
    14
    United Kingdom United Kingdom
    @Itfearme - Your plugin is no longer able to access the API. It every time gives an error of "503 - Bad Gateway". I by looking quickly noticed that it is attempting to access via "http://api.trakt.tv". This address is no longer available for the API it needs to access "https://api.trakt.tv/" as part of attempt instead. This is the new address for the API.

    Please provide an update which fixes this. It hopefully should be a fairly simple fix if you are already compatible with the V2 API. Just swap out the http Trakt api calls with https ones.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Until 8 Jan 2019, Trakt is working on my side :) (didn't test today the 11th)
    Are you sure you correctly enable it? (from MP config)
    Here:
    upload_2019-1-11_7-43-27.png


    It's my dev PC so plugin is not up to date but on my HTPC it is and working :p
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,697
    7,081
    Sydney
    Australia Australia
    Country flag
    No problem here, please try re-authorise the application with trakt.tv as per above example, you can revoke and authorise if it thinks it's already authorised.

    Also if you want SSL you can enable in the advanced configuration GUI if you have the extensions plugin installed, otherwise you can edit the MediaPortal.xml and change the following setting from no to yes:
    Code:
    <entry name="UseSSL">yes</entry>
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,344
    1,824
    Country flag
    I had to do the same last month, as it seems Trakt went through some early spring cleaning on authorizations.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,504
    1,707
    Nuenen
    Netherlands Netherlands
    Country flag
    No problem here, please try re-authorise the application with trakt.tv as per above example, you can revoke and authorise if it thinks it's already authorised.

    Also if you want SSL you can enable in the advanced configuration GUI if you have the extensions plugin installed, otherwise you can edit the MediaPortal.xml and change the following setting from no to yes:
    Code:
    <entry name="UseSSL">yes</entry>
    Did that a while ago, but apparently it breaks onlinevideos for some sites.
    Traced it back to the cause and it's because you are setting ServicePointManager.SecurityProtocol to SecurityProtocolType.Tls.
    Surprised that the trakt site still supports this, but other sites (for f.e. onlinevideos) need TLS1.1 or even TLS1.2
    Also the need to set Expect100Continue to true is not needed anymore (at least for mediaportal) because it already has this value.
    So in my opinion it's best to leave both properties as they are and just connect to trakt with the given url.

    Pull request made: Fixed unwanted SecurityProtocol side-effects by doskabouter · Pull Request #119 · trakt/Trakt-for-Mediaportal
    I'm going to deploy this to my prod. system and see if something is going to act up
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    Lichloathe Trakt for MP2 question General 7
    ajs Trakt error when start with MP crash Trakt 1
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    fischy667 wrong/no sync with trakt on some series Trakt 2
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    Similar threads

























    Top Bottom