After resuming from hibernation, DVB-T stutters badly (1 Viewer)

igalan

Retired Team Member
  • Premium Supporter
  • June 30, 2005
    406
    20
    Barcelona
    Spain Spain
    varesino said:
    One question for Igalan: do you have the my same problem as described in my second post of this tread:

    http://www.testteam-mediaportal.com/Joomla/forum/showthread.php?t=629

    If yes probably the two issues are related.
    I can edit both card properties any time (and scan for channels), so no problem here (this is the issue you ask for, isn't it?). I'm usually running the latest SVN, because a lot of work is being put into bugfixing lately :) .
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    igalan said:
    varesino, your findings are interesting. If it stutters with other software, a driver bug would cause this behaviour, but then why only closing and reopening the program fixes the problem?
    this idicates that the application is not able to release the hook before hibernate correctly or during the initialisation of the TV-Card after hibernate something goes wrong.

    If it would be a driver bug a restart of the application wont fix the issue.
    And if it would be a driver issue the issues would also occur if the application is not runing before hibernate and manually started after resume. which is not the case as varesino reported.
     

    varesino

    Portal Member
    January 18, 2005
    38
    0
    Europe
    igalan said:
    I can edit both card properties any time (and scan for channels), so no problem here (this is the issue you ask for, isn't it?). I'm usually running the latest SVN, because a lot of work is being put into bugfixing lately :) .

    Yes, it is the issue I'm referring to. This means that the two problem are not related and that I have something to check in my config.

    Thanks for your answer.
     

    MediaTobiPortal

    Portal Pro
    December 13, 2004
    206
    6
    120
    If a restart of MP helps, the problem would be solved, if we could "learn" PowerScheduler to restart MP after waking up from standby/hibernate. I think this would solve many future problems caused by any unknown issues. Even Driver Problems could be solved, if we "learn" PowerScheduler to restart windows after waking up.

    So I´d love a feature in PowerScheduler that allows us to run a batch or script after waking up.

    I`ve written a windows- service, that checks the MediaPortal log file and if this service "sees", that the PC has been in standby/hibernate the PC is restarted and MP then is autostarted again. I had to do this, because my PVR 250 wasn´t working after wake up (now solved driver issue). My problem was solved that time, but as this service was a little bit unstable, quite hard to install and the driver problem is gone, I stopped working on it.
     

    varesino

    Portal Member
    January 18, 2005
    38
    0
    Europe
    Mediatobiportal,
    an alternative to your proposal already exist, it's PVR Scheduler, but, unfortunately, also this program have problem with the latest SVN version of Mediaportal. (I have a post open on that site).

    PS. During the tests of the bug described in this tread PVR Scheduler was not installed.
     

    MediaTobiPortal

    Portal Pro
    December 13, 2004
    206
    6
    120
    Yes, I know PVR-Scheduler an its features, but I don´t want to install PVR Scheduler. I´d prefer to use PowerScheduler only, as it works perfect.....
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    PVR-Scheduler could be used as workaround, but it seems that this is a mediaportal bug that needs to be fixed.
     

    igalan

    Retired Team Member
  • Premium Supporter
  • June 30, 2005
    406
    20
    Barcelona
    Spain Spain
    1. turn off mediaportal autostart
    2. re-start the PC
    3. start MediaPortal
    4. go to MyTV
    ---Video: playing
    ---Audio: playing
    ---note:
    5. quit MediaPortal
    6. manually hibernate the PC (start -> shut down -> hibernate)
    7. resume the PC from hibernate
    8. start MediaPortal
    9. go to MyTV
    ---Video: playing
    ---Audio: playing
    ---note:
    10. quit MediaPortal
    11. manually hibernate the PC (start -> shut down -> hibernate)
    12. resume the PC from hibernate
    13. start MediaPortal
    14. go to MyTV
    ---Video: playing
    ---Audio: playing
    ---note:
     

    igalan

    Retired Team Member
  • Premium Supporter
  • June 30, 2005
    406
    20
    Barcelona
    Spain Spain
    Here're the logs for the second test. As expected video stutters real bad (most of the time you get black picture and every once in a while a frame ca be seen); audio also stutters, but not so much.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S Resume Playback Annoyance Newcomers Forum 4
    joecrow MP 1 Hangs on resume fro sleep (TV) Watch / Listen Media 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    stirlinghart [duplicate] Mp not focused on after resuming from sleep 2.2 Archive 7
    P Multiple clients - share resume/watched data General 1
    stirlinghart FOCUS not on MP after resuming from sleep General 11
    U IR Blaster doesn't work after system wake/resume General Support 6
    megahorst Mediaportal chrashs when the PC goes to suspend mode (or when it resumes?) 1.19 11
    joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
    emphatic Mediaportal sends Windows into hibernation without being setup to do so MediaPortal 1 Talk 21
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    R Suggestions for reliable PCIe DVB-S2 tuner MediaPortal 1 Talk 8
    Golf4 DVB-IP über Fritzbox - m3u-Senderliste Allgemeines Support- und Diskussionsforum 43
    Similar threads

























    Top Bottom