aMPdroid 1.1 - MediaPortal für Android | Page 14

Discussion in 'Plugins & Erweiterungen' started by DieBagger, November 30, 2012.

  1. Golf4

    Golf4 Portal Pro

    Joined:
    August 18, 2006
    Messages:
    2,695
    Likes Received:
    139
    Location:
    Dunkeldeutschland
    Ratings:
    +214 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Ok, mit dem AMD405e ?
    Und wenn du mit Win7 aufs MP-Web gehst, wie siehts da aus?
    Habe mal versucht von extern mit einem Win7-PC zu streamen aber da gings nur in Gruselauflösung.
    Das gleiche aber ach im internen Netzwerk - ich denke da muß ich noch was am WHS machen. Vielleicht fehlen da irgendwelche Codecs (?).


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. diskeeper

    diskeeper Portal Pro

    Joined:
    January 5, 2007
    Messages:
    6,109
    Likes Received:
    400
    Gender:
    Male
    Location:
    Dortmund
    Ratings:
    +417 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Der stream auf das handy wird durch die geschwindigkeit vom upload und der mobilen datenverbindung limitiert,
    da nutze ich deshalb ffmpeg medium.

    Habe den htpc grad ganz frisch aufgesetzt und der einzige codec den ich zusätzlich installiert habe,
    ist der lavf.
     
  4. eronix

    eronix New Member

    Joined:
    February 5, 2014
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    nabend,

    eine Frage bezüglich der aMPdroid App. Sobald ich die App gestartet und erfolgreich verbunden habe, befinde ich mich ja in der Ansicht, in der links die sechs Kategorien zusehen sind und rechts die drei Slide Menüs Filme, Serien und Aufnahmen zu finden sind.

    Bei mir jedoch steht bei allen drei der Hinweis "Plugin nicht am Server verfügbar". Auch wenn diese Plugins vielleicht nichts mit der App zu tun haben, wüsste ich gerne wo ich diese Plugins herbekomme und wohin sie installiert werden müssen.

    Ich habe bereits in der MP Config nachgeschaut und dort natürlich auch den Eintrag Plugins gefunden. Aber, bin ich da richtig frage ich mich? Auch den MP Extensions Manager habe ich offen, sind dort die geforderten Plugins zu finden?

    greetz
    eronix
     
  5. RicoHTPC
    • Super User

    RicoHTPC Super User

    Joined:
    February 4, 2011
    Messages:
    1,441
    Likes Received:
    97
    Location:
    Cuxhaven
    Ratings:
    +178 / 6
    Home Country:
    Germany Germany
    Show System Specs
    Dafür brauchst du zuerst mal den MP Client Teil auf deinem Server. Dann wirst du auch die Plugins,
    bzw. wie am Beispiel von Videos, standard Datenbanken nutzen können.
     
  6. eronix

    eronix New Member

    Joined:
    February 5, 2014
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    hi,

    kannst du das etwas näher ausführen? Den MP Client habe ich auf meinem Rechner, klar, sonst würde ich es ja nicht starten können. MP habe ich ohne die TV-Komponente installiert und einen Server benutze ich nicht, falls das relevant ist.

    greetz
     
  7. RicoHTPC
    • Super User

    RicoHTPC Super User

    Joined:
    February 4, 2011
    Messages:
    1,441
    Likes Received:
    97
    Location:
    Cuxhaven
    Ratings:
    +178 / 6
    Home Country:
    Germany Germany
    Show System Specs
    Du hast also ein Single Seat System ohne TV Server, richtig?
    Und auf dem PC hast du MP und MPextended? Dann müsstest du auch diese Funktionen nutzen können.
    Mit Plugins sind in diesem Zusammenhang die Video und Musik Datenbanken gemeint, sowie die
    MP Plugins TV Series und Moving Pictures. Beide Plugins fndest du im MP Extension Installer, die anderen sind
    ohnehin Kern-Features von MP.
     
  8. eronix

    eronix New Member

    Joined:
    February 5, 2014
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    nabend,

    Ganz genau.


    Die beiden Plugins habe ich per Extension Installer installiert und testweise ein paar Filme hinzugefügt (Moving Pictures). Leider steht im Hauptmenü der App und wenn ich direkt auf Filme tippe immernoch Plugin am Server nicht verfügbar. Den MPextended Dienst habe ich bereits neu gestartet. Auch im MP Client selbst habe ich bereits einen Ordner in denen die Filme liegen hinzugefügt. Dieser lässt sich allerdings ohne Probleme mittel App ansteuern, allerdings nur wenn ich bereits in der "Steuerung" drin bin, also die geteilte Ansicht (Fernbedienung links - Optionen zum Auswählen rechts).


    edit: (07.02.14)

    Nachtrag,

    heute nach dem Starten von App und dem MPExtended Service, werden die Filme angezeigt die ich zuvor in den Einstellungen von Moving Pictures der DB hinzugefügt habe. Das funktioniert also endlich, Auch streamen funktioniert bisher ohne Probleme.

    Apropos Probleme, das alles funktioniert allerdings ohne das sich die App mit dem Client verbunden hat (rote Anzeige unten rechts). Läuft das stattdessen über diese andere App, Wifi Remote? Na jedenfalls erscheint die Meldung "Verbindung konnte nicht hergestellt werden" sobald ich "Remote Verbinden" antippe.

    Ohnehin funktioniert das Verbinden recht sporadisch, mal muss ich erst MP starten und eine Weile warten dann verbindet er von selbst, mal gehts garnicht. Gibts eine bestimmte Reihenfolge die man beachten muss? Reicht es wenn der MP Extended Service gestartet ist oder muss MP Extended auch noch gestartet sein?
    Warum verbindet er nicht beim Tippen auf "Remote Verbinden"?

    greetz
     
    Last edited: February 7, 2014
  9. Golf4

    Golf4 Portal Pro

    Joined:
    August 18, 2006
    Messages:
    2,695
    Likes Received:
    139
    Location:
    Dunkeldeutschland
    Ratings:
    +214 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Mal ne zwischenfrage,
    reicht es nicht die Thumbs und DBs auf dem Server abzulegen u. zu verlinken - ohne Client-Install ?
    (Videos, TV-Records, Musik, Bilder liegt natürlich schon auf dem Server)
     
  10. sonnybonds

    sonnybonds Portal Pro

    Joined:
    December 3, 2008
    Messages:
    85
    Likes Received:
    3
    Ratings:
    +9 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hallo,

    hat noch jemand einen Tipp zu dem Problem mit dem Musik-Streaming. Auch bei mir versucht er das als Video abzuspielen.
    Wie Tomchieur habe ich schon die Extensions in Musik- und Videodatabase geprüft, scheint OK zu sein, aber weder mp3 noch flac funktioniert. Videos und TV dagegen ohne Probleme.
    Habe keine Ahnung was ich noch tun soll. Wäre echt dankbar um jeden Tipp!

    Zur Info, falls das irgendwie hilft:
    Samsung Galaxy Pad GT-P1000 (Das Original) mit Android 2.3.6
    MP Version 1.2.3, MP Extended 0.5.4

    Die Logs von MPExtended sagen:
    014-03-19 20:17:36.14031 [(17)] WARN: Failed to extract image to temporary file C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg with executable=C:\Program Files\MPExtended\Service\Streaming\ffmpeg.exe arguments=-ss 10 -i "H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3" -vframes 1 -vf "yadif,scale=ih*dar:ih" -f image2 "C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg"
    2014-03-19 20:17:47.91398 [(28)] WARN: Failed to extract image to temporary file C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg with executable=C:\Program Files\MPExtended\Service\Streaming\ffmpeg.exe arguments=-ss 10 -i "H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3" -vframes 1 -vf "yadif,scale=ih*dar:ih" -f image2 "C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg"
    2014-03-19 20:17:48.15600 [(27)] WARN: Failed to extract image to temporary file C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg with executable=C:\Program Files\MPExtended\Service\Streaming\ffmpeg.exe arguments=-ss 10 -i "H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3" -vframes 1 -vf "yadif,scale=ih*dar:ih" -f image2 "C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_10.jpg"
    2014-03-19 20:17:53.26429 [(27)] WARN: Failed to extract image to temporary file C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_0.jpg with executable=C:\Program Files\MPExtended\Service\Streaming\ffmpeg.exe arguments=-ss 0 -i "H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3" -vframes 1 -vf "yadif,scale=ih*dar:ih" -f image2 "C:\ProgramData\MPExtended\Cache\imagecache\extract_File-9-fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz-Content-0_0.jpg"
    2014-03-19 20:17:53.53331 [(29)] INFO: Called InitStream with type=File; provider=9; itemId=fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz; offset=0; clientDescription=aMPdroid; identifier=aMPdroid.-323603546.ts; idleTimeout=
    2014-03-19 20:17:53.69431 [(29)] DEBUG: Called StartStreamWithStreamSelection with ident=aMPdroid.-323603546.ts; profile=Android FFmpeg HD; start=0; audioId=-1; subtitleId=-2
    2014-03-19 20:17:53.72332 [(29)] DEBUG: StartStream with identifier aMPdroid.-323603546.ts for file mediatype=File provider=9 id=fs2_QWxiZW4sIFNpbmdsZXMsIFNvdW5kdHJhY2tzXF9NdXNpY2Fsc1xDYXRzIC0gMTk4M1wwMSAtIFByb2xvZyBKZWxsaWNsZSBLYXR6ZW4ubXAz filetype=Content offset=0 path=H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3
    2014-03-19 20:17:53.97633 [(29)] DEBUG: Using 1280x720 as output size for stream aMPdroid.-323603546.ts
    2014-03-19 20:17:53.99133 [(29)] DEBUG: Final stream selection: audioId=0, subtitleId=
    2014-03-19 20:17:54.05534 [(29)] INFO: Assembling following pipeline:
    2014-03-19 20:17:54.05534 [(29)] INFO: data 5: MPExtended.Services.StreamingService.Units.EncoderUnit (input False, data True, log True)
    2014-03-19 20:17:54.05634 [(29)] INFO: log 6: MPExtended.Services.StreamingService.Units.FFMpegLogParsingUnit
    2014-03-19 20:17:54.05634 [(29)] INFO: logconn 5 -> 6
    2014-03-19 20:17:54.05934 [(29)] INFO: Encoding: starting output named pipe \\.\pipe\97fc3953-027e-4106-9e0a-284d82e07397
    2014-03-19 20:17:54.07434 [(29)] INFO: Encoder: Transcoder configuration dump
    2014-03-19 20:17:54.07434 [(29)] INFO: Encoder: hasStdin False, hasStdout False, hasStderr True
    2014-03-19 20:17:54.07434 [(29)] INFO: Encoder: path C:\Program Files\MPExtended\Service\Streaming\ffmpeg.exe
    2014-03-19 20:17:54.07434 [(29)] INFO: Encoder: arguments -y -i "H:\AUDIO\Alben, Singles, Soundtracks\_Musicals\Cats - 1983\01 - Prolog Jellicle Katzen.mp3" -s 1280x720 -aspect 1280:720 -map v:0 -map a:0 -codec:v libx264 -b:v 1768k -profile:v baseline -preset:v faster -coder rle -codec:a aac -b:a 512k -ac 2 -strict experimental -async 1 -sn -f mpegts "\\.\pipe\97fc3953-027e-4106-9e0a-284d82e07397"
     
  11. Babba123
    • Premium Supporter

    Babba123 MP Donator

    Joined:
    December 22, 2007
    Messages:
    100
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi. Ich habe das Problem, dass ich mit ampdroid nicht auf meine Musik zugreifen kann. Ich habe einen funktionierenden Zugriff auf TV, Filme, Serien und Videos. Nur die Musik funktioniert nicht. Die Datenbank habe ich aufgebaut. MPExtended schaut auf die korrekte Datenbank-Datei.
    Beim Zugriff auf "Musiker" steht seltsamerweise kurz "Lade Videos" da. Angezeigt wird dann gar nicht nichts. Warum da kurz "lade Videos" steht ist mir auch schleierhaft.

    Ebenfalls habe ich das Problem, dass ich nicht auf meine Videodateien zugreifen kann, die auf dem NAS liegen. Das heißt dass ich meine Videos aus der Datenbank angezeigt bekomme, die ich mit dem Plugin MovingPictures erstellt habe, aber wenn ich auf den Menüpunkt "Shares" gehe und dann den Pfad aufrufe der auf dem NAS liegt mir ein leerer Ordner angezeigt wird. Ich habe bereits gelesen, dass man am besten in MediaPortal nicht mit Laufwerksmappings arbeiten sollte, sondern lieber den kompletten UNC-Path angeben soll. Das habe ich bereits getan !
    Statt dem Laufwerk M: (auf dem meine Musik liegt) habe ich die IP \\192.xxx.xxx.xx\video angegeben. Der Zugriff in MediaPortal über das "Hauptmenü -> Videos" auf den o.g. UNC-Path funktioniert einwandfrei !

    Firewall-Probleme habe ich ausgeschlossen, da ich die Firewall bereits testweise deaktiviert hatte.

    Die Logs geben keinen Aufschluss darüber warum der Zugriff nicht funktioniert.

    Habt ihr eine Idee warum ich in ampdroid gar nicht auf meine Musik komme ? Weder über die Kategorien (Musiker etc) noch über die "Shares" ?
    Habt ihr eine Idee warum ich nicht auf meine Videos komme wenn ich in ampdroid bei den Videos die "Shares" wähle ?

    Ich könnte mir denken, dass es Zugriffsrechts-Probleme sein könnten. Nur wo sollen die konfiguriert werden, wenn der Zugriff über MediaPortal direkt einwandfrei funktioniert !
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!