[Android] aMPdroid 0.8 - Streaming and more (2 Viewers)

750913372

Portal Pro
June 25, 2009
52
15
Bruxelles
Belgium Belgium
Hi,
I've installed aMPDroid on galaxy tab 10.1v on Android 3.0 and it works like a charm (just have to close properly the app before to quit it otherwise it crashes).

Just one question: is it possible to display the music artist (and album) in the now-playing screen. Currently, I just have the track name.

Thank you.
 

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,466
    4,634
    45
    ::1
    Netherlands Netherlands
    Country flag
    I'm lost....

    I just can't seem to get a connection from my phone (Samsung Galaxy S2) to my HTPC.
    I've tried troubleshoot section, and all seems ok.
    - The test links are working
    - Set login for GmaWebService to right user (all content is on remote shares)
    - Checked firewall settings (all good)

    When i startup WifiRemote Client Demo, it detects the server and connects without a problem. Checked logs, but no errors to be found :(

    Anybody any idea what could be the problem??

    ** EDIT **
    Some strange things happening. When i use the Demo Client, it shows the detected server (called 'HTPC'). I can connect to that, also when i enter HTPC:8017 for manual connect, but when i enter that info in aMPDroid, it can't connect to remote :(
    When i enter the IP adress in Demo Client manual connect, it won't connect @ all.

    ** EDIT 2 **
    Indeed strange stuff... I just updated MP, started aMPDroid again on my phone and everything is working :eek: (so far)
     

    Rob99

    Portal Member
    September 12, 2010
    8
    0
    Discovered this remote today and it's quite cool.
    I have two questions:

    1) I'm not able to stream videos to my phone... When it opens in phones Streaming Media Player, it says "Sorry, this video cannot be played".
    Could it be because I have "baby android" i.e. HTC Wildfire (it's display is smaller, processor and RAM weaker)?

    2) Is it somehow possible to remove 'Home' button from remote screen? Again, as I'm using HTC Wildfire, it's display is smaller and 'Home' and 'Down' buttons overlap and it's very hard to tap the right one.


    But overall great job... Thank You!
    Hope that music streaming function will appear sometime soon.
     

    nissse

    Portal Member
    September 27, 2006
    15
    0
    41
    Sweden Sweden
    Hello

    Is there anyone that can help me troubleshoot.
    I have tried to get this to work for weeks now witout any success.

    This is my setup:
    1 TV Server + MP
    2 TV Clients

    Now for the problem:
    In aMPdroid when I click on TV and recordings selecting "Play on PC" I only get the sound and no picture. I can still navigate as normal in MP and the sound of the recorded tv is in the background. It is the same for all 3 clients.
    Have tried changing codecs and video render mode.
    Playing recorded tv works as normal using a local remote.

    Troubleshooting from here Troubleshooting - MediaPortal Wiki is all returning good and working

    trying the same from videos instead of recorded tv works good.

    Any ides ?
    I love the app and really like to get all the functions working.
     

    HardBeat

    New Member
    December 11, 2011
    3
    1
    41
    Netherlands Netherlands
    I'm also hoping someone can help me solve a problem I have with aMPdroid because everything is working great except streaming. When I start streaming I always get the player which is buffering but it wont start. When I press pause or back I get an error: -38,0. After some digging around I noticed that ffmpeg.exe doesn't start when I start a stream.

    When I start the same video with the debug option (to track down stream errors) it will start downloading the file, I go to the downloads section and I can play the video with no problems at all. When starting the debug methode the ffmped.exe starts working instantly.

    I tried all the troubleshoot solutions and tests and they all complete or respond with no problems.

    I added my GmaWebservice.log in which I first tried to start two streams normaly, and after that I used the debug option.

    I realy hope someone can help me get this problem solved, when it works it would be an amazing app :)
     

    HardBeat

    New Member
    December 11, 2011
    3
    1
    41
    Netherlands Netherlands
    I'm using a HTC Desire S, with android 2.3.5 (custom rom). If you think it can be the phone or the android version I will put back the original to see if that will solve the problem.

    Update: I reïnstalled my phone with another rom (Saga3D) and everything is working now. Thnx for the help, I wasn't thinking it could be a problem with the phone itself.

    Update2: I didn't test the TV and recording streaming when I posted the update but these two still don't work (everything else is working great). I have seen the errors -17 and -38 when playing around trying to start different streams. The stream does try to start, ffmpeg will start on the "server" but the video on my phone just hangs at the 1 sec mark. Once again I can watch the recordings and even "live" tv when I use the debug option and run the video from the downloads section but than only video with no sound. Anyone who can give some insight where to start looking for any problems? Can it be a codec problem as I'm using the default windows (DTV-DVD Video-Decoder) to watch and record tv with mediaportal 1.2?

    Solved: First tried a different codec but still the same problem. Than I copied the recording.ts to the video map and there it played without any problems. So I compared the config.xml from the GmaWebService with the TranscoderConfig.xml from the TV4Home Core Service and noticed a difference at the ffmpeg.exe CodecParameters. So I tested it with the Android LQ settings and changed it to the GmaWebService parameters.

    The TranscoderConfig parameters were:
    "<codecParameters>-vcodec libx264 -b 256k -profile baseline -preset veryfast -acodec aac -ab 64k -strict experimental -async 1 -deinterlace -f mpegts</codecParameters>"
    changed to:
    "<codecParameters>-vcodec libx264 -b 256k -profile baseline -preset veryfast -acodec aac -ab 64k -ac 2 -strict experimental -sn -async 1 -f mpegts</codecParameters>"

    and it is working now, I can play my recordings (from the TV section) and stream live TV. Not completely sure what I exactly changed but I'm happy now :D
     

    paalkr

    Portal Pro
    June 30, 2008
    145
    20
    Norway Norway
    Country flag
    Hi!

    First of all, :D for this great remote control/android client application for MePo! I'm using aMPdroid on my Samsung Galaxy SII and Samsung Galaxy Tab 10.1 all the time to stream LiveTV, videos and to schedule recordings. Everything are working excellent, except for the tablet layout. I must admit that I haven't read all 537 post in this thread :) , but from my searches I have understood that there has been some discussion regarding a tablet version of the app.

    I do understand that it's a great deal of work to create a complete new layout, so would it be possible to add a configurable feature to allow auto rotation of the app? It won't be perfect, but in my opinion it will be much better than being stuck in portrait mode on a tablet.

    Regards,
    PK
     

    Ballermann

    Portal Pro
    April 22, 2011
    131
    3
    Im Norden :)
    Germany Germany
    AW: [Android] aMPdroid 0.8 - Streaming and more

    Hey there.... I`d like to say that this is a great app for MePo... problem is: I can´t config the WiFi-Remote-Plugin - so I can´t establish a connection to the tablet... :(

    First time after installing config was working, second time not anymore.

    My Win7 is a german version, so I just try to translate as good as possible the error message:
    "An item with the same key has already been added"

    I tried to config in the extension installer GUI, also not working... error message: "Exeption in in plugin setupform loading: An item with the same key has already been added"

    Even after uninstallation / new installation the same error is coming up.

    Hope anybody could help, I really like to try this nice app.
     

    simpman

    Portal Member
    April 19, 2008
    12
    2
    Canada Canada
    Help! I can't get media to stream any more. Is it possibly because I updated to Ice Cream Sandwich? It streams a couple of seconds then gives me "Stream Failed Stream stopped unexpectedly, try to restart?" When I click yes it gives me a list of external players which don't play the video either, and clicking no stops it.

    On an unrelated matter, why is it that shows that the app detects as 4:3 are still being shown in widescreen? Annoying...


    Nexus S running Android 4.0.3
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ge2301 Android based client for MP2 MediaPortal 2 3
    K MpTvClient: Client for Amazon and Android devices General 2
    K Client für Android und Amazon-Geräte Allgemeines Support- und Diskussionsforum 68
    hanfmaster Dvb-s2 zu android ipad Einsteigerforum 0
    Lehmden Rezension Android TV Box KM8P Barebones/PC-Systeme/Kaufberatung 8
    S rotierende disk in streamed mp Skin Modifikationen 30
    C Streaming/transcoding MP2 vs MP1? General 4
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    P Streaming MediaPortal 1 Talk 5
    P Streaming to two clients from the same card Newcomers Forum 1
    L Non-PC device streaming... Newcomers Forum 1
    raffe How to add 500+ streams? OnlineVideos 1
    R Heavy pixelation on HD OTA Streams Installation, configuration support 1
    C streaming out UDP instead of RTSP Newcomers Forum 0
    C Recording back to back shows from IPTV streams General Support 8
    T Missing sound in online streaming service (SVTPlay) General Support 3
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    doskabouter Black screen while watching some iptv streams General Support 2
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    jmarc Recording IPTV streams General Support 1
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    Top Bottom