Bass player with ASIO support? | Page 4

Discussion in 'Listen Music' started by rockmeisster, December 6, 2006.

  1. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    Jan,

    yes please wait for the next build to try.
    But i'm afraid, that it'll still not work.
    i need to consult the BASS people.

    regards,

    Helmut


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. stanik

    stanik Portal Pro

    Joined:
    October 10, 2006
    Messages:
    146
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    Czech Republic Czech Republic
    Hi.
    I have same problem. Audio is faster and when I try play DTS CD nothing happenst. No sound and no reaction on Play CD button in MP.

    How is working configuration of ASIO for DTS CD playing. I tried play DTS CD in Winamp, but hear only noise.
     
  4. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    As i indicated above, you should use the latest SVN before doing any further tests.
     
  5. stanik

    stanik Portal Pro

    Joined:
    October 10, 2006
    Messages:
    146
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    Czech Republic Czech Republic
    OK, Already have SVN 716. Was a last yesterday afternoon. On this SVN I made tests and doesnt work.
     
  6. ariyanto

    ariyanto Portal Member

    Joined:
    November 8, 2006
    Messages:
    26
    Likes Received:
    0
    Location:
    London
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Please Help

    Hi please can you help me,

    I have been trying for days now to set up IASO and get it to work and have been looking for help within the forums, I use the bass player as to play my music. I have a philips Ultimate Edge sound card which has 24bit. this has both the philips sound card driver and a WDM version i have the default set to the Ultimate Edge driver not WDM for both recording and output. I have the Direct sound selected in MP, I have installed IASO4all installed as well.

    I have tryed alsorts of variations ect and seem not to be able to get it to work, i either get no sound at all or playing back like miss piggy because it plays too fast, if youe could just explain how i should set up ASIO so that at least i know that i am doing things right.

    Thanks for any Help :D
     
  7. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    stanik, ariyanto,

    please PM me your email address and i'll send you a sample program.
    Most probably i need to discuss that with teh BASS people, but first i need to know how the sample performs.

    thanks,

    Helmut
     
  8. Koudijs
    • Premium Supporter

    Koudijs Retired Team Member

    Joined:
    January 4, 2007
    Messages:
    132
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Netherlands Netherlands
    I performed some additional tests with svn build 12732 and the sample program.
    I also installed Asio4All since that is the driver used during development, I get different results for different combinations:

    svn 12732 + M-Audio Revo5.1 ASIO driver
    - Speed too high
    - No sound from digital output

    sample program + M-Audio Revo5.1 ASIO driver
    - Speed Ok
    - No sound from digital output

    svn 12732 + Asio4All
    - Speed too high
    - Sound from digital output

    Sample program +Asio4All
    - Speed Ok
    - Sound from digital output

    So with the last combination I can play a wav file. I use a HDCD encoded wav file to check for bit-perfect playback. If my receiver shows the HDCD logo I know that the bits were unchanged. With the sample program I do not get bit-perfect playback, so somewhere in the process bits are still changed.

    At this moment I use Foobar 0.8.3 with kernel streaming for bit-perfect playback, if I play the wav file this way the HDCD logo is displayed on my reveiver.

    If I should generate a log file with a certain combination please let me know.

    Jan
     
  9. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    Jan,

    is the number of speakers reported correct, when you press settings in the sample program?
    If the sample plays correct with Asio4All, then this might indicate problems with the driver of the soundcard.
    the interesting thing is that the code used in MP and the sample program is identical.

    looks i need to speak to the BASS people.

    Hopefully they can find something.

    thx,

    Helmut
     
  10. Koudijs
    • Premium Supporter

    Koudijs Retired Team Member

    Joined:
    January 4, 2007
    Messages:
    132
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Netherlands Netherlands
    The driver of my soundcard does not report the number of speakers, maybe because I am using the digital output.
    With Asio4All the number of reported speakers is 6, this is correct since it is a 5.1 card.

    To check the ASIO driver of my card I will install the latest version of FooBar, I report the results later.

    Jan
     
  11. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    i've made some modifications to ASIO support, please grab the latest public svn build from today
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!