Direct3D could not be created after resume (1 Viewer)

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag
    Hi I can't find a JIRA issue for MediaPortal hanging on startup due to autostart in mp config incorrectly starting MP on startup before DirectX is ready. It seems to be quite a common issue lately, I have seen 4 people have it in the last 2 weeks. Has anyone added this into JIRA yet? Should we disable the "Auto start MP with windows" option in mp config until this is sorted, as it seems to result in occasional crashes on startup.
     

    Toddi

    MP Donator
  • Premium Supporter
  • December 29, 2008
    53
    17
    Kiel
    Germany Germany
    Country flag
    Hi,
    after updating to MP 1.4 i have had the same error.
    For me the solution was to delay the mp start after dwm.exe has started.
    Maybe it's related to the special setup i'm using without explorer as shell. My shell is an autoit-script.
    However, maybe it helps someone.
     
    Last edited:

    Scythe42

    Retired Team Member
  • Premium Supporter
  • June 20, 2009
    2,065
    2,703
    46
    Berlin
    Germany Germany
    Thanks for confirming. MP will abandon the RunKey (as Microsoft wants since Vista) and will use the Task Scheduler for autostart. This should make go this away as MP is only started once the Desktop is properly loaded (this includes DWM).

    Will provide a patch in GIT from my current private fork in the coming days.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    G [fixed] No recorded video thumbnails created while recording. 2.2 Archive 2
    M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
    uxDesign Can't play Blu Ray: VideoPlayer9: Exception while creating DShow graph 1.20 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    stirlinghart [duplicate] Mp not focused on after resuming from sleep 2.2 Archive 7
    P Multiple clients - share resume/watched data General 1
    stirlinghart FOCUS not on MP after resuming from sleep General 11
    U IR Blaster doesn't work after system wake/resume General Support 6
    megahorst Mediaportal chrashs when the PC goes to suspend mode (or when it resumes?) 1.19 11
    B pls help. tv stops playing but resumes if I push pause and play General 0
    BlueMax1916 Problems with MP1 client process dying when resuming from standby, probably MovingPictures related Moving Pictures 2
    BlueMax1916 Problems with MP1 client dying after resuming from standby General Support 2
    Similar threads

























    Top Bottom