1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EPG-Buddy a new EPG Tool with easy usage. | Page 11

Discussion in 'Tools and other software' started by Lehmden, November 26, 2016.

  1. piscdi

    piscdi Portal Member

    Joined:
    March 17, 2017
    Messages:
    19
    Gender:
    Male
    Location:
    Minot, Maine
    Ratings:
    +7 / 0
    Home Country:
    United States of America United States of America
    Hi Lehmden,





    Thank you again for all your hard work; it's day two with your latest version and all is well. The ampersand issue is, as you so ably put it, cosmetic. I only mentioned it because I thought it might be responsible for the issue Breese and I were experiencing. Its great that you are working on a fix for it, though; really speaks to to your professionalism.

    I have discovered a small issue that again, I have no explanation for; it seems to have appeared since your fix. Some of the downloaded guide appears to be in German (its been many years since my high school German classes, but on this I'm fairly sure ;)). It appears to occur only in the program titles, not the descriptions. And it appears not to be skin related as I see it both on the server sporting the WMC skin and a client running BV Titanium. This one is a little more than cosmetic as it effects the recording schedule. Gunsmoke was scheduled to record at both 1 pm and 1:30 pm, but due to the renaming, the 1:30 won't record. That's actually how I discovered this issue. Screen shots follow.

    BTW To Breese' question about the actual naming of the H & I channel, yes, that is indeed how it is named as you can see by the screen shots below.

    Oh, one last question, Lehmden: are you still working on a Schedules Direct module for EPG Buddy? Just curious.

    Have a great weekend, all.
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. piscdi

    piscdi Portal Member

    Joined:
    March 17, 2017
    Messages:
    19
    Gender:
    Male
    Location:
    Minot, Maine
    Ratings:
    +7 / 0
    Home Country:
    United States of America United States of America
    Oops, forgot to attach the log file from this morning.
     

    Attached Files:

  4. Lehmden
    • Team MediaPortal

    Lehmden Test Group

    Joined:
    December 17, 2010
    Messages:
    10,446
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,274 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    Oops, seems to be a missing setting. :oops: You're right it is German. Next version will have this setting, promised... In meantime you can correct this with a SQLite Tool (like SQLiteExpertPersonal, it's free and easy to use) yourself. Open the database file "EPG-Buddy.s3db" in SQliteExpert (or similar) and find table "EPG_GRABBER_SETTINGS" There is a row with "Language", normally it's the first row. The value after the language is probably "de". This you need to change to "en" (for English language) or any other language code supported by TVDB.

    Astonishing that no one else saw this before. As I'm using "de" all was working as it should. So I didn't notice this but everyone not grabbing in German language must have seen this, I'm sure... Most likely this didn't show up too often as English is the "fallback- language" if nothing could be found in the given language.

    The planes are still there but as tvguide.com is a free (and good, I hope) alternative the priority isn't too high atm. Aside this we both don't have access to SD, so any development wouldn't be too easy.

    It's looking pretty normal.
     
  5. piscdi

    piscdi Portal Member

    Joined:
    March 17, 2017
    Messages:
    19
    Gender:
    Male
    Location:
    Minot, Maine
    Ratings:
    +7 / 0
    Home Country:
    United States of America United States of America
    Hi Lehmden,

    You were right, that was easy. The schedule shows correctly now :D.

    And thanks for turning me on to SQLiteExpertPersonal.
     
  6. Lehmden
    • Team MediaPortal

    Lehmden Test Group

    Joined:
    December 17, 2010
    Messages:
    10,446
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,274 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    New Version 0.4.1.8 in first post. Aside some bugfixes there is a new setting for used metadata language while comparing with TVDB. You now can choose between all languages available on TVDB. If nothing is found in your language, English is used as "fallback" language.
    And WebGrab+Plus is upgraded to V2.1. For this you need to redo your WebGrab configuration once. Without renewing your configration WebGrab did not work any more from within EPG-Buddy...
     
    • Thank You! Thank You! x 1
  7. bc420

    bc420 Portal Member

    Joined:
    March 15, 2012
    Messages:
    30
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Just want to thank you guys for the latest fixes has been pretty good for my system 90% correct and maps nice and easy can't complain 1125 channels two providers . The slight delay you put in there seems to have fixed the issue i was having before . looking forward to testing this version thanks again you guys for your hard work !!
     
  8. phreich

    phreich New Member

    Joined:
    August 12, 2017
    Messages:
    1
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Hi,

    I am hoping the developer Lehmden will read this.

    I can't get the process to work -- the epg-grabber is abending in the second of the three command windows.

    Although it continues to the next window once I click okay to close the program, it does not build a good xml file.

    Attached is a screenprint of the abend.

    I downloaded the latest version from the end of the first post.

    Thanks,

    Philip 2017-08-12 15_00_12-Clipboard.jpg
     
  9. Lehmden
    • Team MediaPortal

    Lehmden Test Group

    Joined:
    December 17, 2010
    Messages:
    10,446
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,274 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    Do you use WebGrabPlus+ from inside EPG-Buddy? And if yes, did you configure it right? WebGrab is a lot more complicated to configure as the other direct supported sources. This error happens while trying to enrich the EPG- data that was downloaded before by WebGrab. And normally this is caused by a not responding TVDB server, means the download of metadta for a show didn't succeed. But not this time. Here it looks as if something is clearing or blocking the temp- folder while it is in use. I don't know what to do as without those temp files the process can not run successfully. Just for testing, disable WebGrabPlus+ as EPG source and try if the "rest" (tvguide.com and similar) is working normally.

    In general, WebGrabPlus+ is the most complicated and the slowest of all ways to get EPG data. But it covers much, much more websites and channels than anything else. Normally WebGrab should be used only for very few channels not covered by the "regular" sources. Personally I'm using WebGrab for two channels I wouldn't get EPG anywhere else...
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Like Us On Facebook

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!