Excessive frame drops | Page 2

Discussion in 'Installation, configuration support' started by tclulow_4213, October 5, 2015.

Tags:
  1. tclulow_4213

    tclulow_4213 Portal Member

    Joined:
    October 5, 2015
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    To answer some of the questions/suggestions made.
    DVDs suffer the same problem.
    I'm not using the laptop's monitor, just HDMI to the panasonic.

    Here's the resource montor (looks well withing the PC's capabilities to me). The CPU spike about 20 seconds in is when I started the playback.
    upload_2015-10-7_22-50-16.png

    Here's the '!' screenshot:
    upload_2015-10-7_22-59-2.png

    In MediaPortal configuration -> Codecs and renderer -> TV codecs -> Hardware acceleration
    I've tried None, DXVA2 (copyback) and DXVA2 (native) which all exhibit this behaviour.
    NVIDIA CUVID and Intel QuickSync appear to be not available - it looks like some of the text has been truncated in this message:
    upload_2015-10-7_23-9-56.png




    With regard to the comments about 50/60hz, I remember seeing some config screens for refresh rates but I can't find them now so if that's important someone will have to direct me to the config page.
    I've tried changing the TV refresh rate to 50hz, but the problem persists.

    Tony.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,687
    Likes Received:
    558
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +985 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I set the refresh rate for my HTPC in the "Control Panel" application for the graphics adapter (Nvidia in my case). That offers a choice of resolutions, refresh rates, and colour depth.

    There are other places that refresh can be set (I think), but I would start with the graphics adapter. A modern TV will adjust to whatever refresh rate the graphics adapter is outputting.

    -- from CyberSimian in the UK
     
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    They're here:
    http://wiki.team-mediaportal.com/1_...figuration/11_General/21_Dynamic_Refresh_Rate

    Note that you have to enable expert mode (top right corner in MediaPortal Configuration) to see that section.
     
  5. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,392
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,173 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    CUVID is a feature supported only by nVidia cards.
    Quick Sync was initially built into some Sandy Bridge CPUs, but not into Sandy Bridge Pentiums or Celerons, so your GPU just doesn't support it.
    text is truncated if you use 125% in windows DPI settings.
     
  6. CypherMK
    • Team MediaPortal

    CypherMK Test Group

    Joined:
    March 11, 2009
    Messages:
    1,735
    Likes Received:
    297
    Gender:
    Male
    Ratings:
    +617 / 3
    Home Country:
    Netherlands Netherlands
    Show System Specs
    If you look at the shift+1 Screenshot the actual fps is 34. 2610. In my opinion this means that the video card can't handle the interlaced video.
     
  7. CypherMK
    • Team MediaPortal

    CypherMK Test Group

    Joined:
    March 11, 2009
    Messages:
    1,735
    Likes Received:
    297
    Gender:
    Male
    Ratings:
    +617 / 3
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Can it handle 1080p mkv files?
     
  8. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,746
    Likes Received:
    1,420
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,849 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    you using a laptop connected to a tv?

    without reading through all your posts and logs, I would hazard a guess that this could relate to a multiple display issue. I'd suggest try without connecting to any external displays or hdmi audio devices and retry.

    also the number of dropped frames suggest and the fact the cpu usage is not maxed out makes me think that the GPU can't deinterlace/render fast enough. You can lower the work on the GPU by either disable deinterlacing or force it to use bob or weave (less taxing on gpu). Another option is to use software deinterlacing and let cpu do the work.

    EDIT:

    on your ! screenshot render time = 25ms, however at 50fps you only have 20ms per frame, so it has to drop every 5th frame because it's too slow.
     
    Last edited: October 8, 2015
  9. tclulow_4213

    tclulow_4213 Portal Member

    Joined:
    October 5, 2015
    Messages:
    10
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Lots more suggestions/comments, thanks.
    I've tried disconnecting the TV and using the laptop's display - problem persists.

    I've tried changing the de-interlacing (below) but to no effect. Is there somewhere else to specify what to do with interlaced source?
    upload_2015-10-8_13-6-41.png

    I enabled the pop-up to notify me about refresh rate changing. I had the desktop set to 1920x1080/60 and when I started playing TV the popup notified me of a change to 50hz which I assume is as it should be.
    I've run a DPC latency checker which reports no issues.

    In an attemt to reduce the GPU's load, I've disabled hardware acceleration (the main CPUs seem to have plenty of capacity) - but the problem persists.

    So it seems the root cause is the GPU can't handle the data rates.
    However WMC works fine without any dropouts.
    What's it doing that MediaPortal isn't? Maybe using different drivers?
    Any ideas what else to try before I give up and buy a consumer freeview PVR?

    Tony.
     
  10. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,811
    Likes Received:
    1,126
    Gender:
    Male
    Ratings:
    +2,411 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Could you give the Microsoft-DTV codecs in lieu of LAV a try and have a look at the stats to see if there is any change?
     
    Last edited: October 8, 2015
    • Great Idea! Great Idea! x 1
  11. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I think - in some circumstances - the MS DTV decoder will drop the framerate if it thinks the render time is too long, so definitely worth a try.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!