[solved] - (Kodi issue) MCE Remote not working in 1.13pre. Worked fine in 1.12

Discussion in 'Input / Output interfaces' started by Kevin TenBrook, December 18, 2015.

  1. Kevin TenBrook

    Kevin TenBrook Portal Member

    Joined:
    December 18, 2015
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +3 / 1
    Home Country:
    United States of America United States of America
    Title kind of says it all. I have an MCE compatible remote, specifically a Mediagate GP-IR0GBK remote with transceiver. Windows recognizes the IR receiver as a Microsoft ehome HID device (along with the associated keyboard devices). In MP 1.12 I selected the MCE remote option, and everything worked perfectly. Now with 1.13, that option is gone, replaced by the Generic HID. But the remote doesn't work! Only the left/right/up/down/OK buttons seem to work.

    I've pounded my head for several hours now trying to get it to work (and completely messed up my Harmony setup in the process) to no avail. The remote commands are clearly getting to the PC, and the fact that it worked in 1.12 shows that there is not a hardware issue. It seems to be a mapping problem. But how can I determine what the remote sends and how MP interprets each signal.

    For now, back to 1.12.

    I hope someone can help, because otherwise I'll be in 1.12 for a long time, and may just go back to NextPVR or Kodi, both of which also worked fine with this remote.

    Thanks in advance.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,604
    Likes Received:
    449
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +676 / 2
    Home Country:
    England England
    Show System Specs
  4. Kevin TenBrook

    Kevin TenBrook Portal Member

    Joined:
    December 18, 2015
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +3 / 1
    Home Country:
    United States of America United States of America
    Thanks for your reply. I've tried that, of course. Checked the Generic HID remote. However, it is impossible to uncheck all the MCE stuff since the MCE tab no longer appears. I suspect that may be the bug because this is an upgrade over 1.12 and the MCE remote was selected prior to the update. Maybe the upgrade left behind some 1.12 settings I no longer can access?
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi Kevin

    No, that's not possible. The old MCE remote handler was completely removed. Any settings which may or may not have been left over are now obsolete and have no effect.

    If you would like assistance with this then log files will be required. Ideally enable the generic HID remote handler including extended logging, then use the MediaPortal Watchdog tool with option 1 to collect appropriate log files. In this case just press some of the buttons on the remote, including some that are working and some that aren't.
     
  6. Kevin TenBrook

    Kevin TenBrook Portal Member

    Joined:
    December 18, 2015
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +3 / 1
    Home Country:
    United States of America United States of America
    Thank you MM for your generous offer to help. But I have reverted to 1.12 and now the remote works perfectly. I had tried previously when I first installed MP to make it work using the Generic-HID tab but was unsuccessful. At least, it looked like it was going to hours of investigation and mapping to make something work, whereas just selecting the MCE tab worked out of the box. I realize that the MP team needs to focus their efforts, but clearly the old MCE remote handler worked perfectly for a whole slew of MCE "compatible" remotes while the HID handler does not. I hope that as the MP team moves forward, that they reconsider dropping the MCE support and holding off until the HID handler can work without the need to tweak dozens of mappings. A checkbox lableled "I have an MCE compatible remote" perhaps?

    Thanks again.

    I will happily reinstall 1.13 and perform the logging you described if you think it helps the team improve MP. Otherwise, I also need to keep the wife happy, and she needs a working remote for that.
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  7. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,604
    Likes Received:
    449
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +676 / 2
    Home Country:
    England England
    Show System Specs
    Hi Kevin, We always look forward to anything that makes MP better :)
    If you are willing to test then I'm sure your input would be warmly accepted.
    Please bear in mind though that a lot of our users and team members are not primarily English speakers (although @mm1352000 is if Kiwi is accepted ;) ) so if someone sounds rude, it may not be the case! :D
     
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Well that's really really strange. The new generic HID handler and mapping should "just work" with MCE-compatible remotes. Given how many people use such remotes, we'd have been idiots to have designed the update in any other way.

    The fact that your remote doesn't appear to work with the generic HID handler is likely frustrating and disappointing. However, I don't think it's clear - either from your result, or from other issue reports on the forum (of which there are few) - that there are a "whole slew" of remotes and/or people in your position. Anecdotally, results with the new generic HID handler have been very positive.

    Sorry, that's not going to happen. MP 1.13 is scheduled for release in the near future. There's not enough time or evidence of a problem to justify either reinstating the old MCE remote handler or holding off on the release. If anybody runs into unexpected problems they will be able to report a problem and roll back to MP 1.12 exactly as you've done.

    As I said above: it was intended that there shouldn't be any need to tweak any mappings. Therefore your proposed checkbox would/should be superfluous.

    Thanks for the offer. It's actually unnecessary to reinstall 1.13, because the generic HID implementation in MP 1.13 is only a slight revision of the one in MP 1.12. That being the case, I hope it will be possible for you to produce log files without much hassle. :)

    Regards,
    mm
     
    • Like Like x 1
  9. JonHancock

    JonHancock Portal Member

    Joined:
    December 17, 2007
    Messages:
    33
    Likes Received:
    4
    Ratings:
    +7 / 0
    Hi,
    Just wanted to add that I had this exact same issue with a Harmony touch last night when I upgraded to 1.13 last night. Everything working with 1.12. I also found an MCE RC6 remote I use with another client and this gave the same results. I have also reverted to 1.12.

    Cheers,
    Jon.
     
  10. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Thanks for the report Jon.
    Are you able to provide log files?
    (...remembering 1.12 + HID handler is roughly equivalent to 1.13, so you don't have to update just to get log files...)
     
  11. JonHancock

    JonHancock Portal Member

    Joined:
    December 17, 2007
    Messages:
    33
    Likes Received:
    4
    Ratings:
    +7 / 0
    Hi, I've attached the logs. Hope I've collected them all properly. Let me know if you need anything else.

    Cheers,
    Jon.
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!