[fixed] - Live-TV: Fast forward and rewind leads to picture freeze | Page 2

Discussion in 'MediaPortal 1.2.0 ALPHA' started by tom78, November 9, 2010.

  1. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. infinite.loop
    • Premium Supporter

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
  4. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Attached are modified Core.dll and dshowhelper.dll for MP 1.2.0 Alpha for testing - copy these into \Program Files\Team MediaPortal\MediaPortal (but backup the original dll's first, just in case!)

    I've modified the fast-forward and rewind behaviour for TV and Video playback - this fixes the problems on my Vista systems, but I can't test this on Win7. Note that Video FFWD/REW also now mutes the sound (unless you are bitstreaming) to match the TV behaviour.

    Tony
     
    • Like Like x 1
  5. romuz
    • Premium Supporter

    romuz Retired Team Member

    Joined:
    July 26, 2008
    Messages:
    1,045
    Likes Received:
    125
    Location:
    Moskau
    Ratings:
    +126 / 0
    Home Country:
    Russian Federation Russian Federation
    Owlsroost attach a patch for core pls
     
  6. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Attached.

    Tony
     

    Attached Files:

  7. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark

    When putting these two files into MP 1.2 alpha SVN26846 mediaportal does not load up. In the middle of "loading input devices" it minimizes to tray and stays there. Copied the original files back and now it works again.

    Will try the patch later on and see if thats the same behaviour.

    thanks
    Mylle
     
  8. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    The core.dll is for MP 1.2.0 Alpha release version only (SVN 26638)

    I'll generate a patch against the latest SVN later.

    Tony
     
    • Like Like x 1
  9. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    Great. Thanks
     
  10. harryzwo

    harryzwo Portal Pro

    Joined:
    July 25, 2006
    Messages:
    711
    Likes Received:
    34
    Ratings:
    +64 / 1
    Home Country:
    Germany Germany
    Show System Specs
    This Patch works fine under Win7 in MyTV. But one probelm exists. In myMusic ffwd is OK, REW doesn't work.
     
  11. tom78

    tom78 Portal Pro

    Joined:
    August 10, 2007
    Messages:
    149
    Likes Received:
    5
    Ratings:
    +5 / 0
    Home Country:
    Germany Germany
    Show System Specs
    AW: Live-TV: Fast forward and rewind leads to picture freeze

    I tested this 2 files, too. (only with Live-TV)
    W7 x86 and it works well! But i have still one improvement suggestion:
    Now when i'm pressing REW and MP reaches the end of the timeshift buffer, it switches automatically to the play mode.
    It would be great if the same would happen when pressing FFWD.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!