[WiP] madVR support in MP1 (15 Viewers)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,936
    1,385
    Home Country
    Germany Germany
    Country flag
    Seems I had forgotten my password for Doom 9 and after resetting it screwed up an attempt to post a question in the Madvr forum.:oops:
    So then decided to play with it further and have found a fix.:)
    In the screenshots below the first profile is the failing one for Win 10 2004 which worked with 1909 and earlier and the second one works with 2004 perfectly again.
    Not sure why Win 10 2004 does not like the first profile but happy to have fixed it.

    madvr3D-1.jpg madvr3D-2.jpg
     

    ThoW1982

    Portal Member
    November 6, 2010
    30
    16
    Home Country
    United Kingdom United Kingdom
    Country flag
    Hi

    I managed to get Geforce 3070 which replaced my Radeon 580.

    I have it connected to Samsung Q70R. With Radeon 580 I haven't had any issues with madvr in SDR or HDR (all perfect in my opinion).

    It looks like HDR with Geforce 3070 is hard to do due to driver issues (?) I have tried many different drivers for 3070 but on the ones that I can get HDR to work I get the following issues:

    1) Switch on Mediaportal 1.27
    2) Play SDR content - all good
    3) Play HDR content - all good; HDR switches on on the Q70R
    4) Play SDR content - all colors disturbed, Q70R reports HDR off

    example.jpg


    5) Play HDR content - all good

    If I restart Mediaportal - SDR is OK until I play HDR, then it starts again. Basically once I play HDR I need to restart Mediaportal to play SDR content.
    I can't imagine myself not using Mediaportal (been using more than 10 years), so if I can't solve this I will return Geforce 3070 and put back Radeon 580 (I like Mediaportal that much).

    My settings:

    LAV-video-2.jpg


    Same SDR playback issues after HDR also happen on DXVA2 (copy back) and DXVA2 Native.

    Madvr settings:

    madvr-1.jpg

    madvr-2.jpg

    madvr-3.jpg

    madvr-4.jpg

    madvr-5.jpg

    madvr-6.jpg

    madvr-7.jpg

    how many video frames are presented in advance = "1" sorts out micro stutter on Geforce RTX GPUs according to some posts on Doom9's Forum - Powered by vBulletin. Generally people say that they manage to get the HDR playback sorted with MPC in full-screen fine in Geforce RTX GPUs but Mediaportal is different...

    Can anyone help me pls? I'm guessing here but it seems like madvr is not properly disabled after playing HDR in Mediaportal on Nvidia card? Or maybe some madvr settings need adjusting? I have spent close to 12 hours on this but can't solve this issue :(

    I have tried many times to export logs using MediaPortal WatchDog but every time I try to play HDR content with it running colors are washed (no proper HDR displayed) and then SDR is working correctly.

    If i just fire up Mediaportal and play HDR then it's OK but if I play SDR all content colors are disturbed until Mediaportal restart.

    Getting desperate here as I have now less than 12 days to return the card to the seller. Very willing to donate if this issue with SDR colors after playing HDR via passthrough HDR to display is fixable.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    I understand how you feel, but this will definitely not be fixed within 12 days, that I can tell you for sure.
    It needs a lot of investigation and troubleshooting and (most likely) code adjustments. Not every developer has a HDR capable device, so that also makes troubleshooting difficult.

    If you want to play on the safe side, you can return the card and buy it again once this is fixed.
     

    bilis4

    Portal Pro
    February 14, 2007
    74
    70
    53
    Athens
    Home Country
    Greece Greece
    Country flag
    @ThoW1982 Its not Mediaportal related. It is Nvidia related. Same thing happens to me with kodi also. For me last working nvidia driver is 446.14 but i doubt it will suit you, cause the driver is older than your card.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,881
    5,544
    France - IDF
    Home Country
    France France
    Country flag
    The problem to compar mpchc with kodi or mediaportal, is the fact than mpchc is only videoplayer, nothing else.

    The best way, would to use mpchc as renderer for MP as API interface, but mpchc is more young than mp, i think.

    Envoyé de mon LG-H870S en utilisant Tapatalk
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    @ThoW1982 Its not Mediaportal related. It is Nvidia related. Same thing happens to me with kodi also. For me last working nvidia driver is 446.14 but i doubt it will suit you, cause the driver is older than your card.
    I would have to disagree with that, since MPC-HC + madVR with the latest Nvidia drivers (from 7/1/2021) is a perfectly working combination.
     

    bilis4

    Portal Pro
    February 14, 2007
    74
    70
    53
    Athens
    Home Country
    Greece Greece
    Country flag
    I would have to disagree with that, since MPC-HC + madVR with the latest Nvidia drivers (from 7/1/2021) is a perfectly working combination.

    I have not tested last drivers yet. But since 446.14 was ok for me and after that was not, i came to the conclusion that nvidia changed something in the drivers.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,936
    1,385
    Home Country
    Germany Germany
    Country flag
    I would have to disagree with that, since MPC-HC + madVR with the latest Nvidia drivers (from 7/1/2021) is a perfectly working combination.
    Have you tried setting up MPC-HC to use external filters only and selecting LAV as the only external filter? That way you will be using the same setup as MP. Just in case it is something in LAV/settings.
    Screenshots below are for MPC-BE but should be the same for -HC
    lav1.jpg lav2.jpg
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    I have not tested last drivers yet. But since 446.14 was ok for me and after that was not, i came to the conclusion that nvidia changed something in the drivers.
    I also recall that version as being a very good version. The problem is that there are many variables naming MediaPortal, Nvidia and not to forget the windows updates. I always use MPC-HC as comparising and that has been working really well. Lately i was so fed up with the issues that i even used MPC-HC for playback....

    Have you tried setting up MPC-HC to use external filters only and selecting LAV as the only external filter? That way you will be using the same setup as MP. Just in case it is something in LAV/settings.
    Yes, I have MPC-HC setup with LAV as external filters and madVR as DShow Video output ;)

    You can read more about my testing from yesterday and my findings about the (most likely) root cause of this issue in this post. ;)
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    I have not tested last drivers yet. But since 446.14 was ok for me and after that was not, i came to the conclusion that nvidia changed something in the drivers.
    I stand corrected.... I had to test it again, and indeed, 446.14 is working for me also from a few tests.
    Need to see if it holds, but i recall it was having issues sticking to 12bit for 23.976 and i often had to correct that in Nvidia Configuration.
    But so far, so good!
    Now i'm still baffled why the latest drivers work fine in windowed mode and why MPC-HC, lav filters and madVR combo is working without issues...
    But TNX for the driver hint ;)
     

    Users who are viewing this thread

    Similar threads

    Recently I have been trying to reduce or eliminate juddering on my system. I notice it particularly with: Horizontal panning (e.g. in travel or nature documentaries) Horizontal "ticker tape" news feeds (e.g. "Sky News" channel) Vertically scrolling programme credits (e.g. "Mock the Week") I originally had my Nvidia screen-config set...
    Recently I have been trying to reduce or eliminate juddering on my system. I notice it particularly with: Horizontal panning (e.g...
    Tinkering with using MadVR. I'm still running a 1080p TV, but have plenty of old DVD rips that I haven't updated yet, and my next...
    Replies
    15
    Views
    4K
    Just for your information: couldn't find the ns*.tmp file...
    Just for your information: couldn't find the ns*.tmp file...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    39
    Views
    2K
    • Sticky
    It's very strange, but you can see that it happens. The logic of NSIS is a complete mystery. :)
    It's very strange, but you can see that it happens. The logic of NSIS is a complete mystery. :)
    We have just released MediaPortal 1.28 Summer Breeze Highlights of this release Bugfixes: [MP1-5053] - TV framerate is not...
    Replies
    12
    Views
    857
    • Sticky
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5081] - WatchDog...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    235
    Thanks for that but it does seem to me that Madvr is the issue here, I guess it is not as robust as the EVR or does not get shut down as elegantly, I also suspect, though I have not tried it, that the result would be the same for playback of any video, i.e. not just TV. Given that German TV is now all transmitted as full HD, the need...
    Thanks for that but it does seem to me that Madvr is the issue here, I guess it is not as robust as the EVR or does not get shut...
    When I finish watching TV I always stop the playback and exit to the home gui before putting the HTPC to sleep and have no...
    Replies
    2
    Views
    3K
    Top Bottom