Mediaportal sends Windows into hibernation without being setup to do so

Discussion in 'MediaPortal 1 Talk' started by emphatic, January 17, 2019.

  1. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    This is a recent thing that's very annoying, and I don't know where it came from all of a sudden.



    The problem is twofold:

    1. The Power Off button on my remote sometimes puts my system into hibernation instead of Shut Down. But, only when executed in MediaPortal. If I close the application first, then use the Power Button on my remote, Windows is exited correctly. Also, if I wake it from hibernation, MediaPortal will freeze up after a couple of seconds.No changes has been made to my Windows power schedule, and I haven't changed remote inputs in MediaPortal.

    2. MediaPortal will just go into hibernation on it's own. If I leave Windows running with MediaPortal closed, the system stays on.

    Emph
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    Update, it's actually something Microsoft calls Away Mode.

    I have set my power schedule to not allow it when sharing media, is that not the correct way to solve this? It's like MediaPortal decides to just do the opposite of what my Windows Power schedule is set to.

    Someone?
    Emph
     
  4. Hairysoundman

    Hairysoundman Portal Member

    Joined:
    April 25, 2018
    Messages:
    15
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    I've been experiencing this since updating to 1.22 (which also coincided with a windows update). Will have a play with the power settings and see if I can disable Away Mode.
     
  5. Hairysoundman

    Hairysoundman Portal Member

    Joined:
    April 25, 2018
    Messages:
    15
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    OK, I've just checked my mediacentre (what I call my HTPC). Despite setting the power settings in Windows settings to "Never" yesterday, today I found that it had gone into sleep mode, the setting had reverted back to 30 minutes, plus also the TV server had stopped.

    So, I've gone through the power settings with a fine tooth comb, plus also I've enabled "Wake on LAN" in the MediaPortal Config app. We'll see if this cures it.
     
  6. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    Check the settings in your Power Scheduler in the TV Server, that's where my remedy was.

    Emph
     
  7. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,645
    Likes Received:
    542
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +962 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    These symptoms suggest that you are using Windows 10. Sadly, whenever a significant Windows update occurs, Windows 10 resets the settings in the power plan :(. So you need to recheck the power settings after every Windows update :mad:.

    The solution? Use Windows 7 (that is what I do). :D

    -- from CyberSimian in the UK
     
  8. Hairysoundman

    Hairysoundman Portal Member

    Joined:
    April 25, 2018
    Messages:
    15
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    I've checked all that, but I can't see anything different in Power Scheduler from before.

    I've reset my Windows power settings and they appear to have stuck, but now I've finding that the TV server is stopping, and when I go back to my MP it has the "select TV server" screen up. The TV server won't restart until you go into TV Server Config, which tells you you need to start the TV Server before configuring it.

    Yes I am on Win10Pro, but wouldn't go back to W7 now if you paid me.

    This set up has been totally stable and reliable for two years now, through several Windows updates. None of them have done all this shit. This has just started happening since I updated MP to 1.22.

    How do I set the TV Server to, "never f-ing switch off you moron"?
     
    • Funny Funny x 1
  9. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
  10. Hairysoundman

    Hairysoundman Portal Member

    Joined:
    April 25, 2018
    Messages:
    15
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Hmmm, the config page of the client Powerscheduler plugin is very limited, indeed it says that the Server plug-in controls it. I've dug down as far as I can in the Server PS plug-in settings, and made sure they're all applied, so we'll see what happens next time I go back to the MP Client...
     
  11. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    It’s rather the opposite: they should not be applied. The only thing you need is to activate wake-up by the scheduler.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!