MPTagThat - The Mediaportal Tag Editor | Page 13

Discussion in 'MPTagThat' started by hwahrmann, February 26, 2009.

  1. henso
    • Team MediaPortal

    henso Development Group

    Joined:
    February 16, 2012
    Messages:
    1,490
    Likes Received:
    363
    Gender:
    Male
    Ratings:
    +551 / 0
    Home Country:
    Denmark Denmark
    I get a “mvhd box not found” error.
    I get many of the above errors when importing mp4 movies in MP2.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,489
    Likes Received:
    1,621
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,246 / 1
    Home Country:
    Austria Austria
    Interesting, because at 0x128C8E9A a mvhd box is present and found by the library:

    upload_2018-3-3_11-48-5.png

    upload_2018-3-3_11-50-37.png


    And when you do your proposed changes from the previous post, you are not getting this erroe?
     
  4. henso
    • Team MediaPortal

    henso Development Group

    Joined:
    February 16, 2012
    Messages:
    1,490
    Likes Received:
    363
    Gender:
    Male
    Ratings:
    +551 / 0
    Home Country:
    Denmark Denmark
    Correct.

    I'm not sure we use the same source if it works for you, so for completeness I will just mention what repository I use: GitHub - MediaPortal/MPTagThat: MPTagThat is a feature rich open source tag editor with a modern interface to tag all your music.
    In MP2 we use the nuget "MediaPortal.TagLib" v2.1.0.3 which seems to be based on this source (correct me if I'm wrong).

    With that source I get the following:
    upload_2018-3-4_12-48-22.png
    As you can see the box size is much larger than the remaining bytes in the file, which leads to the exception.

    This then leads to the mvhd box not being found here:
    upload_2018-3-4_12-55-28.png
     
  5. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,489
    Likes Received:
    1,621
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,246 / 1
    Home Country:
    Austria Austria
    You are absolutely right.
    I was running my tests with the tagblib-sharp build pointing to my fork, which is different to what i use in mptagthat.
    This error was fixed there about 11 month ago and it seems that i missed that one and didn't it carry over in our build.
    I will grab all the other pull requests which have been done in the last few weeks and will update the library.
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  6. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,489
    Likes Received:
    1,621
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,246 / 1
    Home Country:
    Austria Austria
    @henso i have updated our feed with Taglib 2.1.0.4. Please let me know if it works for you
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!