Music playback stops (1 Viewer)

hinuslinus

MP Donator
  • Premium Supporter
  • February 12, 2012
    6
    4
    United States of America United States of America
    Country flag
    Good luck! Forgot to mention that I looked at your most recent log and didn't see the same issues that were causing my stoppage. But I thought I'd throw it out there as something to try and for any others who may come across this thread for music stopping in v1.4.
     

    volumia

    Portal Pro
    November 23, 2011
    100
    54
    whereever my feet take me...
    Netherlands Netherlands
    Country flag
    Sorry to say that unticking the option did not fix music playback for me. I am having the same playback problems, when randomly the audio will stop (never the same and not every track). Everything else (series, movies, etc.) runs fine.
    On screen the actual total time of the track will change to the time where it stops. Pressing the next button wil resume playback on the next track however.
    I am running MePo 1.4 (fresh install) with StreamedMP skin on Win7 x64 by the way, and no hardware drivers changed between the 1.3 and 1.4 version. Audio and video are over HDMI and connected to a Yamaha receiver.
    Tried both BASS and WASAPI, same result. Even went back to the codec version I used on the MePo 1.3 installation (from Shark codecs 4.1.7 to 4.1.6 and back again) to exclude that. Windows Media Player was playing all MP3's without problems in all cases.
    The MP3 location did not matter either, I tried it from al local, USB drive and a DFS share. Attached are todays log files. Hope my info will help in finding the solution. Should more or testing be needed, just say the word...
     
    Last edited:

    Requiem

    MP Donator
  • Premium Supporter
  • January 1, 2012
    586
    214
    Germany Germany
    Country flag
    This describes exactly what I'm experincing, though it also affects series watching from time to time as mentioned above. unticking the option mentioned above did also not solve the problem for me. Very similar setup with MP1.4/StreamedMP/HDMI connected to Yamaha receiver -> no problems before.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,465
    4,631
    45
    ::1
    Netherlands Netherlands
    Country flag
    This describes exactly what I'm experincing, though it also affects series watching from time to time as mentioned above.
    So that means it's not just the Music section giving issues. Start MediaPortal without any plugins enabled like the FritzBox Manager & MPSync stuff (since that's also throwing errors). So you can either start MP in Debug-Mode (from that Start Menu), or disable the plugins manually and see if that solves the problem. Might very well be a plugin that's causing the issues.

    @volumia
    Code:
    [2013-06-29 01:35:59,211] [Log	] [7		] [DEBUG] - fileSystemWatcher_Error path \\haleysystems\root\multimedia\muziek\albums exception=System.ComponentModel.Win32Exception: De opgegeven netwerknaam is niet langer beschikbaar
    [2013-06-29 01:35:59,211] [Log	] [7		] [DEBUG] - RemoveWatcher \\haleysystems\root\multimedia\muziek\albums
    [2013-06-29 01:35:59,320] [Log	] [FileExistsCache Thread] [DEBUG] - AddWatcher \\haleysystems\root\multimedia\muziek\conference
    [2013-06-29 01:35:59,320] [Log	] [FileExistsCache Thread] [DEBUG] - InsertFilesIntoCacheAsynch: pre-scanning dir : \\haleysystems\root\multimedia\muziek\country
    [2013-06-29 01:35:59,335] [Log	] [7		] [DEBUG] - RemoveWatcher removing folders from cache=\\haleysystems\root\multimedia\muziek\albums
    It seems the fileSystemWatcher is throwing an exception on a network share for being unavailable, so i'd suggest to double check that. might be that it stops on this error without a clear log entry.

    I've tried every combination i could think of, with both BASS & WASAPI settings and several buffer settings, but (beside a tiny buffer issue) i still can't reproduce this, and all my music files are on a network share also.
     
    Last edited:

    Requiem

    MP Donator
  • Premium Supporter
  • January 1, 2012
    586
    214
    Germany Germany
    Country flag
    This describes exactly what I'm experincing, though it also affects series watching from time to time as mentioned above.


    So that means it's not just the Music section giving issues. Start MediaPortal without any plugins enabled like the FritzBox Manager & MPSync stuff (since that's also throwing errors). So you can either start MP in Debug-Mode (from that Start Menu), or disable the plugins manually and see if that solves the problem. Might very well be a plugin that's causing the issues.
    I'll try that, thogh the FB error has been there for months (also placed a support question there but no answer to that), the error with MPSync was caused by a corrupted FanartHandler database, fixed that one. I'll try to reproduce the error in watchdog mode, but as it appears sporadically, this might take a while.
     

    volumia

    Portal Pro
    November 23, 2011
    100
    54
    whereever my feet take me...
    Netherlands Netherlands
    Country flag
    I checked on the network erros, but they had nothing to do with the files being used (music) at that point. Tried again today and noticed that it is always the second song in any list that seems to stop.
    Here's what happened when playing: The Four Seasons - Big girls don't cry.mp3 and on. No network errors or any other.... and it quit after 1:10 min., also the secong try.

    ----------------------------------------------->
    [2013-06-29 12:04:51,496] [Log ] [FileExistsCache Thread] [DEBUG] - InsertFilesIntoCacheAsynch: pre-scanning dir : \\haleysystems\root\multimedia\muziek\albums
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [DEBUG] - MediaInfoWrapper: isVideo:False, isDVD:False[enabled:False]
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [DEBUG] - MediaInfoWrapper: disabled for this content
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [INFO ] - g_Player.OnChanged()
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [INFO ] - RadioRecorded:OnPlayRecordingBackChanged Music \\haleysystems\root\Multimedia\Muziek\Oldies\The Four Seasons - Big girls don't cry.mp3
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [INFO ] - TvRecorded:OnPlayRecordingBackChanged Music \\haleysystems\root\Multimedia\Muziek\Oldies\The Four Seasons - Big girls don't cry.mp3
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [INFO ] - g_Player.Play(\\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3 Music)
    [2013-06-29 12:05:06,482] [Log ] [MPMain ] [DEBUG] - PlayerFactory: Successfully created player instance for file - \\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3
    [2013-06-29 12:05:06,483] [Log ] [MPMain ] [INFO ] - BASS: ---------------------------------------------
    [2013-06-29 12:05:06,483] [Log ] [MPMain ] [INFO ] - BASS: Creating BASS audio stream
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: Stream Information
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: ---------------------------------------------
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: File: \\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [DEBUG] - BASS: Type of Stream: BASS_CTYPE_STREAM_MP3
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: Number of Channels: 2
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: Stream Samplerate: 44100
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [DEBUG] - BASS: Stream Flags: BASS_MUSIC_FLOAT, BASS_STREAM_DECODE, BASS_UNICODE
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: ---------------------------------------------
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [DEBUG] - BASS: Registering stream playback events
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: Successfully created BASS audio stream
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: ---------------------------------------------
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - BASS: playback started
    [2013-06-29 12:05:06,528] [Log ] [MPMain ] [INFO ] - g_Player.OnStarted() \\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3 media:Music
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [DEBUG] - MediaInfoWrapper: isVideo:False, isDVD:False[enabled:False]
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [DEBUG] - MediaInfoWrapper: disabled for this content
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [INFO ] - g_Player.OnChanged()
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [INFO ] - RadioRecorded:OnPlayRecordingBackChanged Music \\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [INFO ] - TvRecorded:OnPlayRecordingBackChanged Music \\haleysystems\root\Multimedia\Muziek\Albums\Veronica's Top 100 - 1965\Righteous Brothers - You've lost that lovin' feelin'.mp3
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [INFO ] - g_Player.Play(\\haleysystems\root\Multimedia\Muziek\Oldies\The Four Seasons - Big girls don't cry.mp3 Music)
    [2013-06-29 12:07:30,355] [Log ] [MPMain ] [DEBUG] - PlayerFactory: Successfully created player instance for file - \\haleysystems\root\Multimedia\Muziek\Oldies\The Four Seasons - Big girls don't cry.mp3
    [2013-06-29 12:07:33,596] [Log ] [MPMain ] [INFO ] - BASS: ---------------------------------------------
     

    volumia

    Portal Pro
    November 23, 2011
    100
    54
    whereever my feet take me...
    Netherlands Netherlands
    Country flag
    Sure, will do next time! Nothing significant changed since the last time, so I figured to safe the space. Have the previous ones and my added info after that helped in pinpointing anything by the way?
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,465
    4,631
    45
    ::1
    Netherlands Netherlands
    Country flag
    Sure, will do next time! Nothing significant changed since the last time, so I figured to safe the space. Have the previous ones and my added info after that helped in pinpointing anything by the way?
    Unfortunately not :(
    Also the last log paste doesn't show anything useful. It shows 'Big girls don't cry' playing, and after that the next song (Top Gun bar song :) ) starts to play.
     

    volumia

    Portal Pro
    November 23, 2011
    100
    54
    whereever my feet take me...
    Netherlands Netherlands
    Country flag
    HomeY, actualy the logs may have given a hint.
    I was going over your remark about an "exception on a network share for being unavailable" in the back of my head and wondered what caused it since there were no actual network related problems.
    It took some time to figure out what caused the "FileExistsCache Thread" to show up in the first place. Found it and it's in the MediaPortal Configuration screen (see attached picture) under: GUI -> GUI settings -> Enable file existence cache. I unchecked it, the errors are gone in the logs and the music keeps playing without any glitches (or at least for the last hour).
    Could all this be caused bij some false negative registered by this feature that you know?
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M Music playback stops after certain files 1.19 0
    horned_reaper [solved] Music playback hangs General Support 58
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    horned_reaper [solved] 5012: Restart current music track General Support 13
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    globaldonkey Music Database Error Listen Music 1
    joecrow Music on Headphones Listen Music 7
    2BitSculptor MP 1.23.. music stops playing General Support 6
    Sarxas What Music Are You Listening To? OffTopic 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    BlueMax1916 [confirm] Music: Every 2nd track skipped MediaPortal 2 30
    N Music player help Listen Music 4
    N How to shuffle all my music, and how to sort by album artist General 4
    R MP 2.2 client spielt audio-titel kurz an und springt dann zum nächten Allgemeines Support- und Diskussionsforum 9
    joecrow Music: Fade Out not working 1.20 Pre Release 0
    E [Pending] Handling Multifile Cue Submit: code patches (MediaPortal/TV-Server/etc.) 56
    X Music : WASAPI only plays one track then stops General Support 1
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    Similar threads

























    Top Bottom