[Neues Plugin] Atmolight plugin

angie05

MP Donator
  • Premium Supporter
  • March 29, 2010
    141
    28
    anbei eine neue atmowin version:

    fix:
    - suspend/ resume should work now
    - gamma adjustment inverted (now you can use standard values like 2.20)
    - shutdown color should always work now
    add:
    - color adjustment/ calibration for the primary colors (red, green, blue)
    sum of the 3 red, 3 green and 3 blue values has to be lower or equal 255 (use "normalize CMS" after adjusting the primaries)

    link
     
    Last edited:

    Lightning303

    MP Donator
  • Premium Supporter
  • September 12, 2009
    798
    63
    Country flag
    - suspend/ resume should work now
    Hey, leider funktioniert das bei mir immer noch nicht. Oder ich verstehe dich falsch. Wenn mein Rechner aus dem Ruhezustand aufwacht, ist weiterhin die Verbindung zu meinem SEDU Board verloren. Ich muss also weiterhin entweder automatisch atmowin killen und neustarten, oder manuell neu connecten.
     

    Lightning303

    MP Donator
  • Premium Supporter
  • September 12, 2009
    798
    63
    Country flag
    Hey, leider funktioniert das bei mir immer noch nicht.
    Hmmm, bei mir funktioniert sowohl STR als auch STD. Ich habe mal eine Version mit ein paar Timing-tweaks versehen. Probier mal ob diese bei dir funktioniert.
    Scheint zu funktionierene, dank dir :).
    Leider habe ich jetzt ein Problem das meistens wenn ich ein Video stoppe die LEDs anbleiben in den Farben in denen sie grade waren. Das ist nicht immer so, aber zu 80% würde ich sagen. Hatte vorher die AtmoWin version aus der mpe installiert.
     

    angie05

    MP Donator
  • Premium Supporter
  • March 29, 2010
    141
    28
    das meistens wenn ich ein Video stoppe die LEDs anbleiben
    ich schau mal, aber Workaround ist einfach im SEDU Setup Tool "feste Farbe" = schwarz als Standardprogramm einzustellen. D.h. immer wenn das Sedu keine Daten erhält, schaltet es dann die LEDs aus.

    edit: wenn man das Medium stoppt, gehen bei mir zu 100% auch die LEDs aus. Ich kann "diesen Fehler" nicht nachvollziehen.
     
    Last edited:

    popy

    Super User
  • Team MediaPortal
  • Super User
  • July 3, 2011
    617
    28
    Country flag
    Hey Leute.

    Hab seit Update auf v1.4 Probleme mit atmowin/mp.
    Mediaportal stürzt öfters ab.
    Anbei die Logs. Das Error2 ist interessant.

    Kann mir bitte jemand helfen.

    Danke
    pOpY
     

    Schicksal

    Portal Pro
    February 7, 2010
    800
    18
    Country flag
    Ich hab da mal ne Frage:

    Ich habe nicht zu basteln und dachte sowas über einen Arduino wäre ein prima Bastelprojekt.
    Mein TV hängt an der Wand mit der schmalsten Halterung die ich gefunden habe.
    Rund herum ist Platz für die Beleuchtung, allerdings sind die Lautsprecher an der Unterseite press an der Wand,
    da ist nix mit beleuchten. Ist auch nicht so schlimm und WAF wird nicht geschmälert.
    Hab da mal ein Bildchen gebastelt wie es aussehen soll/wird.
    Atmolight.png

    Die wirklich wichtige Frage:
    Ist es möglich diesen unteren Bereich so zu definieren, dass auch der passende Teil des Bildes zum Beleuchten genutzt wird?
    Also weil ja oben und unten ungleiche Anzahl an LEDs haben und wenn nun unten 2/3 der LED Menge verwendet wird, soll nicht der komplette untere Rand des Bildes auf diese 2/3 komprimiert werden, sondern der Bildbereich bei den Lautsprechern einfach "ausgespart".
    Ich hoffe ihr versteht wie ich das meine. :D

    Wenn dies nicht geht, dann brauche ich mit dem Projekt erst gar nicht starten und kann mir das Geld für die LED Streifen sparen. Kosten ja auch einiges :(
     

    PrivotSponge

    MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    18
    BaWü
    Hi Schicksal,

    was dir vorschwebt funktioniert! Hab ich bei mir wegen dem Standfuß des TVs auch machen müssen.
    Ich habe insg. 112 LEDs. In Atmowin habe ich aber 120 eingestellt und 8 davon in der Mitte unten deaktiviert --> geht bestens.

    Es macht aber mehr Aufwand mit dem Verlöten der Streifen, da du ja 2 "Lücken" hast. Ich hab nur eine und konnte somit 1 Kette verwenden. Hab einfach links neben dem Standfuß angefangen mit aufkleben und rechts neben dem Standfuß aufgehört.

    Du musst halt vorher alles genau ausmessen.
     

    Schicksal

    Portal Pro
    February 7, 2010
    800
    18
    Country flag
    Zunächst einmal wird da nix mit verlöten schwer. Das kommt vielleicht falsch rüber in dem Beispiel. Oben und an den Seiten sind ganze Streifen. Unten fangen ziemlich direkt am Rand die Boxen an. Das wenige was übrig bleibt (zum Rand) benötige ich für die Streifen an der Seite, somit laufen die wirklich von ganz oben bis ganz unten. Also bleibt unten ein mittiger Streifen.

    Verstehe ich jetzt richtig, dass man einzelne LEDs in der Software ausschalten kann?
    Würde also bedeuten, wenn oben (als rechnerisches Beispiel) 50 LEDs sind und auch in der Software, dann würde ich unten in der Software auch 50 angeben. Da aber nur 30 physisch vorhanden sind, 10 Stück links und rechts ausschalten? Also für unten würden dann 50 berechnet, aber nur die 30 in der Mitte angesteuert?

    Dann stünde ja dem Projekt nichts mehr im Wege :)


    -------edit---------
    Wie viele LEDs/Meter sind denn nötig/sinnvoll?
    Von kleinen Abweichungen gibt es die Streifen mit ca 30LED/m oder 50LED/m.
     
    Last edited:

    PrivotSponge

    MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    18
    BaWü
    Also bleibt unten ein mittiger Streifen.
    [/QUOTE]
    Ich dachte, die LEDs müssten alle miteinander verbunden sein ? (Also in Reihe) Ist zumindest bei mir mit Sedu Board und den Flexbändern so...
    Ich habe diese hier: http://shop.led-studien.de/product_info.php/info/p56_LED-Flexband-digital-WS2801-Zuschnitt.html
    32 LEDs/m
    Ich habe mir das ganze fertig-verlötet zuschicken lassen und musste es nur noch aufkleben.

    In der Atmowin Software kannst du beliebig Kanäle deaktivieren. Man musst die fehlenden aber trotzdem mitzählen.

    Wieviel m bzw. LEDs sinnvoll sind lässt sich nicht sagen, da die Maße der Glotze ja nicht bekannt sind...
    Die Maße bei mir sind z.B.: 1230 mm x 710 mm
    Angebracht habe ich: oben 38 / links u. rechts jeweils 22 / unten 30 (insg. 112 St. bei 55 Zoll)

    50 LEDs/m sind, glaube ich, schon übertrieben! Brauchst ja dann ~100 Watt nur für das Ambilight :)
    Hell genug sind die auch (zumindest meine), außerdem wirst du die einzelnen LEDs sowie nicht mehr unterscheiden können, bzw. einen Unterschied an der Wand sehen.
     
    Last edited:
    Top Bottom