[solved] Passing ISO (-Path) to external Player without mounting it? (1 Viewer)

jimmyo

MP Donator
  • Premium Supporter
  • October 1, 2006
    89
    19
    Home Country
    Sweden Sweden
    Hi fLaSkin

    You have coded excacty what i need to get PowerDVD to work as I would like with MP.
    I have tried to build the dll myself without luck , my knowledge of the process is to limited.
    Any chance you could send the modified dll to me?


    /Jimmy
     

    fLaSkin

    Portal Member
    September 4, 2012
    11
    7
    33
    Böhl-Iggelheim
    Home Country
    Germany Germany
    Hey there!

    Because someone (Jimmy ;)) asked for it, I've uploaded the DLL for mediaportal (including my changes) in that post.

    Informations:
    That DLL is based on the latest stable release of mediaportal (1.8.1), the base has been taken from the main branch on GitHub.

    Thing(s) I've done:
    Options for outsourcing the mounting process to external player under the advaned options inside the moving pictures configuration.

    The DLL got zipped by me because of the file-upload restrictions inside the forum.
    Inside is just the DLL for replacing the "old" one under "[your installation-path]/plugins/windows/"

    Have fun using it, I hope it's working for you (all).

    Some feedback if it's doing what it should and what you want it to do, or if not and the bug is related to my changes, would be great ;)

    Cheers,
    fLaSkin
     

    Attachments

    • MovingPictures 1.8.1 external-mount-edit.zip
      495.6 KB

    jimmyo

    MP Donator
  • Premium Supporter
  • October 1, 2006
    89
    19
    Home Country
    Sweden Sweden
    Thanks for your work

    Have now tried the new dll and changed Advanced settings to Pre-mount = false.
    Blu-ray Movies works great in Moving Pictures without mounting and are handled by PowerDVD :)
    The only problem I get is that DVD Movies doesn't work if I set Pre-mount to false.
    Any suggestions why?

    /Jimmy
     

    fLaSkin

    Portal Member
    September 4, 2012
    11
    7
    33
    Böhl-Iggelheim
    Home Country
    Germany Germany
    Hey Jimmy!

    Glad to here that it's working (50/50) for you :D

    I got to say, that I never tested it with DVDs - I just don't have any more and only Store Blu-rays on my device :cool:

    Maybe here Kicks in some mediaportal configuration for Disks?
    Have you done any configuration for external Playback of Disks in the mediaportal configuration?

    If so, may you could try to disable that and test if now the Handling is completely done over the pre-mointing Settings.

    Cheers!
     

    jimmyo

    MP Donator
  • Premium Supporter
  • October 1, 2006
    89
    19
    Home Country
    Sweden Sweden
    Hi

    DVDs:
    I have now tried with and without Extternal Player configured in Media Portal.
    If I have set Pre-mount to True in Moving Pictures it works with internal and external player (PowerDVD) in Moving Pictures
    If I have set Pre-mount to False in Moving Pictures it doesn't work with either internal or external player (PowerDVD) in Moving Pictures
    I checked the Moving Pictures logs and I see that your code under Bluray/HD-DVD Playback affects DVD's. It sets , Mounted='False' in the logs when playing DVD's.

    So maybe a solution is to change the code so it only affects Bluray/HD-DVD Playback.

    /Jimmy
     

    Der_Bub

    MP Donator
  • Premium Supporter
  • June 17, 2008
    830
    60
    Cologne
    Home Country
    Germany Germany
    Hello Jimmyo,

    I have the pretty same Problem: Mounting an Image is only succesfull, if I use a AHK script to Start Power DVD (which runs until the movie/PowerDVD is closed).

    Unfortunatly if PowerDVD is started via script, the Navigation Bar of PowerDVD is allways on Top. I have to make a Mouse move with Keyboard/-pad, to get diaspear it. (A mouse move via script does not work either)

    So I'm very interested in your solution: With the new Moving Pictures Parameter and direct start of PowerDVD from it, the Images aren't mounted/started by PowerDVD (manually drag&drop works fine). Which Settings do you have in Moving Pictures?

    Is an Image/Movie automatically started after selecting it in Moving Pictures?

    Thanks allot!

    Best wishes
    BERND
     

    Users who are viewing this thread

    Similar threads

    Ok i can't test now and not sure if i will able too (Nvidia card on my side) but the windowed mode is maybe related to recent change to have a proper OSD and video size when starting 4K video etc. (bug discovered from @GeYe ) About the UI lazzy lol, MP is set to running @24Hz on my side so for me i have adapted my eyes surely lol. In...
    Ok i can't test now and not sure if i will able too (Nvidia card on my side) but the windowed mode is maybe related to recent...
    Hi I have upgraded to 1.16.0 Pre Relase recently and enabled madvr hoping I could play 3D Bluray .iso without a need to use...
    Replies
    4
    Views
    5K
    Guys, I've been a long time MP1 user but I'm migrating to a Server/Client setup where I'll have one machine running Server & Client (Main HTPC), and another machine running Client Only (Bedroom HTPC). For this architecture, I'm testing out MP2 since it seems to be able to do this network/sharing natively. I have a lot of BD ISO's...
    Guys, I've been a long time MP1 user but I'm migrating to a Server/Client setup where I'll have one machine running Server &...
    Guys, I've been a long time MP1 user but I'm migrating to a Server/Client setup where I'll have one machine running Server &...
    Replies
    0
    Views
    1K
    I'm looking for some help from someone who's using Cyberlink PowerDVD as the External Blu-ray Player with MovingPictures. I'm migrating from TotalMedia Theatre, which I've been using for almost 6 years now with MediaPortal/MovingPictures. I recently upgraded my Windows 8.1 HTPC to Windows 10, and TotalMedia Theatre is not only not...
    I'm looking for some help from someone who's using Cyberlink PowerDVD as the External Blu-ray Player with MovingPictures. I'm...
    I'm looking for some help from someone who's using Cyberlink PowerDVD as the External Blu-ray Player with MovingPictures. I'm...
    Replies
    0
    Views
    1K
    Experiencing a strange issue. With my MediaPortal 1.13, on my Windows 10 HTPC, I use MovingPictures for movies, and have Cyberlink PowerDVD 15 Ultra setup as the external player for ISO's. This combination works flawlessly - no problems. All my BD & DVD ISO's launch in PowerDVD, remote control works fine & everything works...
    Experiencing a strange issue. With my MediaPortal 1.13, on my Windows 10 HTPC, I use MovingPictures for movies, and have...
    Experiencing a strange issue. With my MediaPortal 1.13, on my Windows 10 HTPC, I use MovingPictures for movies, and have...
    Replies
    0
    Views
    545
    Thank you for giving this your time; I appreciate it. Please take your time. Logs attached. Screenshot showing DVD Discs / Images Player setup correctly: Screenshot showing Virtual Drive setup correctly: Screenshot showing Videos plugin enabled: Thanks again!
    Thank you for giving this your time; I appreciate it. Please take your time. Logs attached. Screenshot showing DVD Discs /...
    I was baffled today to realize MP-TVSeries doesn't seem to use external player to launch ISO's. I have the virtual drive & tmt5...
    Replies
    9
    Views
    1K
    Top Bottom