PC wont go to standby

robcarter
Country flag

Portal Pro
February 19, 2010
99
8
Home Country
England England
Hi

tried powercfg -requestsoverride driver \FileSystem\srvnet system, but the computer is refusing to goto standby, I have file and printer sharing enabled but that shouldn't stop powerdown.
Log:
[2013-11-28 09:45:12,661] [Log ] [PS StandbyWakeup] [DEBUG] - PS: System is idle and may go to standby
[2013-11-28 09:45:12,661] [Log ] [PS StandbyWakeup] [DEBUG] - PS: Active standby is disabled - standby is handled by Windows
[2013-11-28 09:45:12,676] [Log ] [PS StandbyWakeup] [DEBUG] - PS: Requests preventing Windows standby: [DRIVER] \FileSystem\srvnet, [DRIVER] Legacy Kernel Caller
As a last resort, I tried forcing standby in tvserver settings by ticking 'PowerScheduler++ Forces System to go to Standby when idle' this seems to have sorted the problem, but I'm still not a sure why windows won't shut itself down, and are there any downsides to using this method?
 

stanleywinston

Portal Member
October 7, 2013
21
1
Home Country
United Kingdom United Kingdom
Hi
Not sure if you are still having these issues but I've been having the same thing and I might have actually got mine sleeping now (although to be fair I'd thougt I'd fixed this many times before)
Firstly there may be two issues here. Many people are reporting issues with homegroup that I think manifests itself as the [DRIVER] \FileSystem\srvnet thing. The cure for that seems to be getting every pc in the house turned on and sharing on the same homegroup and then disabling the whole thing.
The one that was really bugging me was the [DRIVER] Legacy Kernel Caller one. Many things point at doing a REQUESTSOVERRIDE but that never seemed to work for me.
I found out that the legacy driver in question was the TV card. And all it was saying really was the TV card was in use. No idea why but my TV card seemed to be in constant use due to EPG grabbing. That is the conclusion that I came to anyway as, when I disabled the EPG grabbing (when idle and when timeshifting) the PC went straight to sleep (after the 15 minutes). I didn't work out why EPG grabbing seemed to be endless (my EPG is populated just fine the parameters were on default). But I'm just using the wake PC for EPG grabbing in the powerscheduler menu and hopefully that'll mean that it will continue to keep up to date.
 

robcarter
Country flag

Portal Pro
February 19, 2010
99
8
Home Country
England England
Hi
I used the tvserver setting "PowerScheduler++ Forces System to go to Standby when idle" but I realise that that isn't an ideal way to do things, I noticed that both the kernel legacy process and the netsrv process preventing the standby disappeared when the TV service was stopped, so your idea about the epg grabber may be right. as regards the homegroup, I thought mine was disabled, i have the network set to 'work place' I did notice if homegroup was the problem.
 

stanleywinston

Portal Member
October 7, 2013
21
1
Home Country
United Kingdom United Kingdom
My understanding of the homegroup problem is that you can have it even if homegroup is disabled as it can be other PCs on the network polling for a former member of a homegroup. think it's only relevant if any of the PCs are on windows 8 though as that seems to set up and enable a homegroup by default on installation so if you've never had a homegroup or windows 8 then that is probably not your issue. Apparently you can test for it by just unplugging the network cable and see if it goes away. Netsrv might also be related to standard file shares as well (I think).
 

robcarter
Country flag

Portal Pro
February 19, 2010
99
8
Home Country
England England
Hi,
An update: I diagnosed my problem to my TBS6820 TV card, if I stop tv server, disable it in device manager, then restart tv server, the PC goes to standby correctly, if I have it enabled and the tv server stopped the pc goes to sleep correctly. so not really sure what to do now. is media portal 1.5 likely to be the problem, as It worked with 1.4.
The legacy kernel caller message seems to be caused by this card.
any suggestions welcome
 

stanleywinston

Portal Member
October 7, 2013
21
1
Home Country
United Kingdom United Kingdom
are you sure it is not just that the card is in constant use doing epg checking. That seemed to be the issue with mine. If you disable all epg updating does the legacy caller disappear?
 

robcarter
Country flag

Portal Pro
February 19, 2010
99
8
Home Country
England England
Hi
I unticked 'update epg whilst idle'
epg1.jpg

And the pc went to standby - Success!, however surely this shouldn't effect standby as there is an option in power scheduler to ignore epg updating:
epg2.jpg

If the 'Do not put computer to sleep while grabbing epg' box is unticked surely the grabbing while idle should be ignored when going to standby?
 

stanleywinston

Portal Member
October 7, 2013
21
1
Home Country
United Kingdom United Kingdom
i wouldn't get too excited. It worked for me for about a day before the problem returned. I now have nothing in powercfg and no sleeping
 

Luca Brasi
Country flag

MP Donator
  • Premium Supporter
  • November 14, 2007
    1,025
    48
    Home Country
    Germany Germany
    Hey guys,
    i've been struggeling with this shit for years for all the differnet reasons you mentioned above.
    Right now I seem to have fixed it by disabling epg grabbing but we will see...

    I noticed one thing while fiddeling with it. I had seen my one card dedicated to epg grabbing shown highlighted in red in the manual control window in the tvserver config. Even when no grabbing was going on and grabbing while idle was disabled. Didn't give much about it but today I decided to assign another card to epg grabbing for testing. Now this one got the red flag in the manual control. After that I disabled epg grabbing completely and the red disappeared. PowerScheduler and powercfg /requests were no more showing srvnet or Legacydevicehandler preventing stand by and the sys went to sleep as it was supposed to.

    So I am wondering if there really might be a bug in the tvserver and I could contact the devs about it.
    Could you guys please try to confirm the scenario?


    For anyone coming to this thread because of problems with your system not going to sleep, try theese steps (this is for win7/8):
    - Go to an administrative console (win-key>type "cmd">right-click on the cmd.exe>run as administrator)
    - type powercfg /requests
    - Look at the components preventing the sleep. Some might be ok like the tvservice (this depends on your settings in the powerschduler) or teamviewer, winbackup... Others like srvnet and Legacydevicehandler are likely to cause trouble. So...
    - type
    powercfg -requestsoverride driver \filesystem\srvnet system>Enter
    powercfg /requestsoverride driver srvnet system>Enter
    powercfg -requestsoverride driver Legacydevicehandler system>Enter
    reboot
    >most likely this won't solve the issue but you can check if it did for the Legacydevicehandler in the powerschduler conifg or by powercfg /requests .
    Screenshot@mmignote 2014-02-19 12 54 00.jpg
    srvnet is known to show up even though it isn't preventing sleep any more. You never know...
    - To test if it helped do the following: Set sleep after time to something small, maybe 1 minute, fire up mp and leave the machine alone for a couple of minutes. Make sure no recording is running, no other client is playing media and so on. Hopefully the sys will go to sleep, if not...

    - So... if the problem still persists try the following tips below, reboot after each tip, check powercfg /requests and see if anything changed. Also check the logs from powerschduler and then repeat the test above.

    - Disable EPG Grabbing in the tv server config completely for testing purposes, reboot and test.
    - Solved? If yes, try to enable it just for "while timeshifting", reboot and test..
    - Problem back? Disable completely again and set Powerschduler to do the grabbing on a schedule.
    - Follow the instructions here: External Link
    then go to energy settings and make sure that
    Screenshot@mmignote 2014-02-19 13 02 35.jpg
    and
    Screenshot@mmignote 2014-02-19 13 05 15.jpg
    are set to enabled.
    You might notice that the screenshots are not from an english system. I don't have one and I suppose that you're capable of dealing with this...
    - Disable this homegroup crap on all machines. (>Set the two homegroup services to disabled)
    - If you ever have configured the homegroup crap on any machine in your network enable it on all machines, add all machines to the same crappy homegroup and let it run for some time like that. Then disable the homegroup crap on all machines and reboot them.
    - Disable media sharing on all machines as discribed here: External Link

    This is all I came up with after being harassed by sleep problems for years (the htpc, not me... ) If anyone can add some hints or give deeper insight I'd be very greatful...
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom