[confirm] Problem playing recorded TV in RC2 (1 Viewer)

disaster123

MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: Problem playing recorded TV in RC2

    I've now completely uninstalled MP (using MP full uninstall) and reinstalled RC2 - but still the same problem.
     

    Fredvr

    Portal Member
    February 27, 2009
    8
    0
    Netherlands Netherlands
    just solved mine...

    downloaded the latest media splitter\ffdshow and registered mpcvideodec.ax (from the mpc standalone filters)
    in media portal ic selected MPC-HC as H264 codec and ffdshow for mpeg.
    in ffdshow I disabled the H264/AVC codec

    everything looks fine now!
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: Problem playing recorded TV in RC2

    Fredvr
    you must had definitely a different problem. As your solutions can't help if MP cannot load it's own TsReader.ax
     

    Fredvr

    Portal Member
    February 27, 2009
    8
    0
    Netherlands Netherlands
    yep That's what I realize aswell. In my case it was just a matter of having the (in)correct codecs installed apparently.. :oops:
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Re: AW: Problem playing recorded TV in RC2

    I've now completely uninstalled MP (using MP full uninstall) and reinstalled RC2 - but still the same problem.
    Hi,

    I don't see any logs from you, or an indication of what codecs you are using. My gut feeling (based on the fact that MP is working fine for most people) is that there is something about your system that MP does not like. However, we need far more information if we are to sort it.

    Mark
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: Problem playing recorded TV in RC2

    elliottmc
    Correct i know that i haven't posted logs - I'm sorry. But the only error you'll see is:
    Code:
    2010-04-15 15:40:58.315200 [Info.][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Retrieving the COM class factory for component with CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} failed due to the following error: 800700c1.
    This error has absolutely nothing todo with codecs - as it is only related to the tsreader.ax filter which is part of MP so we all use the same filter. The funny part is that inserting the tsreader filter works fine when watching live TV. For me it seems that TSReaderPlayer handles both cases (watching live tv or starten a .ts file) differently? Could that be?
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Re: AW: Problem playing recorded TV in RC2

    @elliottmc
    Correct i know that i haven't posted logs - I'm sorry. But the only error you'll see is:
    Code:
    2010-04-15 15:40:58.315200 [Info.][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Retrieving the COM class factory for component with CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} failed due to the following error: 800700c1.
    This error has absolutely nothing todo with codecs - as it is only related to the tsreader.ax filter which is part of MP so we all use the same filter. The funny part is that inserting the tsreader filter works fine when watching live TV. For me it seems that TSReaderPlayer handles both cases (watching live tv or starten a .ts file) differently? Could that be?
    I have absolutely no idea. This would require one of the experts to comment.

    However, something in your full logs might give more of a clue as to why this is happening for you. What sort of recordings are you trying to play (h264 or mpeg2)? Does it even matter? Do any recordings ever play fine?

    For me, playing recorded TV is not a problem, so there clearly is something about your system, and I realise that you know more about coding than I ever will, but please humor me and post your complete logs and a description of the steps you took in order to see the failure. Please also include in this a successful attempt to start live TV so we can see a comparison.

    Best wishes,

    Mark
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: Problem playing recorded TV in RC2

    OK will post logs tonight. It doesn't matter if h264 or mpeg2. It only matter that tsreader is in use => .ts file type.
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: Problem playing recorded TV in RC2

    nice to see that there are more people having this problem. Perhaps we will find some things we all have together. I'm using Win 7 x64 with ATI 10.5 preview drivers and MP RC2. What are you using?

    EDIT1:
    OK i also found out that it is working fine, when i start the SAME file through MySeries. So there must be something wrong with the recording section in MP.

    EDIT2:
    I also tried different tsreader.ax files from the last month - no change. My tip is a change in the basetsreaderplayer stuff of MP. My tipp is a change in MP/Core/Player
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    T Mp 1.20 won't play .265 hdr capable file......settings problem? logs inc. Watch / Listen Media 0
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 12
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    Top Bottom