[confirm] - Problem playing recorded TV in RC2 | Page 4

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by gyring_eddy, April 15, 2010.

  1. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: Re: AW: Problem playing recorded TV in RC2

    I'm already using actual SVN builds.

     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. elliottmc
    • Team MediaPortal

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Re: AW: Re: AW: Problem playing recorded TV in RC2

    Right, so with current SVN (care to tell us the number?) you cannot play recorded TV with a self-compiled normal build, but you can with a debug build? Is this correct?

    Look, I don't mean to offend you, but if you want the team to take this issue at all seriously, you need to be making clear bug reports and follow the guidelines. Right now you are drip-feeding us information and trying to decide what we do or do not need, which is not helpful.

    I guess what we might need is full logs for the same situation using the debug and non-debug core.dll, for comparison. I know that it might not show anything, but it is the best chance we have. Please post the full logs, and not the snippits of the log that you personally think might be the most help.

    Mark
     
  4. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: Problem playing recorded TV in RC2

    elliottmc
    you're right i'm really sorry this wasn't my intention.

    I'll try to explain a little bit more clearly.
    1. test standard RC2 => recordings don't work, mptvseries works, livetv works - after starting livetv or mptvseries first recordings work too
    2. test complete full uninstall of RC2 + reinstall => the same
    3. test compile of SVN 25667 + reinstall => the same
    4. test replace release core.dll SVN 25667 with debug core.dll SVN 25667 => WORKS
    5. test verfiy: replace the debug core.dll with standard core.dll => doesn't work again
    6. test verfiy: replace the release core.dll with debug core.dll => WORKS
     
  5. elliottmc
    • Team MediaPortal

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Re: AW: Problem playing recorded TV in RC2

    Thanks for clarifying.

    Could you also check one more thing? What happens if you try to turn on live TV after rebooting? Does it work okay the first time, or just the second time?

    If you try to play back a TV recording, does it fail the first time, or every time?

    The reason I ask is that on two of my client systems, TV does not work properly the first time after reboot (audio plays but no picture) but it works fine after that. The team is looking into this issue. It is conceivable that your problem is related to this.

    Mark
     
  6. Golf4

    Golf4 Portal Pro

    Joined:
    August 18, 2006
    Messages:
    2,673
    Likes Received:
    139
    Location:
    Dunkeldeutschland
    Ratings:
    +213 / 1
    Home Country:
    Germany Germany
    Show System Specs
    AW: Problem playing recorded TV in RC2

    Moin moin,
    sorry, the new compilet core.dll does not run :(
    I cannot open mediaportal.exe and also the mpconfig.exe
    It is produced also none mp-logfile.

    G4
     
  7. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: Problem playing recorded TV in RC2

    Golf4
    in my test i was using an actual SVN build - sorry i forgot that. So it means my compiled core.dll isn't any longer compatible with RC2. Sorry.

    elliottmc
    > Could you also check one more thing?
    Shure.

    > What happens if you try to turn on live TV after rebooting? Does it work okay the first time, or just the second time?
    Live TV plays fine - doesn't matter if it is after reboot, standby or whatever.

    > If you try to play back a TV recording, does it fail the first time, or every time?
    Everytime until i start livetv or a .ts file through MovingPictures or MPTvSeries.
     
    • Like Like x 1
  8. gyring_eddy
    • Premium Supporter

    gyring_eddy MP Donator

    Joined:
    January 2, 2008
    Messages:
    19
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Apologies, I started the thread then neglected to keep up with the discussion.

    disaster123: No, I didn't fix it. I've just been living with it till I get a moment to tinker. I'm glad you had some success with your debug core.dll - pity I'm still using the original RC2 build. Which SVN are you using now?

    elliottmc: I've attached a new log containing:
    1. an unsucessful attempt at playing a tv recording,
    2. subsequent sucessful initiation of live tv,
    3. successful attempt at playing the recording that failed in 1.

    Out of curiosity I tried moving a .ts file from my recordings folder to my videos folder and playing it from the videos screen in MP - it played fine. Live TV also works first time after MP startup, as do other types of video.

    I think my codecs could still be to blame - I've been having some problems with h264/AAC playback since switching to RC2 which may or may not be related.

    Thanks again.
     
  9. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: Re: Problem playing recorded TV in RC2

    Yes it seems to be a bug in the recording section. Your result is what i've seen too. It's working fine from MovingPictures, MPTvSeries, ...
     
  10. arion_p
    • Team MediaPortal

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    Perhaps not related but: is anyone having this issue not running x64?
     
  11. Golf4

    Golf4 Portal Pro

    Joined:
    August 18, 2006
    Messages:
    2,673
    Likes Received:
    139
    Location:
    Dunkeldeutschland
    Ratings:
    +213 / 1
    Home Country:
    Germany Germany
    Show System Specs
    AW: Problem playing recorded TV in RC2

    Hi Disaster123,
    vielen Dank für deine SVN build 25683.
    Die Corel.dll (1.0.6.12592) habe ich ausgetauscht.
    Der Fehler ist nun beseitigt.
    Auch der Thumnailer (mtn.exe) funktioniert nun wieder für HD-Aufnahmen.
    Der Senderwechsel von sd zu hd und umgekehrt geht sehr flüssig.
    Die sd und hd Wiedergabe läuft ohne Stottern.

    disaster123,
    Thank you for your SVN build 25683rd
    The Corel.dll (1.0.6.12592) I replaced.
    The error has now been removed.
    Even the thumnails (mtn.exe) now works again for HD recording.
    Also the channel changing from sd to hd or vice versa is very fluid.
    The sd and hd playback runs without stuttering.
    (Thanks google translator ;))

    By G4
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!