[Help Us!] RTSP streaming library update (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    • Thread starter
    • Moderator
    • #31
    Everything is very quiet here. Should I assume that means there are no problems to report? :)
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,360
    4,987
    France - IDF
    France France
    Country flag
    In testing...
    But the olwroost branch. For now not crashing.
    I try to check my issue before say it's filter issue
     

    Nervesagent

    Portal Pro
    February 26, 2014
    150
    19
    40
    Denmark Denmark
    Works as expected. Even in mixed environment it worked (old filter client, new filter server), now both on new filter. Even after upgrading server and client to Windows 10 it worked.
    Only thing that doesnt work is my friggin' Fritz DVB-C -> IP tuner.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    • Thread starter
    • Moderator
    • #36
    Only thing that doesnt work is my friggin' Fritz DVB-C -> IP tuner.
    I've been waiting for an update and/or new log files from you because that's what you said you were going to do... ;)

    Existing problem with scanning my Fritz Dvb-c network tuner channels has not been solved, but I will look a little more into it and post some new logs here:
    https://forum.team-mediaportal.com/t...n-fritz-dvb-c-wlan-repeater-m3u.130730/page-4
    I still think manually adding the url, tsid and pid will get me there.
     

    Nervesagent

    Portal Pro
    February 26, 2014
    150
    19
    40
    Denmark Denmark
    Only thing that doesnt work is my friggin' Fritz DVB-C -> IP tuner.
    I've been waiting for an update and/or new log files from you because that's what you said you were going to do... ;)

    Existing problem with scanning my Fritz Dvb-c network tuner channels has not been solved, but I will look a little more into it and post some new logs here:
    https://forum.team-mediaportal.com/t...n-fritz-dvb-c-wlan-repeater-m3u.130730/page-4
    I still think manually adding the url, tsid and pid will get me there.
    I did some new tests today and posted some new logs and screens for you to get a better understanding of the issue.
    Since my previous logs on Oct. 16 I've upgraded to Windows 10 (no problems with that so far, just the same issue with Fritz)
    Thanks for your help again MM!
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    • Thread starter
    • Moderator
    • #38
    Just a quick update to let you all know that it's possible that this update will be included in MediaPortal 1.14 PR. Therefore: if anybody can show just cause for this update to not be included, speak now or forever hold your peace... :love:
     

    yrehan

    Portal Member
    April 14, 2012
    31
    6
    44
    Sweden Sweden
    Hi, I have tested your branch after merging it to latest master. Working great. My server and client both are running Windows 10 x64. Great work! Thank you!

    Br,
    Yrehan[DOUBLEPOST=1451945094][/DOUBLEPOST]BTW, December 22nd version of Live555 is already available (http://www.live555.com/liveMedia/public/live.2015.12.22.tar.gz). Not sure if it worth the trouble but I tried it after rebasing your branch on top of it. It works without issues as well. Only require following patch to build though:

    diff --git a/DirectShowFilters/LiveMedia555/liveMedia/include/GenericMediaServer.hh b/DirectShowFilters/LiveMedia555/liveMedia/include/GenericMediaServer.hh
    index 7f88fc6..934e8a9 100644
    --- a/DirectShowFilters/LiveMedia555/liveMedia/include/GenericMediaServer.hh
    +++ b/DirectShowFilters/LiveMedia555/liveMedia/include/GenericMediaServer.hh
    @@ -156,7 +156,6 @@ protected:
    Port fServerPort;
    unsigned fReclamationSeconds;

    -private:
    HashTable* fServerMediaSessions; // maps 'stream name' strings to "ServerMediaSession" objects
    HashTable* fClientConnections; // the "ClientConnection" objects that we're using
    HashTable* fClientSessions; // maps 'session id' strings to "ClientSession" objects
     
    Last edited:

    Charlie TV

    MP Donator
  • Premium Supporter
  • February 22, 2014
    81
    27
    United Kingdom United Kingdom
    Country flag
    Hi guys,

    I installed this on my setup, I have one TV server in the loft with all the TV cards (USB on a powered hub) and two clients (Intel NUCs). I left both clients streaming live tv overnight on different channels for maximum stress and when I got up this morning I noticed that both clients had disconnected from the server. I pulled logs from the server and one client.

    Connectivity is Wired LAN 1Gb.

    Hope this helps, let me know anything you want me to test.

    Cheers
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C streaming out UDP instead of RTSP Newcomers Forum 0
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    R RTSP Streaming Not Working General 20
    AberDino 4k TV Stutter with RTSP General Support 7
    S rotierende disk in streamed mp Skin Modifikationen 30
    C Streaming/transcoding MP2 vs MP1? General 1
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    P Streaming MediaPortal 1 Talk 5
    P Streaming to two clients from the same card Newcomers Forum 1
    L Non-PC device streaming... Newcomers Forum 1
    raffe How to add 500+ streams? OnlineVideos 1
    R Heavy pixelation on HD OTA Streams Installation, configuration support 1
    C Recording back to back shows from IPTV streams General Support 8
    T Missing sound in online streaming service (SVTPlay) General Support 3
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    doskabouter Black screen while watching some iptv streams General Support 2
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    jmarc Recording IPTV streams General Support 1
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    C Is there a Tuner Stream Failure Alarm Plugin? MediaPortal 1 Plugins 1
    P [solved] MediaPortal 2 Won't stream HDHR Dual General 1
    M.Hulot Streamed MP behält gewählte Ansicht nicht bei Allgemeines Supportforum 4
    Top Bottom