SAT>IP-Server XORO in MPO einbinden (1 Viewer)

harryzwo

Portal Pro
July 25, 2006
714
64
Germany Germany
Country flag
Ich möchte nochmal ein schon öfter behandeltes Thema angehen

Ich versuche einen Sat-IP Server Xoro in Mediaportal einzubinden.
Als m3u benutzte ich die von Xoro empfohlene ChannelListe 'http://www.satip.info/Playlists/ASTRA_19_2E.m3u'. In VLC funktioniert die gut.

In der Tvserverconfig erhalte ich beim Test schon die Meldung 'no mediaportal iptvfilter and url source splitter is loaded'
Wenn ich einen Suchlauf start ergeben alle Einträge 'No signal'.
Im Ereignisprotokoll sieht alles gut aus.

Ich gehe davon aus, wie in anderen Post gelesen, dass es sich um einen Fehler in der m3u handelt.
Vielleich hat jemand eine Idee was ich noch ausprobieren kann.
 

Attachments

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    Ich bin gerade dabei, eine aktualisiere Testversion der TVEngine "3.5" mit Sat>IP-Support fertig zu stellen. Allerdings läuft diese ausschließlich im MP2-Server als Plugin, eine Standalone- oder MP1-Version gibt es nicht.
    Mit der Version werden Sat>IP-Geräte als Tuner gefunden und man muss keine .m3u verwenden. Ich konnte diesen Stand schon mit verschiedenen Geräten testen, er funktionierte ziemlich gut.
    Wenn du Interesse hast, kann ich in den nächsten Tagen eine Plugin-Version zum Testen bereitstellen.
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    Ja. Das würde ich gerne mal testen. Wie weit ist die TVEngine "3.5"? Kann ich die bei der Installation von MP2 auswählen? Vor einiger Zeit habe ich MP2 testweise installiert und ich glaube es wurde automatisch die TVEngine "3.0" installiert.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    Ok, dann wollen wir mal: hier gibt es eine neue Plugin-Version zum Download. Bitte die Installationsanleitung auf der Seite beachten (SlimTV.Service3 entfernen und neues Plugin reinkopieren).

    Das enthaltene SetupTV zum Sendersuchlauf benutzen. Wenn die Sat>IP-Geräte gefunden werden, sieht es in etwa so aus:
    upload_2019-2-18_17-46-6.png


    Ich habe hier eine AVM Fritz!Box 6490 Cable mit 4 Tunern und einen Fritz!Repeater DVB-C mit 2 Tunern.

    Es gibt derzeit noch ein bekanntes Problem mit dem Sendersuchlauf, zumindest bei mir. Dabei werden Tuning-Details überschrieben, so dass die PmtPID "0" gesetzt wird (was falsch ist). Umgehen kann man das, indem man einzelne Transponder scannt.

    Zuerst also schauen, ob das Gerät und die Tuner gefunden werden und dann mal einen Sendersuchlauf starten, wie es sonst auch bei MP1 erfolgt.

    Noch eine Warnung:
    Die Version ist eigentlich schon ein paar Jahre alt, hat aber ein paar Bugfixes und Modernisierungen erfahren. Das ganze dient vor allem dem Test der Sat>IP-Funktion.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Ich hoffe sehr, das es mit der neuen TVE Version klappt.

    Aber falls nicht, MP benötigt "unübliche" m3u, leider... Da muss man immer Hand anlegen, sonst wird das nichts. MP erwartet folgendes bei den URL in der Playlist:

    http://192.168.1.100/?&?src=1&freq=11362&msys=...

    wohingegen eine "Standard- m3u" so aussieht:

    http://192.168.1.100/&src=1&freq=11362&msys=...

    Der "Rest" ist aber identisch, wobei die IP Adresse natürlich von deiner Konfiguration abhängt. Mein SAT>IP Router (Triax TSS400) hat eben die IP 192.168.1.100.

    Was dieser Quatsch mit den zwei zusätzlichen "?" soll, weiß ich nicht, ist aber leider nun mal so... Die m3u lässt sich aber mit jedem besseren Editor schnell ändern. Es muss aber auch tatsächlich geändert werden, sonst läuft das nicht mit MP (egal ob MP1 oder MP2)..
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    @morpheus_xx

    ich habe MP2 neu installiert und bin wie beschrieben vorgegangen. Beim Schritt:
    Execute SetupTV from folder: C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service35\SetupTv\SetupTV.exe and do a channel scan as known from MP1
    geht es nicht weiter, da kein TV-Server gefunden wird. Ich gehe mal davon aus, dass MP1 nicht installiert sein soll.

    @Lehmden

    in meiner m3u stehen RTSP-Adressen.
    Die sehen so z.B. für 'Das Erste' aus

    rtsp://192.168.178.31/?src=1&freq=11494&pol=h&ro=0.35&msys=dvbs2&mtype=8psk&plts=on&sr=22000&fec=23&pids=0,17,18,5100,5101,5102,5104
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    Execute SetupTV from folder: C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service35\SetupTv\SetupTV.exe and do a channel scan as known from MP1
    Kurze Frage: hast du nach dem Ausstausch der Plugins den MP2-Server-Dienst neu gestartet? Das geht über das Tray-Icon, Rechtsklick, Dienst starten.
    Zweiter wichtiger Punkt ist, dass das SlimTV.Service3 aus dem Plugin-Verzeichnis entfernt wurde. Wenn nicht, werden Konflikte erkannt und keins von beiden aktiviert.
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    ja MP2-Dienst vor kopieren von verz. 3.5 und löschen Verz. 3.0 gestoppt und danach wieder gestartet. Allerdings habe ich MP1 und MP2 vorher deinstalliert. Bei MP1 habe ich die erste Variante gewählt(die wo nicht alles komplett deinstalliert wird). Ich hole gerade eine Sicherung zurück und werde alles komplett deinstallieren und dann noch einen Versuch starten MP2 zu installieren.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    Hi.
    in meiner m3u stehen RTSP-Adressen.
    Das muss geändert werden. MP kann nur HTTP, nicht RTSP für den IPTV "Tuner".

    rtsp://192.168.178.31/?src=1&freq=11494&pol=h&ro=0.35&msys=dvbs2&mtype=8psk&plts=on&sr=22000&fec=23&pids=0,17,18,5100,5101,5102,5104

    muss in:

    http://192.168.178.31/?&?src=1&freq...22000&fec=23&pids=0,17,18,5100,5101,5102,5104

    geändert werden, sofern dein Xoro die IP 192.168.178.31 hat... Sonst musst du auch noch die IP anpassen. Das sollte sich aber mit der "Ersetzen" Funktion von z.B. Notepad++ im ganzen Dokument in einem Rutsch erledigen lassen. "rtsp://192.168.178.31/?" durch "http://192.168.178.31/?&?" ersetzen lassen und gut ist. Die neue m3u aber unbedingt unter einem anderen Namen abspeichern, damit im Zweifel das Original noch vorhanden ist.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    rtsp://192.168.178.31/?src=1&freq=11494&pol=h&ro=0.35&msys=dvbs2&mtype=8psk&plts=on&sr=22000&fec=23&pids=0,17,18,5100,5101,5102,5104

    muss in:

    http://192.168.178.31/?&?src=1&freq...22000&fec=23&pids=0,17,18,5100,5101,5102,5104
    Das kann ich so nicht bestätigen. Der IPTV-Support kann RTSP nutzen.

    Ich würde aber gerne erst den einen Weg testen, damit wir nicht zuviele Dinge gleichzeitig ändern und versuchen.
    Ich hole gerade eine Sicherung zurück und werde alles komplett deinstallieren und dann noch einen Versuch starten MP2 zu installieren.
    Benutze auf jeden Fall MP2.2 als Basis, führe die Schritte nochmal aus und wenn es nicht funktioniert nutze bitte den MP2-LogCollector, um die zur Diagnose nötigen Logfiles zusammenzustellen. Hänge die erzeugte Zip-Datei hier mit an.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    H SAT>IP-Server Kathrein unter TV3.5 Allgemeines Support- und Diskussionsforum 39
    Golf4 DVB-IP über Fritzbox - m3u-Senderliste Allgemeines Support- und Diskussionsforum 33
    K 1&1 IP-TV TV / Streaming 16
    J Kein Rtl, Sat 1 Pro 7 ... mehr TV / Streaming 0
    W Keine SD Sender mehr wie Pro 7, SAT 1 RTL Allgemeines Support- und Diskussionsforum 4
    K sudden complication watching recorded TV Newcomers Forum 6
    Lehmden General Sat>IP Basics and TVE TV Engine 10
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    A VB-IP SPAIN Movistar plus tunning details (Update 26 dec 2018) Submit: EPG-Grabbers and tuningdetails 1
    porky996t DVB Sat card possibly failed General Support 1
    A DVB IP Crash on Scanning - 1.20 General Support 0
    J Use IP address of NAS in network path for Recorded TV General Support 8
    Y TSS 400 MKII SAT>IP WDR HD Lokalzeit und EPG Problem TV / Streaming 18
    catalpa ...immer mal wird der Server abgekoppelt :( Allgemeines Support- und Diskussionsforum 0
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 1
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    Top Bottom