SplashScreen hangs when no audio device available (1 Viewer)

peque

Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    • Thread starter
    • Moderator
    • #31
    It's really easy to reproduce. No audio device in system, and start MP.

    In my case is very important because I've got my HTPC 24x7 up and running, and I automatically restart it every night so I don't have to deal with some MP bugs that appear after some days of usage... Now I can't restart it because my AVR is off, no other audio device is present, and thus MP hangs... :(
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Yes I saw JIRA, that's why I ask... It's been to mayor versions with no news about it.

    @Owlsroost, as I said some posts back:

    Believe me or not, enabling onboard audio makes my MP react with some delay to any key I press. It's weird, and it stays the same way even if I disable this audio device in windows. Only after disabling it in BIOS the delay disappears.

    Really strange all in all, but I prefer to deal with this bug till it's fixed than keeping my onboard audio enabled.
    That's why I don't want to enable onboard audio... :(
    You could try using VB-Audio CABLE - http://vb-audio.pagesperso-orange.fr/Cable/index.htm - as an alternative 'fallback' audio device (not tried it myself, just did some Googling)
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Part of the issue with fixing this is deciding what should happen when there is no audio device available - should MP quit (which is what most multimedia software would do in that situation, with an error message) or sit in a polling loop for a while, waiting for the audio device to become available ?
     

    peque

    Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    • Thread starter
    • Moderator
    • #34

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    It's really easy to reproduce. No audio device in system, and start MP.

    In my case is very important because I've got my HTPC 24x7 up and running, and I automatically restart it every night so I don't have to deal with some MP bugs that appear after some days of usage... Now I can't restart it because my AVR is off, no other audio device is present, and thus MP hangs... :(
    Did you try setting MP as BASS wasapi ?
     

    Peter2

    MP Donator
  • Premium Supporter
  • September 18, 2006
    848
    53
    Belgium Belgium
    Hi guys, I think I have similar issues.
    About 1 month ago, the tv set was replaced and the connection TV <-> HTPC changed from S-Video to HDMI.
    Almost together, I switched from MePo 1.5 to 1.6 because I had other problems so I was not sure why this new problem appeared.
    I too have found the HTPC still running after grabbing the EPG data and also no sound after standby/hibernate until a reboot.
    Because having multiple other issues to get my 1.6 setup to the level of before, I didn't pay much attention to this but I think in 'all' the changes that I have done lately, sometimes both problems would dis-/reappear.
     

    peque

    Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    • Thread starter
    • Moderator
    • #37
    It's really easy to reproduce. No audio device in system, and start MP.

    In my case is very important because I've got my HTPC 24x7 up and running, and I automatically restart it every night so I don't have to deal with some MP bugs that appear after some days of usage... Now I can't restart it because my AVR is off, no other audio device is present, and thus MP hangs... :(
    Did you try setting MP as BASS wasapi ?
    Yes. I do use wasapi for MyMusic, as I've got some dts audio albums. Same issue.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    RoChess Splashscreen MePo version Titan Skin Feedback 8
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    B loading input devices hang General Support 3
    horned_reaper [solved] Music playback hangs General Support 58
    joecrow Win 10 crash, hang and freeze with USB Tuner. General Support 13
    M [solved] Setup Issue - Hanging on Starting Services General 3
    A Hanging in Recorded TV menu General Support 1
    C MP hangs after suspend or TV off General Support 72
    E Hanging on Initializing Directx General Support 6
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    Similar threads

























    Top Bottom