Subtitle issue (1 Viewer)

Rick164

Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    For now you can try DirectVobSub with Mediaportal, know this is a workaround which does limit DXVA however you will get correct subtitles.
    Just tried Mad Max Fury Road (BR-disk / PGS streams) and that worked with Mediaportal in combination with DirectVobSub(xy-VSfilter).
     

    Rick164

    Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    Will do some more testing this weekend with GraphStudio to pinpoint it, not sure which version of MPC engine Mediaportal uses and if that could be updated but will check that as well.
     

    Rick164

    Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    @Sebastiii Loaded the Directshow filters project in located here:

    https://github.com/MediaPortal/MediaPortal-1/tree/master/DirectShowFilters/Filters.sln

    and followed the instructions here:

    https://github.com/MediaPortal/MediaPortal-1/blob/master/DirectShowFilters/VS Environment Setup.txt

    However Visual Studio 2013 will report a lot of errors (2000+) like these:

    Code:
    Error    2637    error C4430: missing type specifier - int assumed. Note: C++ does not support default-int (source\VideoPin.cpp)    C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\include\UIAnimation.h    2428    1    BDReader
    Code:
        4236    IntelliSense: identifier "GC_PAN_WITH_SINGLE_FINGER_VERTICALLY" is undefined    c:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\include\afxwin.h    2051    61    TsReader
    So for some reason it reports that includes provided by Visual Studio and Windows SDK itself are invalid for this project, do I need to install additional libraries or different versions to get that project compiled properly?
     

    Rick164

    Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    Works, thanks (y)

    Had to change WINDOWS_SDK system variable to C:\Program Files (x86)\Windows Kits\8.1 and also use vsyasm 1.2 like described there.

    // Update

    Just merged mpcSubs successfully with the latest MPC-HC master branch so off to test it out :)
    Hoping the issue isn't somewhere in the mpcSub handler code which hooks into various places of the MPC subtitle engine as my C++ isn't that great.
     
    Last edited:

    Rick164

    Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    Needed to rewrite a lot more than expected to make it conform to the newer MPC code, seems they changed just about everything :(
    However after doing some comparing and changes there are now only a few minor things left on the list and 12 or so errors, gonna work on that this weekend and after that testing it again.
    Can follow the progress in this forked branch:

    https://github.com/RickDB/MediaPortal-1/commits/EXP-MPC-HC-Engine_Update

    // Update

    Seems some of the original C++ code which hooks into mc-hc isn't compatible anymore and not sure how to solve that, in the submanager code it now expects a different input format (rectangle instead of &size)

    https://github.com/RickDB/MediaPort...c-hc_subs/src/mpc-hc_subs/SubManager.cpp#L292
     
    Last edited:

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Thanks m8 :)

    I have try to port the code recently and run to headache, so like it was working, i didn't continue but in fact we have an issue :)
    Do you have a sample for testing your change ?
    I will create one this week-end :)

    The original author @cpp2005 (https://forum.team-mediaportal.com/members/cpp2005.26608/) but long time he didn't comes here.
    Maybe @Owlsroost can help on this :)

    I can try too, i will go to switch to your branch :)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    It seems to break also StreamingServer, for you too ? :)
     

    Rick164

    Super User
  • Team MediaPortal
  • Super User
  • January 7, 2006
    1,335
    1,005
    Netherlands Netherlands
    Country flag
    Do you have a sample for testing your change ?
    Will create a sample clip and PM it to you :)

    It seems to break also StreamingServer, for you too ? :)
    Yeah, not sure why that one is affected but did compile fine before the MPC changes so must have something to do with it.

    Been a while since I worked this much with C++ so bit rusty and never was that good at that to begin with :p , did manage to port all the required parts albeit a bit broken at the moment however even when making a few things static (settings / temporary CRECT) it will fail on LNK libraries with no option to see where it's coming from from within VS.
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S [solved] Live TV subtitle issue if not using 100% font General 31
    mickb Subtitles My TVSeries 4
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
    S Australia live TV teletext subtitle General 4
    horned_reaper Issue with / character in artist name Fanart Handler 5
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 6
    R MP2 GUI Issues General 7
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    Similar threads

























    Top Bottom