Testing of 1.2.3 build - new build

Discussion in 'Area 51 - Testing Area' started by elliottmc, March 23, 2012.

Thread Status:
Not open for further replies.
  1. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi,

    Here is a new build of 1.2.3. I thought it was best to start a new thread and close the old one, so we are clear if there are any issues with this version.

    The link is here - download



    The main focus of testing, bearing in mind the recent changes, should be live and recorded TV, EPG grabbing (particularly with freeview HD, but also with other types) and using a CAM to decrypt channels.

    All of the following mantis entries should be fixed with this build

    - 0003782: [TsWriter] PID PMT descriptor size too large for TsWriter
    - 0003829: [TvServer] Prevent "IndexOutOfRangeExceptionin" PatchPMT_AstonCrypt2 code
    - 0003780: [TsWriter] TsWriter passes incomplete PMT to managed TV Server code
    - 0003717: [My TV / TVGuide] EPG grabbing from DVB stream does not work for Freeview HD (UK) channels
    - 0002914: [Streaming] When using RTSP, audio/video format change may cause video playback to hang in a loop
    - 0003806: [TsReader] Black screen on TV start or channel change
    - 0003732: [TvServer] Digital Everywhere can cause locked CAM
    - 0003811: [TvServer] Building TvServer in x64 environment fails
    - 0003827: [Videos] Update MediaInfo to 0.7.54
    - 0003828: [Videos] Update sqlite to latest version
    - 0003738: [MediaPortal 1] Operand size mismatch in the 'PresentImage' callback parameters from dshowhelper to MP
    - 0003737: [MediaPortal 1] Video frame size change on TV channel change fails with some decode filters
    - 0003769: [general] Building MediaPortal in x64 environment fails
    - 0003739: [MPEI] MPEI randomly hangs when installing fonts
    - 0003770: [general] Debug build script for MediaPortal fails to build
    - 0003791: [Music] Music label 2 is not validated
    - 0003792: [Videos] TMDB images search fail (changes in TMDB returned xml)
    - 0003809: [Videos] Media description file (*.mds) cause double entry on movie scan
    - 0003810: [Music] Cover art grab does not work for music albums
    - 0003719: [Music] Album view does not drill down correctly

    Please test everything and report any problems.

    Thanks,

    Mark
     
    • Like Like x 5
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    If you test this build, please give some comment in the thread so we know.

    In particular, please tell us which parts (TV, music, videos, radio, pictures, etc.) you have tested.

    Thanks,

    Mark
     
    • Like Like x 3
  4. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  5. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I haven't tested this build, but tested the Tswriter from here and had serious problems with it as I've reported here.
     
  6. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Ah, I completely missed that, as you did not reply in the testing thread.

    You seem to have a lot of different versions of various things installed. Unless anyone can reproduce your problems on a clean install, the only thing I can suggest is that you try with a clean install of this build and then work forward to try to find out what is causing this behaviour.

    Thanks for testing.

    Mark
     
  7. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Can a fresh install of this be installed without breaking 1.2.2? It doesn't matter if it replaces the TV Server install, as I can always uninstall that and reinstall 1.2.2 but I want to check it doesn't update anything outside the Mediaportal folder (i.e. MySQL) that would prevent me going back to 1.2.2 by just deleting the 1.2.3 folder and putting the 1.2.2 one back.

    Seems quite clear it's the new TSwriter causing this behaviour though, as it doesn't happen when I go back to the 1.2.2 one.
     
  8. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    It should not update anything outside of the MP folder, so you should be safe.

    Well, it could be the new TsWriter interacting with one of the other things you have added.

    Also, it is pretty well established that the Nova-t 500 has some issues, particularly with sleep. Has the computer been woken from sleep or just booted from cold?

    I'm not seeking to blame everything expect MP, but I have just spent the last 15 minutes doing channel changes with DVB-T and DVB-T2, and I can't get it to behave badly. Hopefully someone can look at your logs, but we really need to have everything with a clean install so that we can check. Ideally this would include a fresh TV database so that all channels are tuned and active (rather than possible old out of date tuning details - it can happen).

    For what it's worth, the only changes in TsWriter are related to EPG grabbing. You could also try changing your EPG grabber settings and see if this makes any difference.

    Thanks,

    Mark
     
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,270
    Likes Received:
    6,221
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,229 / 9
    Home Country:
    France France
    Show System Specs
    Yep Doveman :)
    Backcup your installation folder.
    And try installing separate installer in fresh folder to see the result :)
     
  10. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Is anyone else testing this? We can't release it until it is tested!
     
  11. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,258
    Likes Received:
    4,995
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,421 / 38
    Home Country:
    Germany Germany
    Show System Specs
    Yes, I´m testing it. Can´t say anything about the TSWriter/TVServer changes, because here all worked before and still work OK now.
    The cover lookup in Music works as expected, the TMDB lookup in Videos as well.
    So I can say for me this version works w/o any problems :D
     
    • Like Like x 2
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!