Testing of 1.2.3 build - new build (1 Viewer)

Status
Not open for further replies.

elliottmc

Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Hi,

    Here is a new build of 1.2.3. I thought it was best to start a new thread and close the old one, so we are clear if there are any issues with this version.

    The link is here - download

    The main focus of testing, bearing in mind the recent changes, should be live and recorded TV, EPG grabbing (particularly with freeview HD, but also with other types) and using a CAM to decrypt channels.

    All of the following mantis entries should be fixed with this build

    - 0003782: [TsWriter] PID PMT descriptor size too large for TsWriter
    - 0003829: [TvServer] Prevent "IndexOutOfRangeExceptionin" PatchPMT_AstonCrypt2 code
    - 0003780: [TsWriter] TsWriter passes incomplete PMT to managed TV Server code
    - 0003717: [My TV / TVGuide] EPG grabbing from DVB stream does not work for Freeview HD (UK) channels
    - 0002914: [Streaming] When using RTSP, audio/video format change may cause video playback to hang in a loop
    - 0003806: [TsReader] Black screen on TV start or channel change
    - 0003732: [TvServer] Digital Everywhere can cause locked CAM
    - 0003811: [TvServer] Building TvServer in x64 environment fails
    - 0003827: [Videos] Update MediaInfo to 0.7.54
    - 0003828: [Videos] Update sqlite to latest version
    - 0003738: [MediaPortal 1] Operand size mismatch in the 'PresentImage' callback parameters from dshowhelper to MP
    - 0003737: [MediaPortal 1] Video frame size change on TV channel change fails with some decode filters
    - 0003769: [general] Building MediaPortal in x64 environment fails
    - 0003739: [MPEI] MPEI randomly hangs when installing fonts
    - 0003770: [general] Debug build script for MediaPortal fails to build
    - 0003791: [Music] Music label 2 is not validated
    - 0003792: [Videos] TMDB images search fail (changes in TMDB returned xml)
    - 0003809: [Videos] Media description file (*.mds) cause double entry on movie scan
    - 0003810: [Music] Cover art grab does not work for music albums
    - 0003719: [Music] Album view does not drill down correctly

    Please test everything and report any problems.

    Thanks,

    Mark
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    If you test this build, please give some comment in the thread so we know.

    In particular, please tell us which parts (TV, music, videos, radio, pictures, etc.) you have tested.

    Thanks,

    Mark
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    United Kingdom United Kingdom
    Country flag
    I haven't tested this build, but tested the Tswriter from here and had serious problems with it as I've reported here.
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    I haven't tested this build, but tested the Tswriter from here and had serious problems with it as I've reported here.
    Ah, I completely missed that, as you did not reply in the testing thread.

    You seem to have a lot of different versions of various things installed. Unless anyone can reproduce your problems on a clean install, the only thing I can suggest is that you try with a clean install of this build and then work forward to try to find out what is causing this behaviour.

    Thanks for testing.

    Mark
     

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    United Kingdom United Kingdom
    Country flag
    Can a fresh install of this be installed without breaking 1.2.2? It doesn't matter if it replaces the TV Server install, as I can always uninstall that and reinstall 1.2.2 but I want to check it doesn't update anything outside the Mediaportal folder (i.e. MySQL) that would prevent me going back to 1.2.2 by just deleting the 1.2.3 folder and putting the 1.2.2 one back.

    Seems quite clear it's the new TSwriter causing this behaviour though, as it doesn't happen when I go back to the 1.2.2 one.
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Can a fresh install of this be installed without breaking 1.2.2? It doesn't matter if it replaces the TV Server install, as I can always uninstall that and reinstall 1.2.2 but I want to check it doesn't update anything outside the Mediaportal folder (i.e. MySQL) that would prevent me going back to 1.2.2 by just deleting the 1.2.3 folder and putting the 1.2.2 one back.
    It should not update anything outside of the MP folder, so you should be safe.

    Seems quite clear it's the new TSwriter causing this behaviour though, as it doesn't happen when I go back to the 1.2.2 one.
    Well, it could be the new TsWriter interacting with one of the other things you have added.

    Also, it is pretty well established that the Nova-t 500 has some issues, particularly with sleep. Has the computer been woken from sleep or just booted from cold?

    I'm not seeking to blame everything expect MP, but I have just spent the last 15 minutes doing channel changes with DVB-T and DVB-T2, and I can't get it to behave badly. Hopefully someone can look at your logs, but we really need to have everything with a clean install so that we can check. Ideally this would include a fresh TV database so that all channels are tuned and active (rather than possible old out of date tuning details - it can happen).

    For what it's worth, the only changes in TsWriter are related to EPG grabbing. You could also try changing your EPG grabber settings and see if this makes any difference.

    Thanks,

    Mark
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Yep Doveman :)
    Backcup your installation folder.
    And try installing separate installer in fresh folder to see the result :)
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Is anyone else testing this? We can't release it until it is tested!
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,955
    9,302
    Lanzarote
    Germany Germany
    Country flag
    Yes, I´m testing it. Can´t say anything about the TSWriter/TVServer changes, because here all worked before and still work OK now.
    The cover lookup in Music works as expected, the TMDB lookup in Videos as well.
    So I can say for me this version works w/o any problems :D
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    morpheus_xx Test builds of MP2.3 WiP, x64, Nereus and more... MediaPortal 2 44
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 7
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    high attachment test Testforum 0
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    HTPCSourcer [Finished] Nereus: Test results #1 MediaPortal 2 196
    ajs [solved] MP1.23 Temporary Bugfixes - Test General Support 8
    ajs [News] MediaPortal 1.23 Pre-Release ready for testing! News and Announcements 6
    O [News] MediaPortal 1.22 Pre-Release ready for testing! News and Announcements 2
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    O [News] MediaPortal 1.21 Pre-Release ready for testing! News and Announcements 6
    D [solved] Initital testing with second client - cannot play recorded TV General 33
    O Core Testing of the new TsWriter.ax TV Engine 77
    ge2301 MP 2.2 Release - Testing Archive 86
    high [News] MediaPortal 1.20 Pre-Release ready for testing! News and Announcements 10
    O Can't browse network share on new build Newcomers Forum 1
    M General TVE 3.5 VS2019 - build discussion TV Engine 50
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    doskabouter Build errors MediaPortal 1 9
    doskabouter Building TVPlugins MediaPortal 1 17
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    Similar threads

























    Top Bottom