Testing of 1.2.3 build - new build | Page 4

Discussion in 'Area 51 - Testing Area' started by elliottmc, March 23, 2012.

Thread Status:
Not open for further replies.
  1. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi,

    We really need users with UK freesat to test this build. One person has reported problems with EPG grabbing with the included TsWriter.

    If there is a problem and we don't get it verified now, then it is possible that 1.2.3 could break your EPG. Hopefully not, but I want everyone to be aware of what could happen if we don't get the necessary testing.

    Thanks!



    Mark
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I've noticed some glitches/flickering on the TV EPG that I haven't seen with previous builds. It's not as bad today as it has been, but what I'm seeing today is when I'm looking at a later time, so that the current time isn't visible, when the current time marker updates it flashes onto the screen anyway rather than updating offscreen.

    I normally use PureVisionHD but tested and confirmed with DefaultWide as well.
     
  4. jameson_uk
    • Premium Supporter

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,405 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    And you have never seen this before? I can not see any changes since 1.2.2 that would go anywhere near any code that would affect EPG or rendering engine.

    Do you get it without the modified dshowhelper?

    edit: apart from http://mantis.team-mediaportal.com/view.php?id=3738 .... but does not sound like it would cause an issue like this ???
     
  5. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    No, I've never noticed this before, which doesn't mean it wasn't happening of course ;) I think I probably would have noticed it at some point though.

    I don't think I'm using a modified dshowhelper with 1.2.3 (my sig applies to 1.2.2 and I haven't updated it whilst I test 1.2.3). I can't see any mention of it in the logs.
     
  6. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Please could you test without it?

    Thanks,

    Mark
     
  7. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    It's the standard MP 1.2.3 dshowhelper in the logs (v1.4.55g), but anyway it's only actually in use when video is playing, and it's not directly involved in the GUI rendering either.

    The 3738 bug fix has been in the experimental versions for many months, and it only modifies very large aspect ratio numbers before passing them to the MP player code, so that they are not simply truncated along the way (producing a black screen). If the numbers are in the usual range e.g. 4:3, 16:9, they are not modified at all.

    Tony
     
  8. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    There is also bad continuity error in the logs - it looks like the signal dropped out for about 2 seconds, this will cause the GUI rendering to stall since the screen will only update (if playing video) when there are video frames to render.

    Tony
     
  9. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I'm watching TV at the moment and there's no signal dropout or breakup/glitches but I'm still seeing the problem with the EPG.
     
  10. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    And this is the only part where you see flickering, or the only part you have checked?

    Could you post a video of this on youtube so that we can see what you are seeing?

    Is this on a single or dual monitor setup?
     
  11. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    To me it sounds like the infamoust ATI related flickering bug that has been there for years. It can be hidden on some (nowadays majority) of ATI systems but still it seems to popup once a while, althou mainly with the older generation ATI HW.

    I agree with Owlsroost that there has not been any changed between 1.2.2 and 1.2.3 that could affect the GUI rendering.
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!