Thumbnail generation - design problem: thumbnails are almost same and not very informative. (1 Viewer)

regeszter

Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    Hi,

    I tested it with a sort manual recording (1x1 title). It works! Great work! (y)
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,465
    4,631
    45
    ::1
    Netherlands Netherlands
    Country flag
    that's a nice speed improvement on the server side:
    Code:
    [2013-07-27 10:08:40,687] [Log	] [22	  ] [INFO ] - ThumbProcessor.DoWork: Creating thumb for F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts
    [2013-07-27 10:08:40,688] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: preGapSec: 60
    [2013-07-27 10:08:41,816] [Log	] [22	  ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts
    [2013-07-27 10:08:41,816] [Log	] [22	  ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: VideoDuration	: 4490920
    [2013-07-27 10:08:41,817] [Log	] [22	  ] [DEBUG] - F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts duration is 4490, TimeIntBwThumbs is 1107
    [2013-07-27 10:08:43,340] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: thumb creation -loglevel quiet -ss 60 -i "F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts" -vf select=isnan(prev_selected_t)+gte(t-prev_selected_t\,1),yadif=0:-1:0,scale=600:337,setsar=1:1,tile=1x1 -vframes 1 -vsync 0 -an "C:\Windows\TEMP\Stop! Politie - RTL 7 HD - 2013-04-13_0.jpg"
    [2013-07-27 10:08:44,909] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: thumb creation -loglevel quiet -ss 1167 -i "F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts" -vf select=isnan(prev_selected_t)+gte(t-prev_selected_t\,1),yadif=0:-1:0,scale=600:337,setsar=1:1,tile=1x1 -vframes 1 -vsync 0 -an "C:\Windows\TEMP\Stop! Politie - RTL 7 HD - 2013-04-13_1.jpg"
    [2013-07-27 10:08:46,713] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: thumb creation -loglevel quiet -ss 2274 -i "F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts" -vf select=isnan(prev_selected_t)+gte(t-prev_selected_t\,1),yadif=0:-1:0,scale=600:337,setsar=1:1,tile=1x1 -vframes 1 -vsync 0 -an "C:\Windows\TEMP\Stop! Politie - RTL 7 HD - 2013-04-13_2.jpg"
    [2013-07-27 10:08:48,292] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: thumb creation -loglevel quiet -ss 3381 -i "F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts" -vf select=isnan(prev_selected_t)+gte(t-prev_selected_t\,1),yadif=0:-1:0,scale=600:337,setsar=1:1,tile=1x1 -vframes 1 -vsync 0 -an "C:\Windows\TEMP\Stop! Politie - RTL 7 HD - 2013-04-13_3.jpg"
    [2013-07-27 10:08:48,298] [Log	] [22	  ] [DEBUG] - aPictureList.Count: 4
    [2013-07-27 10:08:48,332] [Log	] [22	  ] [DEBUG] - CreateTileThumb: before Saving thumb! tmpFile: C:\Windows\TEMP\tmpC688.tmp
    [2013-07-27 10:08:48,339] [Log	] [22	  ] [DEBUG] - CreateTileThumb: Saving thumb!
    [2013-07-27 10:08:48,398] [Log	] [22	  ] [DEBUG] - CreateTileThumb: after Saving thumb!
    [2013-07-27 10:08:48,501] [Log	] [22	  ] [DEBUG] - TvThumbnails.VideoThumbCreator: thumb creation success C:\Windows\TEMP\Stop! Politie - RTL 7 HD - 2013-04-13.jpg
    [2013-07-27 10:08:49,037] [Log	] [22	  ] [INFO ] - ThumbProcessor.DoWork: Thumbnail successfully created for - F:\TV_Opnames\Stop! Politie\Stop! Politie - RTL 7 HD - 2013-04-13.ts
    (y)
    Quality is also looking good, but i still see a lot of pixelation on some thumbs.
     
    Last edited:

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    If you help us (vuego and me for it) :)
    The doc should mention new options :
    Thumbnail_MP_Config.PNG Thumbnail_SetupTV.PNG
    Thanks :)
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    Wiki page created: http://wiki.team-mediaportal.com/1_...nfig_Tool_Changes/Thumbnail_generation_rework

    This needs a review I think. :) I am not sure what are default values for example.

    EDIT:
    I don't know if we need
    2. If you use more than one thumb (e.g. 2x2 tiles) the time between the thumbs will be calculated automatically from the video duration. This means no more almost the same thumbs.
    at all. It has nothing to do with config. But that is for Docs team. :)

    PS: @michael_t I think you can close: https://issues.team-mediaportal.com/browse/MP1-4079 :)
     
    Last edited:

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    Hi,

    there is an second feature in this rework. If an user press F9 (enter the context menu) on a movie (in my video screen), the user can refresh the thumbnail. MP will generate a random value and increase the time offset to generate a new thumbnail.
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    Maybe you can make a screenshot and add this to Wiki? Thanks! :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom