MP2 - Spring'16 Unable to play Windows Media Center (WMC) Files (.wtv) (1 Viewer)

TiVo

Portal Member
June 6, 2016
11
0
Fareham Hampshire UK
Great Britain (UK) Great Britain (UK)
Country flag
I recently installed Media Portal 2 Spring 16 on three computers.
"Living Room" is a server and client running on a fresh install of 64bit Windows 7 with the free Windows Update to 64bit Windows 10.
"Living Room" plays .wtv files.

"Bedroom" has just the client installed. It is a long standing 64bit Windows 7 with the free Windows Update to 64bit Windows 10.
"Kitchen" is a brand new machine with 64bit Windows 10 OEM and just the client installed. This was bought purely to replace the XBOX WMC Extender I used to use.

When I attempt to play one of my (hundreds of) legacy WMC .wtv files, both "Bedroom" and "Kitchen" fail to play and clicking the question mark icon (which is really easy to miss for a newbie) result in the message "There is no player registered to play Media Item '{insert_name_here}.wtv'".
I attach the log files for "Bedroom" since (a) I am submitting this report from it and (b) I used to view .wtv files using WMC from it before Microsoft stole WMC when I upgraded to Windows 10.

For information both "Bedroom" and "Kitchen" are able to play .wtv files using Windows Media Player.

Having read what posts I could find, I looked into the various Visual C++ x86 redistributables. All were present and correct but I have reproduced the problem having run repair on all of the versions as well as uninstalling and reinstalling from Microsoft downloads and reinstalling Media Portal 2 having uninstalled them - all to no avail.

As I said back at the beginning, the client and server installation "Living Room" (which never even ran WMC before it was upgraded to Windows 10) plays .wtv files as designed.

All of the clients are using the default setting of LAV codecs - I experimented with changing these but it made no difference.

Thanks in advance.

John.
 

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,748
    7,110
    Germany Germany
    Country flag
    Thanks for posting logs in debug level (y)

    [2016-06-07 19:24:58,751] [27752 ] [AMQ 'PlayerContextManager'] [WARN ] - SlimTvPlayerBuilder: Error playing media item 'Resource '{e88e64a8-0233-4fdf-ba27-0b44c6a39ae9}:///E:/Media/Recorded TV/WMC/Celebrity Juice_ITV2_2016_05_12_22_00_00.wtv' at system '191efb58-c436-4a75-acbf-61b5e8deadb2'
    System.Runtime.InteropServices.COMException (0x80004003): Invalid pointer

    at DirectShow.Helper.HRESULT.Throw()
    at MediaPortal.Plugins.SlimTv.Client.Player.WTVPlayer.AddSourceFilter()
    at MediaPortal.UI.Players.Video.BaseDXPlayer.SetMediaItem(IResourceLocator locator, String mediaItemTitle)
    at MediaPortal.Plugins.SlimTv.Client.Player.SlimTvPlayerBuilder.GetPlayer(MediaItem mediaItem)

    The error happens on creation of the playback graph, when the source filter gets loaded. I think for further diagnostics you need to run graphedit/graphstudio (32 bit) on your system and check if the automatic loading of the .wtv works there.
     

    TiVo

    Portal Member
    June 6, 2016
    11
    0
    Fareham Hampshire UK
    Great Britain (UK) Great Britain (UK)
    Country flag
    Here is a screen shot from GraphEdit on "Bedroom"
    GraphEdit was able to play the file.
    upload_2016-6-12_20-44-40.png


    This is from "Living Room" (the one that is ok).
    upload_2016-6-13_8-22-31.png


    Sorry for the delay - I've been away.
     
    Last edited:

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    R 1.27.0 Random "Unable to play" errors after server hardware upgrade. Television (MyTV frontend and TV-Server) 8
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    V Unable to stream : 10 General Support 0
    M Unable to map virtual sent keys in the input device management General 6
    bta489 Sometimes no image rendered when playing video watch/edit Videos 24
    M MP Sometimes Unresponsive When Playing Playlist General Support 0
    squizeer Sound only when playing 4k UHD (HEVC 265) Codecs, External Players 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 26
    P 1.26.0 Can't play blu-ray disc Bugreports 1
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 11
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 30
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3

    Similar threads

    Top Bottom