Version 0.2.0.0 final | Page 5

Discussion in 'ASIO music player' started by Symphy, September 7, 2008.

  1. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yep, I can confirm this. This is why I already had it disabled. :) Besides this reason, I always found those sounds annoying anyway....


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Hello,

    I used an old version of this great software for quite some time and decided to upgrade to the new version.
    I installed the C++ package first en then the Symphy install. I installed it on two PCs.
    On one PC it works great, on the other PC I cannot get it to work. I get an error when
    I try to configure the plugin. Both PCs are running the following Software:

    Windows Vista Home Premium
    MediaPortal 0.2.3
    No asio driver

    Perhaps Symphy knows what is going on.

    I have added the error text below.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Microsoft.Win32.RegistryKey.CheckKeyReadPermission()
    at Microsoft.Win32.RegistryKey.GetSubKeyNames()
    at BlueWave.Interop.Asio.InstalledDriver.GetInstalledDriversFromRegistry()
    at BlueWave.Interop.Asio.AsioDriver.get_InstalledDrivers()
    at MediaPortal.Player.PureAudio.ConfigurationForm.ConfigurationForm_Load(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ContainerControl.WndProc(Message& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
     
  4. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    What is the hardware of the non-functional pc and what is the hardware difference between the two pc's.
    Whats the audio hardware used
    Drivers + version number compare.. etc.
    Connection to amp.

    (a little bit more info would help :) )
     
  5. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Good news here,

    The PC which worked well with the Symphy music player had the ASIO4ALL driver installed.
    When I removed the ASIO4ALL driver, it did not work anymore.

    The previous version of the Symphy music player did not require the asio4all driver at all.
    It worked fine whithout the asio4all driver. Apparently, this new version does require
    this driver! I think this should be avoided.
     
  6. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Are you sure you are using the 0.2.0.0 final and not the beta? This should have been fixed already.
     
  7. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    Yes, I am using the 0.2.0.0 final. The problem with the 0.2.0.0 final version is that
    you get the error when you do not have installed an asio driver.
    When I install the asio4all driver, the plugin works ok. In my opinion, the plugin
    should also work without the asio driver.

    When I have installed the asio4all driver I get the following:

    [​IMG]

    When I have not installed the asio4all driver I get the following:

    [​IMG]
     
  8. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Agree. Not sure yet what goes wrong, but will look into it.
     
  9. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Symphy,

    Just for information only and out of my curiosity. You talked about an update for this plugin which supports 24bit as well. Can you give some indication on when you expect it to be "ready"? (days,weeks,months..) I cant wait to try... gheheheh
     
  10. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    The plan is to release it coming weekend. It'll be a beta, because i dont have an asio device with 24 bit chans to test with. It'll also include an attempt to fix the DTS pause/forward problem. Because i dont have a DTS receiver, not sure if thats gonna work either :)
     
  11. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    OK, Nice. Thats faster than I anticipated... I will test for you then. Just according to the deal ;) You probably already know, I have a Yamaha receiver (DTS/AC3) and the 16/24bit Asio driver from Xonar DX.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!