Win10 falls creators update problems watching videos | Page 3

Discussion in 'General Support' started by joker1639, October 15, 2017.

  1. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,647
    Likes Received:
    543
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +963 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    This sounds similar to a spate of threads that appeared recently on the Lenovo website. The problem was a bad graphics driver from Intel. If this bad driver is included in the Windows 10 update, that might explain the symptoms. See the following post for the solution:



    Solved: Re: Lenovo Y720 sleep issues - Page 2 - Lenovo Community

    -- from CyberSimian in the UK
     
    • Like Like x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    It wasn't - the HTPC was using the same (older) GPU driver before and after the 1709 update, then I updated to the latest driver just in case it might make a difference (it didn't).

    I think MP is still 'alive' but maybe not rendering anything to the screen, or windows 10 window manager isn't allowing it through until something else causes the screen to be redrawn. I don't need to restart MP after I've made it visible again - it works fine afterwards.
     
  4. johnzered
    • Premium Supporter

    johnzered Retired Team Member

    Joined:
    April 20, 2008
    Messages:
    358
    Likes Received:
    37
    Ratings:
    +71 / 0
    Home Country:
    Finland Finland
    Updated my HTPC yesterday, and now I'm facing the same problem as you are...any solution to the problem? I have Intel HD 4000 graphics.
     
  5. joker1639

    joker1639 Portal Member

    Joined:
    May 10, 2009
    Messages:
    23
    Likes Received:
    3
    Ratings:
    +3 / 1
    No solution yet! Seems to be a critical Win 1709 Problem! Win 10 update policy sucks! I for my part rolled back to 1703 and everything works flawless as it should......
     
  6. AlunS

    AlunS Portal Pro

    Joined:
    October 28, 2011
    Messages:
    73
    Likes Received:
    1
    Ratings:
    +4 / 0
    Home Country:
    Ireland Ireland
    I'm getting the same thing on a new 1.16 build(custom build with Sky EPG Grabber) I'm working on at the moment. It's an ASUS B250M-A motherboard with an Intel G4600 Kabylake processor with Intel 630 HD graphics. I'm running a clean install of the latest Fall Creators Update and the latest Intel display driver downloaded from Intel.

    What happens is that sometimes, when the PC returns from sleep, the clock in the top right is frozen at the time it last went into sleep. The impression is that the PC is hung, but if you, say, start Live TV with the remote control you can hear the audio, but there's no picture, If you then hit Ctrl-Alt-Del, but do nothing but hit Esc to quit the Ctrl-Alt-Del options screen, wham, there's the video back again. Like you said, you just have to do something to wake up the screen somehow and it's OK.
     
    • Agree Agree x 1
  7. JimCatMP
    • Team MediaPortal

    JimCatMP Documentation Group

    Joined:
    April 1, 2010
    Messages:
    647
    Likes Received:
    153
    Gender:
    Male
    Location:
    Leeds
    Ratings:
    +282 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi

    For me, totally kills MePo - nothing starts, nothing logged [including Watchdog].

    Re-install fails - AresBackup in AresBackup.

    From System logs....
    Application error :

    Faulting application name: MediaPortal.exe, version: 1.18.0.0, time stamp: 0x59d9d5bc
    Faulting module name: KERNELBASE.dll, version: 10.0.16299.15, time stamp: 0x2cd1ce3d
    Exception code: 0xe0434352
    Fault offset: 0x001008b2
    Faulting process ID: 0x950
    Faulting application start time: 0x01d350ce9a8a4393
    Faulting application path: C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report ID: 707c1550-9d22-4e51-b2c4-abc1fffa12fd
    Faulting package full name:
    Faulting package-relative application ID:

    Source of problem {I think} - .Net4 instance.

    Application: MediaPortal.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.IO.DirectoryNotFoundException
    at System.IO.__Error.WinIOError(Int32, System.String)
    at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)
    at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare, Int32, System.IO.FileOptions, System.String, Boolean, Boolean, Boolean)
    at System.IO.StreamWriter.CreateFile(System.String, Boolean, Boolean)
    at System.IO.StreamWriter..ctor(System.String, Boolean, System.Text.Encoding, Int32, Boolean)
    at System.IO.StreamWriter..ctor(System.String)
    at MediaPortal.Common.Utils.Logger.CommonLog4NetLogger.WriteDefaultConfig(System.String)
    at MediaPortal.Common.Utils.Logger.CommonLog4NetLogger..ctor(System.String, System.String, System.String)
    at MediaPortal.Services.GlobalServiceProvider.LogServiceRequested(MediaPortal.Services.ServiceProvider)
    at MediaPortal.Services.ServiceProvider.Get[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]()
    at MediaPortal.Services.GlobalServiceProvider.Get[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]()
    at MediaPortal.GUI.Library.Log.Info(System.String, System.Object[])
    at MediaPortalApp.Main(System.String[])

    Complete reinstall needed [smooth and fast] to get Config to start:)

    Re-instating the skin/thumbs/database & other 'I'm not going to loose them' files works, no problem.

    Cheers - JCMP.
     
    Last edited: October 30, 2017
  8. Fantoman

    Fantoman Portal Member

    Joined:
    October 6, 2006
    Messages:
    21
    Likes Received:
    0
    Location:
    Gosford
    Ratings:
    +0 / 0
    Home Country:
    Similar problem here after Win 10 Fall Creators update.

    If I turn off my Xbox one (connected by HDMI from HTPC), or change to Netflix, etc then MP will be black when I change back to the HTPC input (or turn the Xbox back on). In the MP log, I can see that the monitor and HDMI audio device are removed during this process, and can see them being re-added when reconnected, however MP remains black.

    CTRL-ALT-DEL and cancel brings MP back on screen. The behavior is the same if video is playing or not.

    Log attached is with MP started while Xbox is on Netflix, so HDMI is equivalent to disconnected for the HTPC during MP startup.

    You can see at 16:48:54 that the monitor is connected and 16:49:24 is when I did CTRL-ALT-DEL.

    I'm contemplating reverting back to past Win version until this is fixed but hopefully this info helps with resolving the issue (unless it needs MS to fix it o_O)
     
  9. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I haven't had much time to investigate further.

    @Sebastiii - any thoughts or pointers to mods/debug worth trying? (as you probably know more about these sort of issues than most people around here ;))

    It looks like MP is fully alive (not hung), but either isn't rendering to the screen (maybe it's waiting for a message from the system?) or the Windows DWM is ignoring it. Doing almost anything that causes the desktop to be redrawn fixes it (switching to another app, popping up the Start menu, minimising and then maximising MP, remote access via Teamviewer etc.)

    As Fantoman suggests, disconnection and reconnection of the display seems to be involved in the issue - on a laptop with just the internal screen active I can't reproduce it, but it happens every time with the HTPC connected to the TV.
     
    Last edited: October 31, 2017
    • Like Like x 1
  10. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,264
    Likes Received:
    6,218
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,224 / 9
    Home Country:
    France France
    Show System Specs
    Not sure too and what can be done on MP side i fear :(
    There is issue about RDP with latest Windows, connecting directly after a connection from RDP, lead to a black screen so it most an issue with WIN10.

    I wasn't able to reproduce the issue on my side so hard fro debugging :(
     
    • Thank You! Thank You! x 1
  11. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    • Agree Agree x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!