Animation slowing down in time | Page 8

Discussion in '1.0 final and SVN Builds' started by zeflash, January 12, 2009.

  1. rtv
    • Premium Supporter

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I am doing some work related to that currently.
    E.g. removing hard coded constants and switch time based refreshes to depend directly on the GUI FPS. The next version will look smoother than before - only time will tell though if it stays smooth for weeks and months...


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    I still find it really odd that restarting MP wouldn't solve the issue :p
     
  4. zeflash

    zeflash Portal Pro

    Joined:
    July 7, 2005
    Messages:
    199
    Likes Received:
    16
    Ratings:
    +16 / 0
    Home Country:
    France France
    Definitely odd, yeah. But who knows - maybe something in MP's code affects the OS' resources?
    I'll try those patches see if that changes anything here. Hopefully it will take a *loooong* time to debug ;)

    Edit:
    Strange, I don't see any checkins in MP's trunk since March 22nd. Why?
     
  5. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Such is extremely rare on todays OSes. Also it should happen on much wider range of PCs.

    Public SVN is updated only when new SVN build is released to be tested.
     
  6. zeflash

    zeflash Portal Pro

    Joined:
    July 7, 2005
    Messages:
    199
    Likes Received:
    16
    Ratings:
    +16 / 0
    Home Country:
    France France
    it's fixed! Great work rtv!
    I tried the latest SVN and even though the previous version was slowed down quite a lot ( it has been running for about 2 weeks) the SVN version I put on top of it made the animations smooth again.

    Now I don't know if it's on purpose or not, but:
    1) animations of movie descriptions for example do not start as fast as before ( need to wait about 2 or 3 seconds for them to start scrolling)
    2) the RSS ticker I have on the basic home (streamedMP skin) stops after a while. If I interact with the app again it starts back up smoothly
     
  7. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    There is new a skin property scrollStartDelaySec which controls the delay in which scrolling starts.

    You may want to checkout Configuration->General->Screensaver, and disable Idle timer. I think this sets the scrolling to 5FPS when idle...dont quote me on it.
     
  8. rtv
    • Premium Supporter

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Thanks - both comments are correct :)
     
  9. CHli

    CHli Portal Pro

    Joined:
    July 5, 2005
    Messages:
    1,251
    Likes Received:
    14
    Occupation:
    Embedded Software Engineer
    Location:
    Switzerland
    Ratings:
    +14 / 0
    Home Country:
    Switzerland Switzerland
    I'm really looking forward for 1.0.1 so I can test these improvements and see if the bug has been squashed out ! Thanks rtv for the great work.
     
  10. vuego
    • Team MediaPortal

    vuego Documentation Group

    Joined:
    August 5, 2006
    Messages:
    1,570
    Likes Received:
    660
    Occupation:
    Alchemist, Astrobiologist, Exotic dancer
    Location:
    Göteborg
    Ratings:
    +868 / 0
    Home Country:
    Sweden Sweden
    Show System Specs
    I noticed that when MP doesn't have focus the GUI slows down to 10 fps. I'm using EventGhost for my remote which can control MP even when it's not in focus. It means that very often my GUI is working at 10 fps and I'll have to walk to the PC and set MP in focus again :/

    Is it possible to disable this feature?
     
  11. kkozma

    kkozma Portal Pro

    Joined:
    February 16, 2009
    Messages:
    189
    Likes Received:
    6
    Occupation:
    Network Engineer
    Location:
    Dayton, OH
    Ratings:
    +6 / 0
    Home Country:
    United States of America United States of America
    I have the same problem and I'm using the last SVN released before 1.0.1 released.

    The interesting thing with me is that this occurs whether I have MP running or not. My machine is on 24/7 but MP isn't. I'll set up a scenario...

    Fresh reboot, start MP, and all the animations are flawless. I exit MP and leave the machine running while we're in bed for the night. The next morning when I start MP I can see that the animations are already starting to become jerky. Repeat the same process. Watch TV, exit MP, leave machine running, and go to bed. By the following day, there may as well not even be any animation because that's how jerky they've become.

    ATI 4550 (512mb ram), XP Pro SP3, 2 GB system ram.

    The only thing I see here that we all may have in common is a remote control of some sort and I would assume we're all using mpTrayMod? Could mpTrayMod be screwing something up?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!