AtmoLight - 1.18.6.0 [2016-09-21] | Page 28

Discussion in 'Ambient Lighting System' started by Rick164, April 20, 2014.

  1. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Logs seem normal as the only error is when coming from standby but it reconnects to Hyperion like it should:

    Code (Text):
    1.  
    2. [2016-02-05 12:11:49,473] [Log  ] [63  ] [INFO ] - AtmoLight: Changing AtmoLight effect to: LEDsDisabled
    3. [2016-02-05 12:11:49,736] [Error  ] [63  ] [ERROR] - AtmoLight: HyperionHandler - Error while sending proto request
    4. [2016-02-05 12:11:49,736] [Error  ] [63  ] [ERROR] - AtmoLight: HyperionHandler - Exception: Unable to write data to the transport connection: An existing connection was forcibly closed by the remote host.
    5. [2016-02-05 12:11:49,751] [Log  ] [TvClient-TvHome: HeartBeat transmitter thread] [INFO ] - RemoteControl - Connected
    6. [2016-02-05 12:11:49,758] [Log  ] [63  ] [DEBUG] - AtmoLight: HyperionHandler - Initialising after standby
    7. [2016-02-05 12:11:49,758] [Log  ] [63  ] [DEBUG] - AtmoLight: HyperionHandler - Initialising
    8. [2016-02-05 12:11:49,758] [Log  ] [35  ] [DEBUG] - AtmoLight: HyperionHandler - Reinitialising
    9. [2016-02-05 12:11:50,607] [Log  ] [35  ] [DEBUG] - AtmoLight: HyperionHandler - connection method is IP
    10. [2016-02-05 12:11:50,607] [Log  ] [35  ] [DEBUG] - AtmoLight: HyperionHandler - Initialising locked.
    11. [2016-02-05 12:11:50,607] [Log  ] [63  ] [DEBUG] - AtmoLight: HyperionHandler - connection method is IP
    12. [2016-02-05 12:11:50,607] [Log  ] [94  ] [DEBUG] - AtmoLight: HyperionHandler - Trying to connect
    13. [2016-02-05 12:11:50,623] [Log  ] [94  ] [DEBUG] - AtmoLight: HyperionHandler - Connected
    14.  
    Crash to desktop I'm not sure as we have error handling in place to prevent AtmoLight from doing that so is unlikely as it would have written the unexpected error to the logs :) , however there's another error in the logs for something called ImageDownloader0 but not sure which plugin that one is.
    Make sure that all plugins are up2date using MediaPortal Extension Manager and see if you can reproduce it consistently, if your AVR has lip sync can try changing that and also see if there's any difference in 24P versus 50/60hz.


     
    Last edited: February 6, 2016
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Lightning303
    • Premium Supporter

    Lightning303 MP Donator

    Joined:
    September 12, 2009
    Messages:
    798
    Likes Received:
    384
    Gender:
    Male
    Ratings:
    +578 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Thanks for reporting.
    Looks like AtmoLight has a problem communicating with Hyperion sometimes. And in some cases failes to reconnect. Crash seems to come from a bug where an object is wrongly removed or not properly checked. Will have a look at it a bit later :).

    @Rick164 look at MediaPortal.1.log ;)
     
    • Like Like x 1
  4. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    @Lightning303 Thanks see it now, odd error as I never seen that one here even during short/long sleeps or repeated hard network disconnects (reloading configs)
    Most likely it's due to Socket being disposed however the initLock should have prevented that here:

    https://github.com/ambilight-4-medi...Core/Targets/Hyperion/HyperionHandler.cs#L137

    We could add a small check there like this:

    if(Socket == null) etc..

    Still would be great if we can find the underlying cause though :)
     
    Last edited: February 6, 2016
  5. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Attached new beta build, added a new check to isConnected() to prevent that error.
    @TheBatfink This doesn't solve the Hyperion connection issues though, best to check connectivity to Raspberry Pi and update Hyperion if the problem persists in case it's a bug there:

    Code (Text):
    1. SSH to Raspberry Pi
    2.  
    3. Run commands:
    4.  
    5. wget -N https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    6. sudo sh ./install_hyperion.sh
    7.  
     

    Attached Files:

    Last edited: February 6, 2016
    • Like Like x 1
  6. TheBatfink
    • Premium Supporter

    TheBatfink MP Donator

    Joined:
    June 11, 2007
    Messages:
    1,285
    Likes Received:
    164
    Gender:
    Male
    Occupation:
    Business System Analyst
    Location:
    Nottingham
    Ratings:
    +221 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hey both. Sorry I never replied, wasn't getting any email notifications. I actually came back to say I am still getting these errors. It's strange because in the beginning it all worked well and I've been using it for quite some time now. I still use all the files and versions from your build guide way back when :)

    I see these issues:

    - Lights do not come on with media which usually results in a crash to desktop as soon as the media finishes and it tries to go back to the menu

    but I am also experiencing this a lot..

    - Start media but no video or audio or lights ever begin (just black screen) but I can use the remote and still get GUI overlay
    - Start media get lights and audio but no video

    I'm experiencing this on network based files and onlinevideos, might be some other issue and not atmolight related (I do see some trakt errors too). Will try the new files and update hyperion too and get back to you this time :)

    Thanks for the help (I attached most recent logs just in case they are useful).[DOUBLEPOST=1457781330][/DOUBLEPOST]I actually get an error with this

    Code (Text):
    1. wget -N https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    It says -N is not a valid option. If I remove the -N it says its not an http or ftp url.

    If I swap https for http, I do see connecting to raw.github.com - but then it fails again and says not a valid http or ftp url.
     
    Last edited: March 12, 2016
    • Thank You! Thank You! x 1
  7. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,587
    Likes Received:
    2,625
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,572 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Try:
    Code (Text):
    1. wget --timestamping --secure-protocol=auto https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    Or:
    Code (Text):
    1. wget --timestamping --secure-protocol=auto --no-check-certificate https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    PS: Which wget version?
    Code (Text):
    1. wget --version
    Or try:
    Code (Text):
    1. curl https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    :whistle:
     
    Last edited: March 12, 2016
    • Like Like x 1
  8. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Which OS are you using on the Raspberry?
    As with Raspbian and OpenElec that command should have worked, the Hyperion docs list it slightly different and also offer the curl option like @ajs mentioned:

    Code (Text):
    1. curl -# -k -L --output install_hyperion.sh --get https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh && sudo sh ./install_hyperion.sh
    Full example located here: https://github.com/tvdzwan/hyperion/wiki/Installation

    Still wondering what is causing it as it looks network related or maybe something Mediaportal that is conflicting internally (another plugin perhaps?), if Hyperion can't get a stable connection it will affect playback so best to rule out any problems on the Hyperion side first.
    If all else fails you could use Raspbian instead of OpenElec which is what I switched to with the APA102 build and use the installation instructions posted above :)
     
    • Like Like x 1
  9. TheBatfink
    • Premium Supporter

    TheBatfink MP Donator

    Joined:
    June 11, 2007
    Messages:
    1,285
    Likes Received:
    164
    Gender:
    Male
    Occupation:
    Business System Analyst
    Location:
    Nottingham
    Ratings:
    +221 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I have no idea what OS? Whatever was on your build thread is whats on my rpi and arduino. All I know is it's openelec! Will have a play again later, thanks.
     
  10. TheBatfink
    • Premium Supporter

    TheBatfink MP Donator

    Joined:
    June 11, 2007
    Messages:
    1,285
    Likes Received:
    164
    Gender:
    Male
    Occupation:
    Business System Analyst
    Location:
    Nottingham
    Ratings:
    +221 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi. I am using your attached atmolight (but still not updated hyperion). Attached log from crash to desktop immediately as media playback finishes.

    Edit. It is openelec 5.0.5

    After your command I get this

    Code (Text):
    1.  
    2. rPI:~ # curl -# -k -L --output install_hyperion.sh --get https://raw.github.com/
    3. tvdzwan/hyperion/master/bin/install_hyperion.sh && sudo sh ./install_hyperion.sh
    4. ######################################################################## 100.0%
    5.  
    6. There is no working 'sudo'.
    7.  
    8. On debian/ubuntu/all general purpose linux distributions 'sudo'
    9. allows a permitted user to execute a command as the superuser
    10. or another user, as specified by the security policy
    11.  
    12. With OpenELEC you have root access by default, so you dont need 'sudo'
    Does this mean it was successful or not?

    Edit 2: This worked..

    Code (Text):
    1.  
    2. rPI:~ # curl -L --output install_hyperion.sh --get https://raw.githubusercontent
    3. .com/tvdzwan/hyperion/master/bin/install_hyperion.sh
    4.   % Total  % Received % Xferd  Average Speed  Time  Time  Time  Current
    5.   Dload  Upload  Total  Spent  Left  Speed
    6. 100 10787  100 10787  0  0  10565  0  0:00:01  0:00:01 --:--:-- 10585
    7. rPI:~ # sh ./install_hyperion.sh
    8. *******************************************************************************
    9. This script will install/update Hyperion and it´s services
    10. Version 0.1
    11. *******************************************************************************
    12. ---> Stop Hyperion, if necessary
    13. ---> Raspberry Pi with OpenELEC found, but SPI is not ready, we write "dtparam=s  pi=on" to /flash/config.txt
    14. ---> Backup Hyperion configuration(s), if present
    15. ---> Downloading the appropriate Hyperion release
    16. ---> Downloading Hyperion OpenELEC release
    17. ######################################################################## 100.0%
    18. ---> Downloading Hyperion OpenELEC dependencies
    19. ######################################################################## 100.0%
    20. ---> Restore Hyperion configuration(s), if present
    21. ---> Starting Hyperion
    22. *******************************************************************************
    23. Hyperion Installation/Update finished!
    24. Please get a new HyperCon version to benefit from the latest features!
    25. Create a new config file, if you encounter problems!
    26. Path to your configuration -> /storage/.config/hyperion.config.json
    27. Please reboot your OpenELEC, we inserted dtparam=spi=on to /flash/config.txt
    28. *******************************************************************************
    29. ---> Do you want to reboot your Raspberry Pi now? (y or n) :
    30.  
     
    Last edited: March 13, 2016
  11. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,587
    Likes Received:
    2,625
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,572 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Try:
    Code (Text):
    1. curl -# -k -L --output install_hyperion.sh --get https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh && sh ./install_hyperion.sh
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!