Guide: Perfect playback & Display calibration (3 Viewers)

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    I've also made an observation that intel hd2000 has bad tearing and doesn't seem to be able to force vsync.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    So my recommend settings for Intel HD Graphics are:

    Intel: Set colourspace to RGB (ie don't tick the YbCbr box)
    LAV: Set to always 16-235, enable RGB24. disable everything else.
    TV: Set HDMI Black level to Low.

    Now play APL clipping.mp4
    Adjust brightness you should be able to see all the bars from 1-25 flashing
    If you can't see all the bars below 16 flashing then disregard these settings, because either your display is processing the signal different to me, or your AVR is interfering with the signal.
    Now decreased brightness until the reference black (16) is not flashing, but the bar # 17 is flashing (just visble)
    Bar #16 at this point should look very black.
    Now go play a movie with dark scenes and you should get very good detail.
    Unfortunately the greyscale ramp always has some banding no matter what settings you use for RGB/YbCbr/HDMI Black level, etc. If it;s not very black then these settings aren;t for you, you will need to experiment.
    You can also experiment with setting LAV output to always 0-255 however this seems to cut off black level 17 (ie 16 black and 17 almost black, both look the same colour), I guess this is due to colour space recompression artifacting.[DOUBLEPOST=1420361676][/DOUBLEPOST]^ even though i think those are the best settings for intel driver with mepo on my system, im forced to change hdmi black level to normal and lav video output to 0-255, this is because I have had to adjust colour settings for PDVD which I use to play blurays and it needs to have HDMI black level normal, otherwise it clips all the blacks, so I've made slight compromises in mepo. The most important thing is that you can see the difference between #17,#18 black levels (ideally also black #16 and black #17), and that 16 looks very black.
     
    Last edited:

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    I've also noticed another bug with MPAR, it doesn't like 2 channel AAC. The fix is to use ffdshow as preferred aac codec (under MP settings,codecs & renderer), and then in ffdshow settings under output, choose "Connect to: [Direct sound]", also untick AAC in the LAV Audio codec settings.
     

    LJG

    Retired Team Member
  • Premium Supporter
  • March 3, 2012
    457
    179
    Home Country
    United Kingdom United Kingdom
    @kiwijunglist junglist That's an interesting comment. Can I ask what problems you have had?

    I use MPAR with AAC in order to use WASAPI, this is the only way that I can get 5.1 audio out of the Freeview HD broadcasts in the UK, but I do get some sync issues sometimes, and thinking about it they could be linked to where the audio codec is AAC (for other media files, not TV).
     

    Owlsroost

    Retired Team Member
  • Premium Supporter
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    I don't know of any problems with LATM-packaged AAC (as used for DVB-T2 broadcasts e.g. in the UK and other parts of the world, like NZ).

    The recent mod to TsReader was to fix a problem with *some* DVB-IP streams which use ADTS-packaged AAC and LAV Audio Decoder.

    I've also noticed another bug with MPAR, it doesn't like 2 channel AAC. The fix is to use ffdshow as preferred aac codec (under MP settings,codecs & renderer), and then in ffdshow settings under output, choose "Connect to: [Direct sound]", also untick AAC in the LAV Audio codec settings.

    AFAIK, MPAR doesn't know the decoded audio data it receives is from AAC (and I've used MPAR quite a lot with stereo AAC - other than the A/V sync problems that lisag mentioned it works fine). The A/V sync problems are a known problem with MPAR, but I don't think these are specific to using it with AAC-derived audio sources.
     

    Peterpack

    Portal Member
    April 21, 2010
    33
    8
    Home Country
    Guys, i'm having a problem getting 7.1 audio (Dawn of planet of the apes remux) to my receiver. I have just upgraded my speakers to 7.1

    I changed the speaker setup in the Media Portal Audio Renderer settings to 7.1 but is still going to my receiver as 5.1

    I have a Denon receiver

    Any suggestions ?
     

    pur_berger

    Super User
  • Team MediaPortal
  • Super User
  • May 14, 2007
    1,679
    309
    51
    Vienna
    Home Country
    Austria Austria
    Guys, i'm having a problem getting 7.1 audio (Dawn of planet of the apes remux) to my receiver. I have just upgraded my speakers to 7.1

    I changed the speaker setup in the Media Portal Audio Renderer settings to 7.1 but is still going to my receiver as 5.1

    I have a Denon receiver

    Any suggestions ?
    If you use LAV you probably need to enable Bitstream for the required Codec to be send to your Receiver (Audio Codec - Edit) - otherwise it will always downscale it. Disadvantage - Your TV will (proably) not be able to understand the Format so no sound - only via Receiver.
     

    Peterpack

    Portal Member
    April 21, 2010
    33
    8
    Home Country
    Guys, i'm having a problem getting 7.1 audio (Dawn of planet of the apes remux) to my receiver. I have just upgraded my speakers to 7.1

    I changed the speaker setup in the Media Portal Audio Renderer settings to 7.1 but is still going to my receiver as 5.1

    I have a Denon receiver

    Any suggestions ?
    If you use LAV you probably need to enable Bitstream for the required Codec to be send to your Receiver (Audio Codec - Edit) - otherwise it will always downscale it. Disadvantage - Your TV will (proably) not be able to understand the Format so no sound - only via Receiver.

    Thanks for your suggestion :)

    Now in the properties for LAV, under the bitstreaming formats, DTS-HD i can't tick the box for and that's the one i need to tick, why would that be ?

    thanks again[DOUBLEPOST=1421317510][/DOUBLEPOST]sorry i worked that one out, had to tick dts first before being able to tick dts-hd :)
     
    Last edited:

    Users who are viewing this thread

    Top Bottom