[WiP] madVR support in MP1 (2 Viewers)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    @Sebastiii For me it is fine with the std. 1.16pr but as soon as I upgrade and start v289 the additional display of Weather Lite is not there at all and Alt+Enter toggling to Windowed mode and back to full screen does nothing for me, it is still missing.:(
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    @joecrow i will link ti a master build to see how it goes because there is change on it but no change from madVR, so it means madVR code remain to 1.16Pre and with other branch bugfix in it :p
     

    ThoW1982

    Portal Member
    November 6, 2010
    17
    12
    United Kingdom United Kingdom
    Country flag
    Hi

    I have some issues with madvr and would like to report them.

    I have AMD 280x with 17.2.1 drivers; 2 displays 1-Acer monitor non 3D 2-Samsung 3D TV working in clone mode, both 1080p60. I use Streamedmp skin with 1.16 Pre Release core.dll overlay fix made by Sebastiii from this thread.

    I have disabled Bluray Menu in Mediaportal Configuration and now when I play Bluray 3D .iso I get side by side 3D, not frame packed 3D (all my Blurays are 'frame packed').

    In madvr settings under devices->properties if Acer has '3D format' selected as 'none' I get 3D .iso displayed in side by side on my 3D TV instead of frame packed. Madvr '3D format' for Samsung TV is set as 'auto'

    If I set '3D format' in Acer to 'auto' or disable Acer display Mediaportal switches to 1080p24 and plays .iso 3D in frame packed mode. All seem to be good. But when playback stops Samsung TV switches to 1080p30, not as it should to 1080p60 and the UI is acting weird (laggy).

    I have tried multiple things to solve it including using v289 core.dll with Ares skin and can not solve this.

    How do I make Mediaportal to switch to 1080p60 after stopping Bluray 3D .iso playback? Also in madvr settings I tried to put 1080p24, 1080p30, 1080p60 in display modes for both displays - that doesn't help at all.
     
    Last edited:

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Normally, it should be madVR to restore the refresh rate :)
    it can happen that madVR start restore but too soon because of C# vs C++ code marshaling so not sure if it can be fixable.
    To be able too, i need to reproduce the issue and need surely same hardware ? so it will be hard !!!
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    @joecrow : master build : http://tinyurl.com/jrscxdk
    master was merged into madVR build (after v281) so maybe it's master issue or madvr :)
    This is very weird, I did an upgrade install on top of std. 1.16pr on my desktop and the extra Weather Lite display was/is working both before and after the install, no problem. I did exactly the same thing on my HTPC, Weather Lite extra display working before the upgrade but totally gone after,:eek:o_O:confused:. only able to get it again with a System restore back to the std. 1.16pr.
     

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    In madvr settings under devices->properties if Acer has '3D format' selected as 'none' I get 3D .iso displayed in side by side on my 3D TV instead of frame packed. Madvr '3D format' for Samsung TV is set as 'auto'
    sadly quite true with dual screen. i have had a similar 3d experience with nvidia cards - no 3d frame packed only sbs.
    i ended up using the tv as primary (extended desktop mode) and set madvr 3dformat auto on all monitors (it doesn't matter if they support 3d really)
    also that the extra setting isn't necessary with mphc for 3d-frame packed playing correct .... mphc seems to handle it different.
    with mphc 3d works with and without the madVR 3d format setting set to auto on and even as secondary screen...

    tried 3d a bit with v289 on my htpc yesterday with following results:
    first run: madvr osd exclusive mode failed!->it starts playing in d3d11 windowed mode-> 2d :(
    second run: d3d11 fse ok -> 3d ok (y)
    third run: d3d11 fse ok -> 3d ok (y)

    so i once again tried directly from 3d to 3d without stop in between:p
    it seems working without a full mepo crash now(y)(y)(y) but only every second time it starts playing 3d as it should be.
    on every second start its faulty, with the same exclusive failed error as before ->d3d11 windowed mode playing in 2d....

    if 3d is correctly playing, the only problem i still see is on start. it always drops a lot of frames (around 200-300) after that its smooth playing till the end.
    but this is also probably very depending on settings (and hardware) ....damn 3d stuff :censored::D
     

    ThoW1982

    Portal Member
    November 6, 2010
    17
    12
    United Kingdom United Kingdom
    Country flag
    if 3d is correctly playing, the only problem i still see is on start. it always drops a lot of frames (around 200-300) after that its smooth playing till the end.
    but this is also probably very depending on settings (and hardware) ....damn 3d stuff
    This happens to me too every time I start 3D frame packed playback. No matter what settings I use.

    Re Mediaportal failing to switch back to 1080p60 after playback of frame packed 3D (in my case it switches to 1080p24 when 3D starts, then to 1080p30 when 3D stops). Setting 'Force MP refresh rate (for 3D)' in madvr Mediaportal tweaks solves the issue with 3D for me - Mediaportal switches back to 1080p60 after playback of 3D frame packed .iso stops.
    But it creates disruption (a new problem o_O) after start of both 2D and 3D contents -> all playback starts in windowed mode then switches after few seconds to exclusive (full screen) mode. This happens for both D3D11 and D3D9. I have tried to use settings available in madvr->rendering->exclusive mode settings and disable 'delay switch to exclusive mode by 3 seconds' thinking it could solve the new problem, but this doesn't seem to help, actually it's acting weird because I disable that option, switch Mediaportal on, do tests, close Mediaportal, access madvr settings and 'delay switch to exclusive mode by 3 seconds' is enabled again. Puzzled :confused:
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 13
    A 1.24.0 1.24 Kills 3D MVC playback on MadVr 1.24 Pre Release 66
    X MadVR Settings Video & DVD 2
    G MadVR, black TV Picture 1.20 Pre Release 1
    S Pause button no longer works with MadVR in 1.19 General Support 4
    C Is there an ideot save how-to implement madVR incl. HDR? Codecs, External Players 1
    Palm_Maniac madVR Frage Allgemeines Supportforum 19
    CyberSimian Support for control.isvisible() in expressions MediaPortal 1 8
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    J Support waipu TV TV-Server 0
    doskabouter WebDAV support OnlineVideos 0
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    CyberSimian Support pack for Ortek VRC-1100 and Hama 00052451 Remotes 6
    cbr954rr [Finished] [MP2-801] Support for tag image extraction Archive 7
    catavolt [solved] FanartHandler - Skin - Holiday and Spotlight support Fanart Handler 9
    C Drive Type is not supported by system Allgemeines Support- und Diskussionsforum 3
    raffe [solved] Export tool and import support from MP-TVSeries & Moving Pictures to MP2 General 22
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    E M3U Playlist and EPG Support/Configuration Installation, configuration support 1
    G Mediaportal2 supported formats General 1
    M [solved] Stub Support General 11
    morpheus_xx [WiP] Adding 64 bit support to MP2 MediaPortal 2 15
    A Mediaportal 1.20 support MediaPortal 1 Talk 3
    Lehmden FTP and WebDAV support. MediaPortal 2 0
    Top Bottom