Mouse Cursor is always present (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Good news and perhaps for everyone.

    Apparently the issue is related to a Microsoft update.

    After the Windows Updates of last week the problem disappeared for me.

    Except for reinstalling the MP-TVSeries plug-in - as requested but which did not help - I did literally nothing with my HTPC.
    After updating Windows with last week (Tuesday) patches (there were a lot) - which I did yesterday - the mouse pointer is gone again.
    I cannot explain it.
    Perhaps the binary of MP-TVSeries was compiled against a new version of a library/dll in Windows that just recently got pushed to the desktops.

    Make sure you update your Windows, reboot and see if the problem persists.
    Sadly the mouse cursor issue has raised its head once again, I have done all the windows updates, uninstalled tvseries plugin and reinstalled from the extension installer, used mediaportal 1.11 now onto mediaportal 1.12 pre release.
    @Sebastiii i will try your bin files in the next few days.Maybe the issue is related to waking the PC from sleep/hibernation, as I only get this issue when my PC resumes from its sleep state?
    It's possible that it happen after resume but please log :) and hope you can try V2 and V3 :p
     

    jan.schreibe

    Portal Member
    January 11, 2009
    13
    2
    Germany Germany
    Here we go for V3 bin :)
    And always, log (debug mode).
    Thanks.
    Hi,

    sorry, forgot to switch to debug. Good News: I installed V3 and it seems to fix the mouse cursor problem for me! Before V3 i had it 100% every time i started my rig, did two reboot now and both times i had no problem anymore!

    Thank you so much!

    Kind regards

    Jan

    Logfiles (Debug mode enabled) for V3 attached.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Here we go for V3 bin :)
    And always, log (debug mode).
    Thanks.
    Hi,

    sorry, forgot to switch to debug. Good News: I installed V3 and it seems to fix the mouse cursor problem for me! Before V3 i had it 100% every time i started my rig, did two reboot now and both times i had no problem anymore!

    Thank you so much!

    Kind regards

    Jan

    Logfiles (Debug mode enabled) for V3 attached.
    Thanks m8 :)

    That's a good news, i will look the log.
    So i will integrate this into my own use to see if it trigger some something wrong or not.
     

    ryan1

    Portal Member
    April 29, 2008
    30
    11
    United States of America United States of America
    I can also confirm that 1.12 pre-release with your v3 mediaportal.exe file eliminates the mouse cursor, even after multiple reboots and hibernations.

    If others confirm this also, hopefully you can merge the changes you made into the final release of 1.12

    (y)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Sure :) it all is ok like it's a bugfix, it can go into 1.12 Final :)
    For now i notice a very little regression, so i will upload a new V4 version that fix that and i would like to know if all is ok on your side (guys).
    The regression ws if we start to move the mouse, the cursor didn't show up directly (for the one that use the mouse) but it's a very little regression and we can keep it like that if it's solve your issue :p bu who knows maybe V4 will be enough too.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    First post edited with Jira link and bin link :p
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ge2301 [Finished] [MP2-782] Show mouse cursor only if it was moved more than 10 pixels MediaPortal 2 13
    J Make the mouse cursor "inactive" when Enter is pressed Feature Requests 2
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    HTPCSourcer [Rejected] Mouse movements and focus: Windows standards MediaPortal 2 3
    N [confirm] Playing a recording, then pressing stop does not leave cursor on the recording MediaPortal 2 21
    B [MP2-772-773] improve busy cursor and settings loading Testing Area 10
    M partially watched video/song/recorded tv show file text color + remember cursor in folders other features (of release or svn versions) 28
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    M [Rejected] Always show full hours in TV Guide Feature Requests 2
    M [Duplicate] Always enter full screen when entering TV from main Menu Feature Requests 1
    Terra Videos do not start playing on first attempt, always have to press play twice General Support 9
    HTPCSourcer [fixed] [MP2-794] Genre filtering always displays English strings MediaPortal 2 9
    M Tuner always in use General 2
    W Strange recording behavior - Schedule shows type once when should be always General Support 1
    Alberto83 [fixed] Live TV always using highest priority tuner? Archive 23
    Top Bottom