MP2 - V2.1 [MP2-554] Installer recognizes Spring '16 as newer (1 Viewer)

Status
Not open for further replies.

breese

Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    I have my installers in the same locations every time so as my Uninstaller will work (quick uninstall and remove all directories for Fresh Installs.

    I could no make other screenshots, but the control panel looks the same for Spring'16 and the "remove" button is the same though

    The problem comes in when you remove the Old Setup.exe and replace it with the new one, you cannot get past the message that you "Cannot upgrade from a Newer Version". I.E. 2.1.16 VERS 2.16
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    Investigations should be better spent on WIX version upgrade definitions
    While someone looks into that...
    How about expanding the installer help window to show all of the available options

    upload_2017-1-2_8-32-43.png
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    The problem is the wrong version number of Spring 16, which lacks a "0". We can of course ask people to uninstall before launching the 2.1pre package. No objection.

    I don't see much value in spending time to programmatically address the problem. It's a one-time thing that will not occur in the future anymore. So better advise people to uninstall Spring 16, ensuring them that their data will be preserved.

    I have no clue why in one particular case, things didn't work as expected. The user has in the meantime resolved his problem.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,777
    7,127
    Home Country
    Germany Germany
    Country flag
    The problem comes in when you remove the Old Setup.exe and replace it with the new one, you cannot get past the message that you "Cannot upgrade from a Newer Version". I.E. 2.1.16 VERS 2.16
    Never have heard this and I also could not reproduce:
    I have removed my old installer and was still able to uninstall MP2 from control panel/programs.

    Also keep in mind that our .exe is only a bootstrapper, which extracts the inner .msi into some temporary system folder before actually installing it. So I really doubt that uninstall success is dependend on original file at install location.
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    While the script seemed to work The version is still not changed correctly
    View attachment 185525
    No, i did not work. Note that the new version is now 2.16.4.7790 - the "0" in front of the 4 is gone. Which is really weird because the batch cannot have done this change. Anyway, we'll ask users to uninstall Spring '16 first before running the installer. I'll change the release news and add info to the Wiki.

    Thanks for your help. Dismissed... :) Now go and check the ISO thing :D
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    I have removed my old installer and was still able to uninstall MP2 from control panel/programs.
    Then it might be recommended that users Uninstall from the Programs and Features Control Panel in the Release notes.
    If they deleted the Orig Installer when downloading the new, this would be the only way to remove the old....

    (just verified the Control panel way does work).
    Reinstalling MP2.1 now

    EDIT:
    Uninstalling from the control panel leaves the Client Launcher and the Server Monitor running....
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,777
    7,127
    Home Country
    Germany Germany
    Country flag
    EDIT:
    Uninstalling from the control panel leaves the Client Launcher and the Server Monitor running....
    Yes, unfortunately. Clean shutdown is only possible starting with 2.1 build :(
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Similar threads

    Der DirectX-WebInstaller wird nicht richtig ausgeführt. Lade und installiere das DX9-Runtime separat (Link). Danach MP2 erneut installieren.
    Der DirectX-WebInstaller wird nicht richtig ausgeführt. Lade und installiere das DX9-Runtime separat (Link). Danach MP2 erneut...
    0xfffffff7 unbekannter Fehler log file:
    Replies
    1
    Views
    611
    got it, and it worked. Thanks!
    got it, and it worked. Thanks!
    MP1 installs and runs with no problem, But MP2 errors out - seems to exit at the Direct X9 install. System is a newer comp w/win...
    Replies
    3
    Views
    963
    • Locked
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this situation, and that people may preferentially view 2.1.3 as the current stable.
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this...
    Hello all, I would like to try MediaPortal 2, but have run into a show stopping installation bug. The installation fails with...
    Replies
    19
    Views
    3K
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my keyboard just fine (also lightspeed wireless). Suggestions?
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my...
    Good evening, having just fresh installed media portal 2.3.2. Looking at trialing again as it now seems to support what I am...
    Replies
    1
    Views
    237
    MP1 MP2 Error on install DE
    Yes, but it is not found: Manual installation should solve it directly. I'm not sure, if 4.7.1 will work. MP2 expects 4.7. I checked and we have not updated yet.
    Yes, but it is not found: Manual installation should solve it directly. I'm not sure, if 4.7.1 will work. MP2 expects 4.7. I...
    cant install on a new Windows 10 PC Log is [0E98:1734][2018-04-08T19:17:59]i001: Burn v3.11.0.1701, Windows v10.0 (Build 10240...
    Replies
    3
    Views
    2K
    Top Bottom