Netflix for OnlineVideos (2 Viewers)

PFJ

Portal Member
November 30, 2014
8
3
57
Sweden Sweden
No, sorry that is not right. I have tried it a lot of times and every time I had verified that the site was up and functional.
And I also tried one more time after your answer. And as I said before "My list", "Search" and "Kids" works and I can play the videos but not browse subcategories and I can't see any listed video.
So it has to be anything else.
 

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    No, sorry that is not right. I have tried it a lot of times and every time I had verified that the site was up and functional.
    And I also tried one more time after your answer. And as I said before "My list", "Search" and "Kids" works and I can play the videos but not browse subcategories and I can't see any listed video.
    So it has to be anything else.
    Hmm, it works without hiccups here, as we both reside in Sweden that is strange. Do you use Swedish Netflix or American through some kind of VPN service?

    Can you force a new login and clear the OnlineVideos cache by exiting Mediaportal an start it again, does it work then? If not, restart MP again with the watchdog and repeat the problem to generate logs. Attach them in this thread so I can analyze them.
    See the opening post for instructions.
     

    PFJ

    Portal Member
    November 30, 2014
    8
    3
    57
    Sweden Sweden
    Hi again
    Thanks for taking your time with my problem:)
    I tried to restart MP, cleared IE cache, etc. but no luck.
    I have never used Watchdog so I hope I got it right, se attached file.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    Can you try to disable descriptions (well all the extra features)? And read PM.
     

    PFJ

    Portal Member
    November 30, 2014
    8
    3
    57
    Sweden Sweden
    I have disbled all extra feautures and also read your instructions one more time.
    I tried to restart MP, cleared IE cache, etc. but still no luck
     

    Jason Pyke

    Portal Pro
    April 12, 2013
    96
    38
    Great Britain (UK) Great Britain (UK)
    @popy, The latest version of OV hasn't been released yet, so you will still get this error. Could you also please attach full logs as a matter of course - there may be something obvious in there.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    @PFJ can you "try" this dll, remove the .zip extension (it will not fix anything, I only need to verify the problem).
    Goto C:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\Windows\OnlineVideos (if you have installed in this location of course...)
    Backup the old file and replace it with this.
    Attach or PM me OnlineVideos.log

    No one else needs to download this file, since it WILL break other sites! It is only to debug a certain part of Netflix.
     

    Attachments

    popy

    Super User
  • Team MediaPortal
  • Super User
  • July 3, 2011
    617
    141
    Country flag
    @Ministerk: Attached the debug logs created with watchdog option 2 and reproduced the issue.

    Here is something interessting:

    Code:
    [2014-12-01 21:13:50,365] [Error  ] [44       ] [ERROR] - [OnlineVideos] log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [encoding] to set object on [log4net.Appender.ConsoleAppender]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [lockingModel] to set object on [log4net.Layout.PatternLayout]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [encoding] to set object on [log4net.Appender.BufferingForwardingAppender]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [lockingModel] to set object on [log4net.Appender.BufferingForwardingAppender]
    Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
       bei OnlineVideos.Sites.WebAutomation.BrowserHost.BrowserForm.ForceQuit()
       bei OnlineVideos.Sites.WebAutomation.BrowserHost.BrowserForm.BrowserForm_Load(Object sender, EventArgs e)
    
    [2014-12-01 21:13:50,365] [Log    ] [MPMain   ] [DEBUG] - Main: WM_ACTIVATE (WA_ACTIVE)
    The exception text is the same as in my screenshot before but what are the log4net messages before?

    thx
    pOpY
     

    PFJ

    Portal Member
    November 30, 2014
    8
    3
    57
    Sweden Sweden
    I do not know if I understood correctly, this is what I did: .
    1) closed MP
    2) downloaded 212794_OnlineVideos.Sites.ministerk.dll.zip and removed .zip
    3) renamed OnlineVideos.Sites.ministerk.dll to OnlineVideos.Sites.ministerk.dll.bck
    4) Copied the file from point 2 to the same library as in point 3
    5) Started MP
    6) Went into the OV-Netflix and tried to browse a few categories.
    7) Attached the latest OnlineVideos.log to this message

    Hope that I got it right, excuse me otherwise.

    Brgds
    /Per
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    I do not know if I understood correctly, this is what I did: .
    1) closed MP
    2) downloaded 212794_OnlineVideos.Sites.ministerk.dll.zip and removed .zip
    3) renamed OnlineVideos.Sites.ministerk.dll to OnlineVideos.Sites.ministerk.dll.bck
    4) Copied the file from point 2 to the same library as in point 3
    5) Started MP
    6) Went into the OV-Netflix and tried to browse a few categories.
    7) Attached the latest OnlineVideos.log to this message

    Hope that I got it right, excuse me otherwise.

    Brgds
    /Per
    You did it the correct way, but I don't now why the attached file got prefixed with 212794_ :confused:. The filename should be OnlineVideos.Sites.ministerk.dll
    If it's not to much of a hassle could you please repeat it again, but without the prefix also?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom