Netflix for OnlineVideos (4 Viewers)

lulsam2

Portal Member
September 2, 2020
7
3
Spain Spain
Country flag
Just a few words to report that now it works again. A big thank you @doskabouter

PD: If you need help to figure out how it works on Kodi, I could install it and provide logs, just let me know.

Best
 

doskabouter

Development Group
  • Team MediaPortal
  • September 27, 2009
    3,593
    1,799
    Nuenen
    Netherlands Netherlands
    Country flag
    Just a few words to report that now it works again. A big thank you @doskabouter

    PD: If you need help to figure out how it works on Kodi, I could install it and provide logs, just let me know.

    Best
    Thanks for the offer. I already managed to get more logging, only thing that is not working is having a sniffer (f.e. fiddler) getting the exact requests and responses from kodi....
     

    lulsam2

    Portal Member
    September 2, 2020
    7
    3
    Spain Spain
    Country flag
    Hi again,

    since last report i have been suffering problems while trying lo log into the Netflix account from OV. At the beggining I thought it is the typical on time issue or something that an upgrade will solve, but after one month I think this is not the case so I guess it is better to report.

    Navigating into the logs I found this:

    [2020-10-17 13:08:44,386] [Error ] [OVInit ] [ERROR] - [OnlineVideos] Vimeo: Error getting oauth token : Anulada la solicitud: No se puede crear un canal seguro SSL/TLS.
    [2020-10-17 13:09:06,079] [Error ] [OVLoad ] [ERROR] - [OnlineVideos] Vimeo: Error getting oauth token : Anulada la solicitud: No se puede crear un canal seguro SSL/TLS.

    It is partially in spanish, but basically it says that it cannot create a SSL/TLS secure channel because the authentication failed. Tested in 3 different PCs, two with Windows 7 (both fail) and one wih Windows 10 (and it works!!). It si clear that it fails becoause something on windows 7 that needs to be updated or hacked, my question is: any idea about if iti is still possible to use OV with W7 for Netflix or must I upgrade?
     

    cbr954rr

    Portal Pro
    October 31, 2016
    115
    7
    46
    Germany Germany
    Country flag
    In my opinion it will be more comfortable to have a plugin that reads a site like netflix and render it to mp. Then users can use that with various streaming sides, like amazon, joyn.de etc.

    The problems with no functional sides and the differences with the gui of a side and the gui online-videos should be also solved with such a plugin
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,593
    1,799
    Nuenen
    Netherlands Netherlands
    Country flag
    Hi again,

    since last report i have been suffering problems while trying lo log into the Netflix account from OV. At the beggining I thought it is the typical on time issue or something that an upgrade will solve, but after one month I think this is not the case so I guess it is better to report.

    Navigating into the logs I found this:

    [2020-10-17 13:08:44,386] [Error ] [OVInit ] [ERROR] - [OnlineVideos] Vimeo: Error getting oauth token : Anulada la solicitud: No se puede crear un canal seguro SSL/TLS.
    [2020-10-17 13:09:06,079] [Error ] [OVLoad ] [ERROR] - [OnlineVideos] Vimeo: Error getting oauth token : Anulada la solicitud: No se puede crear un canal seguro SSL/TLS.

    It is partially in spanish, but basically it says that it cannot create a SSL/TLS secure channel because the authentication failed. Tested in 3 different PCs, two with Windows 7 (both fail) and one wih Windows 10 (and it works!!). It si clear that it fails becoause something on windows 7 that needs to be updated or hacked, my question is: any idea about if iti is still possible to use OV with W7 for Netflix or must I upgrade?
    Well this has nothing to do with netflix...
    There are a few things that could have influence on ssl/tls stuff: one is the current time on that pc has drifted, second is that they now use tls1.2 which is not standard enabled in the onlinevideos plugin.
    Are other people suffering from this same issue?

    In my opinion it will be more comfortable to have a plugin that reads a site like netflix and render it to mp. Then users can use that with various streaming sides, like amazon, joyn.de etc.

    The problems with no functional sides and the differences with the gui of a side and the gui online-videos should be also solved with such a plugin
    That method also has its challenges... especially when navigating through a site (f.e. to find a particular video) when the only thing you have is a remote control.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,593
    1,799
    Nuenen
    Netherlands Netherlands
    Country flag
    Hm, wouldn't have expected that tbh. do you have an onlinevideos.log in debug mode where you failed to do the login step?
    Actually, there are 2 places where there's logging in going on... first one is when you browse through your videos and select a movie/series (that part is put in onlinevideos.log) and the second one is when you selected something to watch and switch over to the browser-emulator part (that is in a different log-file).
    Which part refuses to login at win7?
     

    lulsam2

    Portal Member
    September 2, 2020
    7
    3
    Spain Spain
    Country flag
    Well, the login error happens at first step, while trying to get the profiles list. Attached is the onlinevideos.log file with Debug mode enabled. I took a look but it doesn't seem to have any relevant error until it goes to the login page Netflix, it is also the first time it uses TLS/SSL at all... If OV relies on a windows component to stablish the coms, maybe this is the source of the issue, and if it works on 10 but not on 7, it could be the version of this component.

    Rgds
     

    Attachments

    highcoder

    Portal Member
    October 3, 2008
    9
    3
    Germany Germany
    Country flag
    @lulsam2 I can´t confirm your assumtion. I´m on Win10 LTSB 2016 (1607) with my MediaPC and can´t login.
    @doskabouter No timedrift, current windows patchlevel, MP 1.24.0. How can we enable TLS1.2 in Online Videos? I didn´t see any encryption options in the configurator.

    I´ll try it tomorrow on a current windows 10 machine (2004). Maybe it´s like lulsam2 says, an outdated win component.

    Greetings from Germany.
     

    Users who are viewing this thread

    Similar threads

    Top Bottom