OnlineVideos 2.0 Beta Test

Status
Not open for further replies.

Jason Pyke

Portal Pro
Joined
April 12, 2013
Messages
96
Points
18


For Sky Go there doesn't appear to be anything I can easily hook in to for information, or even actions (there aren't even keyboard or javascript shortcuts for play/pause). I also want to investigate the MediaPortal sleep method being used as it seems to cause extra CPU usage and may have a bearing on playback. Unfortunately, none of these things are quick or easy to investigate.
 

TheBatfink

MP Donator
Joined
June 11, 2007
Messages
1,285
Points
63
Location
Nottingham
Country flag
I wonder if it is being displayed in a non-native framerate as at least in my case it seems very repetitive with the judder, although I guess that doesn't explain why I don't notice it in a normal browser. Thanks anyway!
 

Arni_69

Portal Member
Joined
November 18, 2014
Messages
25
Points
3
Age
41
Ok testet the remote procedure with the original .dll first. Only Stop-Button work.
Then I test the new .dll . from #21 .Here is only a white screen popping up. Netflix dont start.
 

powermarcel10

Retired Team Member
Joined
November 30, 2010
Messages
2,839
Points
113
Age
31
Location
Groningen
Thanks for the new version! Good to see that this awesome plugin is still be maintained.

I will test this new version ASAP!

Question: Are there any skin related changes since this version?

Cheers,
Marcel
 

Ministerk

Super User
Joined
November 28, 2007
Messages
970
Points
63
Location
Uppsala
Country flag
Ok testet the remote procedure with the original .dll first. Only Stop-Button work.
Then I test the new .dll . from #21 .Here is only a white screen popping up. Netflix dont start.
Strange. Only see the initialization of the plugin in onlinevideos.log and nothing else. And there're no browser player logs... :( @Arni_69 big thanks for your help, but the logs does not give me enough info to now where to start to look for problems...
One question (don't get mad at me for asking this, need to be sure), after you started MP with the watchdog - did you reproduce the problem before exiting MP? Read more about the WatchDog in the wiki.

Did you try to unblock the dll/zip described in post #21?
 

ltfearme

Community Plugin Dev
Joined
June 10, 2007
Messages
6,656
Points
113
Location
Sydney
Country flag
The StreamedMP BasicHome editor also needed an update, just a re-compile against the latest version of OnlineVideos. If you need to use it, you can replace your existing file in C:\Program Files\Team MediaPortal\MediaPortal\plugins\process with the one attached to this thread.
 

Attachments

Ministerk

Super User
Joined
November 28, 2007
Messages
970
Points
63
Location
Uppsala
Country flag
Yes, better. Now do the same thing with the new dll (the one from post #21 you now ;) ).
I'm going to do step by step instruction here, I really want to be sure we cover everything:
  1. Close MP
  2. Remove all traces of the dll from post #21 (we don't want to accidentally use a old one!)
  3. Move the original ministerk dll from plugins directory to desktop
  4. download the zip file again from post #21
  5. before unzip right click the zip file choose properties and unblock the zip file
  6. extract the dll and copy it to the correct plugin folder
  7. Goto the logs directory, remove all log-files
  8. Make sure the browser debug is enabled
  9. start mp with the watchdog (report to plugin developer choice)
  10. Goto OnlineVideos -> enter netflix -> start a video
  11. Cross your fingers... If crash goto 13
  12. Let it play for awhile then use the remote
    1. Pause
    2. Play
    3. Right
    4. Left
    5. Stop
    6. Back (if stop didn't work)
    7. Clear (if stop didn't work)
  13. Close MP
  14. Collect logs
  15. Have a nice weekend!
 

Ministerk

Super User
Joined
November 28, 2007
Messages
970
Points
63
Location
Uppsala
Country flag
@ltfearme, I'm adding some TV series scrobbling/tracking info to a couple of site and I noticed that the scrobbling did not stop even if I stopped the video.
This is with OnlineVideos 2.0 and Trakt 5.2.0.0.

According to the trakt website I have now watched 50 minutes of Columbo 4x04 "Troubled Waters"... Just played around 30 seconds. Total length of episode is two hours. If it isn't in my history tomorrow, I will let you know.

Edit: should have put this in the trakt sub forum, time for bed maybe...
 
Status
Not open for further replies.
Top