Plugin: RefreshRateChanger (1 Viewer)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,487
    7,020
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #41
    -Be able to see my recordings from TV
    OT: this is already possible if you add the recording folder as MediaSource. Or what do you mean? If there are more questions/requests, please start an own thread, this helps to keep track of it.

    Now back to RRC:
    Does the playback works smooth now because of forcing rendermode to VSync?

    -RefreshRate switch from 60hz to 24hz
    I know you might have explained it already, but can you please explain in few words what currently happens and what you would expect. I'm sure we'll find a solution :)
     

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    OT: this is already possible if you add the recording folder as MediaSource
    You're right, I add the recording folder as MediaSource and I can now see my recordings.

    I feel that vsync is not good for AVC/AAC videos files, I experience a/v sync problem when skipping through the videos. If I skip in videos with passthrough (Dolby Digital, DTS etc...) there is no a/v problem in vSync.

    If I play the faulty AVC/AAC video in default mode, and skip througt video, I don't have a/v sync issue.

    And for the 60hz to anything is shitty thing, I made a video that I hope will help you out.
     
    Last edited:

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,487
    7,020
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #43
    I feel that vsync is not good for AVC/AAC videos files, I experience a/v sync problem when skipping through the videos. If I skip in videos with passthrough (Dolby Digital, DTS etc...) there is no a/v problem in vSync.
    Does the sync get correct again, if you manually switch back to "Default" render mode? Then it acts as before.

    And for the 60hz to anything is shitty thing, I made a video that I hope will help you out.
    Strange.
    One question: if you disable RRC and manually chose a 23Hz rate in Windows display settings and then start the playback, it is the same? I'd like to see if the issue is caused by dynamically switching or if it also appears if refresh rate is taken from Windows.
     

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    Does the sync get correct again, if you manually switch back to "Default" render mode? Then it acts as before.
    Nope, I need to stop/play.

    One question: if you disable RRC and manually chose a 23Hz rate in Windows display settings and then start the playback, it is the same? I'd like to see if the issue is caused by dynamically switching or if it also appears if refresh rate is taken from Windows.
    I let RRC activated and started MP2 at 23hz and everything play flawlessly. Same thing when I started in 50hz. the only problem is when I start MP2 at 59 or 60hz.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,487
    7,020
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #45
    Next try: I changed the logic for rate changes:
    1. Pause player
    2. Switch refresh rate
    3. Reset DX device
    4. Resume playback
    This required one change in SkinEngine, so please update both contained plugins and test again. Thanks!
     

    Attachments

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    Unfortunatly, it's not better. Same behavior at 59hz. I did not try 24 or 50hz.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,487
    7,020
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #47
    Did you manually select vsync again? I forgot to mention, resetting the DX device leads to Default rendermode again.
     

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    Did you manually select vsync again? I forgot to mention, resetting the DX device leads to Default rendermode again.
    Yeah I tried with no improvement :(

    Again, if I start MP2 with these refreshrate:
    • 59hz to 24hz stutter
    • 60hz to 24hz = stutter
    • 50hz to 24hz = perfect playback
    Don't give up. with the new files, I had strange thing happening when I press stop, the menugui appears after 5 to 10 secs. During these timelaps I only see the background.
    stop.jpg
     

    Attachments

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    Did you have time to code something so I can test this week-end ? :coffee:
     

    kilik360

    MP Donator
  • Premium Supporter
  • September 3, 2010
    574
    232
    Canada Canada
    Country flag
    I'm using 2014-11-01 snapshot, with the "Fixed render synchronization after VideoPlayer ended, it could happen…" commit and it's not better :(

    When I play a file, 24p in this case, through the end, RRC reswitch my TV to 24hz instead of 59hz.

    But if I stop the video myself, it turns to 59hz fine, every time.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    morpheus_xx [WiP] "What's New" plugin for MP2 upgrades MediaPortal 2 20
    da3dsoul [Request] An MVP Plugin example for custom settings in MP2 Plugin Development 2
    da3dsoul MP2 Plugin - Getting Started (Directory Tree and Player) Plugin Development 27
    M Installing Plugins Newcomers Forum 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 10
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    cbr954rr How to disable a pre-configured plugin? General 2
    mrmojo666 [Plugin]Marantz Control Plugin 0.0.0.2 MediaPortal 1 Plugins 2
    mrmojo666 beginner: trying to write a plugin, need help to catch event General Development (no feature request here!) 3
    framug [Rejected] Fix PowerScheduler plugin for MP2 single seat Submit: Code Patches 9
    doskabouter [Question] Stale plugins Developer Discussions 9
    M MP1 stops responding after Starting Plugins General Support 14
    Terra LAVFilter Plugin cannot be updated (MP1.23) MediaPortal 1 Plugins 10
    L Mediaportal 1.21 and Windows 10: user schedules de-activated when powerscheduler plugin is selected General Support 1
    Similar threads

























    Top Bottom