Problems with skipping during timeshift multiseat (1 Viewer)

infinite.loop

Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Hopefully the SMB ts-buffer rollover problem is fixed in the next build then, so we can switch away from RTSP in multiseat.
    Be aware that the team does not give any support for those who use the SMB - HACK in multiseat.
    This option is only there for testing and debug reasons!
     

    Wondermusic

    Extension Developer
  • Premium Supporter
  • September 7, 2009
    1,113
    274
    Wuppertal
    Germany Germany
    Country flag
    AW: Re: Problems with skipping during timeshift multiseat

    I believe this is a big problem so here are my logs.
    client and server.
    multiseat
    client is not in the same computer as server.

    steps:
    16.15 start timeshift
    16.22 2xstep back (shows -30sec) (but does not do it) NOK
    16.22 2xstep back (shows end) (but it shoulnt) NOK
    16.23 2xstep back (shows -30sec) OK
    16.23 3xstep back (shows -1min) OK
    16.24 steps forward (shows end) OK

    if there is any official steps to follow please tell me as i didnt know how to test it correctly, hope the logs are of any use.

    btw, although im sure its somewhere in the logs. im using SVN from 24/12/09 24553
    Have the same thing here since i installed a homeserver (previously everything was in my htpc: server/client and all went fine).

    start timeshift
    2 steps back (shows -30sec) - done nothing
    2 steps back (shows End) - done nothing
    Back to beginnig (Shows Beginnig) - OK
    2 steps forward (shows +30sec) - OK
    2 steps forward (shows +30sec) - OK
    Forward to End (shows End) - OK
    2 steps back (shows -30sec) - goes back about 45sec

    waiting 2 min.

    2 steps back (shows -30sec) - done nothing
    2 steps back (shows -30sec) - done nothing
    Back to beginnig (Shows Beginnig) - OK
    5 steps forward (shows +3min) - forwards nearly to end
    Forward to End (shows End) - OK

    I' ve tried to make the logs with Watchdog, but when it is gathering system eventlog information it hangs. Waited for about 10min. but nothing. I aborted it and copied the logs manually. Hope you can use them...

    Tested with SVN 24669 on my Office- Computer (Win7 x64, 4GB DDR2, Intel E7200, ATI 4870, SAF installed)

    Greets,
    Wondermusic
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    AW: Re: Problems with skipping during timeshift multiseat

    Hopefully the SMB ts-buffer rollover problem is fixed in the next build then, so we can switch away from RTSP in multiseat.
    Be aware that the team does not give any support for those who use the SMB - HACK in multiseat.
    This option is only there for testing and debug reasons!
    Hi Chris,
    to fully understand: What is the "official way" to get thumbnails for TV-recordings and comskip on recordings to work in a multiseat environment with no client running on the server?
    Thanks, Guzzi
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Re: AW: Re: Problems with skipping during timeshift multiseat

    Hopefully the SMB ts-buffer rollover problem is fixed in the next build then, so we can switch away from RTSP in multiseat.
    Be aware that the team does not give any support for those who use the SMB - HACK in multiseat.
    This option is only there for testing and debug reasons!
    Hi Chris,
    to fully understand: What is the "official way" to get thumbnails for TV-recordings and comskip on recordings to work in a multiseat environment with no client running on the server?
    Both is a singleseat feature, which can be used in multiseat by enableing the SMB - HACK.

    Thats also why both features are not officially supported in multiseat - and wont ever be in MP1.
    :sorry:
     

    Wondermusic

    Extension Developer
  • Premium Supporter
  • September 7, 2009
    1,113
    274
    Wuppertal
    Germany Germany
    Country flag
    AW: Problems with skipping during timeshift multiseat

    Hi all,

    i have tested again...

    After installing SAF beta23test3 i run DasErste HD and the jumps are correctly done by the engine.
    I tested it with SD- Channels and it jumps nearly to the right positions and I have not the big problem i wrote before.

    Is there someone who can confirm this?
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Re: AW: Problems with skipping during timeshift multiseat

    Hi all,

    i have tested again...

    After installing SAF beta23test3 i run DasErste HD and the jumps are correctly done by the engine.
    I tested it with SD- Channels and it jumps nearly to the right positions and I have not the big problem i wrote before.

    Is there someone who can confirm this?
    Just test more and you will still encounter it.
    Because, as our developer has allready mentioned a few posts earlier, the current time position in the stream is getting greater than the duration of the stream, and no codec on the clientside can fix that.

    Someone needs to find the reason for this randomly occuring bug, and fix it. Thats the only solution. Sadly our devs ran out of ideas on that matter. :(
     

    mcmanuss8

    MP Donator
  • Premium Supporter
  • October 22, 2008
    19
    2
    United States of America United States of America
    Excellent! I've been suffering from this, will try to install latest SVN this weekend and do some testing.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom