Problems with skipping during timeshift multiseat (1 Viewer)

Gixxer

Retired Team Member
  • Premium Supporter
  • August 18, 2007
    1,383
    41
    35
    Spain
    Spain Spain
    I believe this is a big problem so here are my logs.
    client and server.
    multiseat
    client is not in the same computer as server.

    steps:
    16.15 start timeshift
    16.22 2xstep back (shows -30sec) (but does not do it) NOK
    16.22 2xstep back (shows end) (but it shoulnt) NOK
    16.23 2xstep back (shows -30sec) OK
    16.23 3xstep back (shows -1min) OK
    16.24 steps forward (shows end) OK

    if there is any official steps to follow please tell me as i didnt know how to test it correctly, hope the logs are of any use.

    btw, although im sure its somewhere in the logs. im using SVN from 24/12/09 24553
     

    misterd

    Retired Team Member
  • Premium Supporter
  • April 4, 2006
    1,597
    314
    Germany Germany
    I only found out that the current time position in the stream is getting greater than the duration of the stream. This is why than skip steps aren't available anymore.
    Unfortunately I have no clue why it fails and the recent updates to TsReader doesn't make it easier to find the root cause of it.

    Maybe another dev will have a look on it, as I have no clue anymore where the issue could be.

    MisterD
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Any news on the progress of this? Its by far the biggest problem for multiseat atm (IMHO).
    Currently looks like there is no developer who would be able to reproduce the issue with easy enough to allow good debugging of the issue.
     

    thegunzo

    MP Donator
  • Premium Supporter
  • November 15, 2008
    49
    4
    Sauðárkrókur
    Iceland Iceland
    Hi

    Got logs with this error. My first seek skips to the end. try few more skipping back and forth, somethimes works right, sometimes not.
    Log time 2010-01-04 20:20

    Gunnar Gestsson
     

    chrholm

    Portal Pro
    June 20, 2005
    64
    2
    41
    Copenhagen
    Denmark Denmark
    Thanks for your effort. I can confirm what misterd says that it seems the current time of the stream goes wrong. Sometimes when skipping back it will keep saying its at the end of the stream, but if you keep pressing back it will eventually start to cange to -3 og -5 minutes. The colors and length of the playing bar also seems to behave irratic when the problem occurs.

    Do you need any more logs (there a quite a few in this thread already)? Maybe you can enable some debug logging in the areas where this problem could come from, and we can supply logs from that build?
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Do you need any more logs (there a quite a few in this thread already)? Maybe you can enable some debug logging in the areas where this problem could come from, and we can supply logs from that build?
    Sadly logs are not helpful at this point.
    We need an developer who can dive into this issue and debug it to finde the cause. Sadly we do not have such a person atm. :(
     

    richy759

    MP Donator
  • Premium Supporter
  • July 16, 2007
    130
    4
    United Kingdom United Kingdom
    Is the developer who wrote this part not around anymore, or is it not quiet that simple? (I know debugging directshow stuff isn't easy).

    Rich
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom