Problems with skipping during timeshift multiseat (1 Viewer)

thegunzo

MP Donator
  • Premium Supporter
  • November 15, 2008
    49
    4
    Sauðárkrókur
    Iceland Iceland
    Hopefully the SMB ts-buffer rollover problem is fixed in the next build then, so we can switch away from RTSP in multiseat.
    I am using ths SMB ts-buffer with the newest SNV and the only thing that does not work is that I can't skip back all the way to beginning of the buffer. Perhaps only to the start of the current buffer file. Have not tested it to be sure.
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Seems elliottmc found a fix for this. Can't wait to tryout 1.1 RC. Thanks for the effort guys!
    Hi,

    Ambass and arion_p found the fix. All I did was provide logs and hassle them! I can't take any credit for fixing!

    Best wishes,

    Mark
     

    mironicus

    Portal Pro
    March 9, 2008
    688
    44
    Country flag
    AW: Problems with skipping during timeshift multiseat

    I am refering to that bug. There has been an additional fix in svn 24891 that was linked to this thread.

    Additional fix for mantis #2577 Skip steps no longer work reliably in multiseat TV
    - Duration was updated as soon as the stream was added when timeshift buffer may still be empty. As a result the stream would not play.
    I compiled a new version for me, but TV won't even start anymore after this. It gives me an error message that the transport stream (live2-0.ts.tsbuffer) can't be played. I also get an error message if I want to playback already recorded tv shows. I have included a log.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: AW: Problems with skipping during timeshift multiseat

    I am refering to that bug. There has been a fix in svn 24891 that was linked to this thread.

    Additional fix for mantis #2577 Skip steps no longer work reliably in multiseat TV
    - Duration was updated as soon as the stream was added when timeshift buffer may still be empty. As a result the stream would not play.
    I compiled a new version for me, but TV won't even start anymore after this. It gives me an error message that the transport stream (live2-0.ts.tsbuffer) can't be played. I also get an error message if I want to playback already recorded tv shows. I have included a log.
    2010-01-30 09:25:59.182913 [ERROR][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Es wurden keine Filter zum Rendern der Eingangsdaten gefunden.
    2010-01-30 09:25:59.192914 [ERROR][MPMain(1)]: TSReaderPlayer:GetInterfaces() failed

    What does that say in English? :)
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Re: AW: Problems with skipping during timeshift multiseat

    I am refering to that bug. There has been a fix in svn 24891 that was linked to this thread.

    Additional fix for mantis #2577 Skip steps no longer work reliably in multiseat TV
    - Duration was updated as soon as the stream was added when timeshift buffer may still be empty. As a result the stream would not play.
    I compiled a new version for me, but TV won't even start anymore after this. It gives me an error message that the transport stream (live2-0.ts.tsbuffer) can't be played. I also get an error message if I want to playback already recorded tv shows. I have included a log.
    2010-01-30 09:25:59.182913 [ERROR][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Es wurden keine Filter zum Rendern der Eingangsdaten gefunden.
    2010-01-30 09:25:59.192914 [ERROR][MPMain(1)]: TSReaderPlayer:GetInterfaces() failed

    What does that say in English? :)
    2010-01-30 09:25:59.182913 [ERROR][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph No filters were found to render the inputdata
     

    mironicus

    Portal Pro
    March 9, 2008
    688
    44
    Country flag
    AW: Problems with skipping during timeshift multiseat

    "There were no filters found to render the incoming data".

    I now made a test and recompiled version 24890 and installed it. Mediaportal runs now fine, so it seems a svn change after 24891 made this error for me. :)

    Update: I just tested 24891 and copied the updated streamingserver.dll into the TV Server directory. Mediaportal still runs - so it's another svn change that caused that error. I am sorry. I will test the changes after this too.

    Now I could point it out: The changes in 24892 causes this bug! :)

    Fixed mantis #0002524: MS DTV-DVD filter and another H.264 codec in same graph causes issues
    - allow mixed configuration of codecs part 2: tv
    0002524: MS DTV-DVD filter and another H.264 codec in same graph causes issues - MediaPortal Bugtracker
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom