[Bug] TV: missing audio stream in records (Sky) (1 Viewer)

FreakyJ

Development Group
  • Team MediaPortal
  • July 25, 2010
    4,023
    1,420
    Germany Germany
    Country flag
    Ah and were in contact with dd, this is a known limitation with this modus, also in other software :)
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    I see. Are we still hoping for DD to get it fixed then? Hopefully that's no harware limitation.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    I'm pretty sure I had issues with concurrent recording without that patch. Then again it could be due to my cable setup.
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,023
    1,420
    Germany Germany
    Country flag
    Are we still hoping for DD to get it fixed then? Hopefully that's no harware limitation.
    They told me there is no way in fixing it ;) Except: assign the cam only to one tuner. They somehow mix dynamically a complete new transponder, I don't know why they can't change the transponder dynamically in this case because it seems to work if you change channels... taht you would have to discuss with the guys... I actually never spoke directly to the developer, so probably that is the reason that I don't know the exact details :D
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I agree with FreakyJ. DD should be able to do something about the problem, or at least explain clearly why they don't think they can fix it. I suspect fixing this would cause a short glitch in the streams to any other tuners, and so they don't actually want to do it... but I could be wrong. Any side effects depend on their code/architecture and/or how the fix would be applied. In the meantime I have no direct contact with the developer and I don't speak German so I can't explain our point of view clearly or understand their side. Seems to be "stale mate"...
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again everybody

    @Brette
    @Stéphane Lenclud
    ...and anybody else using Digital Devices tuners + CI to receive Sky Germany.

    We're talking with the DD developers about this problem, and we need somebody to help us by performing a simple test.
    The test is:
    1. Tuner 1 start decrypting channel A.
    2. Tuner 2 start decrypting channel B.
    3. ***dynamic PMT change for channel A***
    4. Tuner 1 stop streaming channel A.
    5. Tuner 1 start streaming channel A.
    => Expected result is that channel A and B are both decrypting successfully for all elementary streams.

    After the test we need you to:
    1. Collect and attach the TV service, TsWriter and TsReader log files.
    2. Tell us what date/time you performed the test.
    3. Tell us which CAM you're using, including firmware version.
    We may need further testing to be done after, but for now only one test is required.

    Is anybody able to help?
    Please consider: this is probably the only chance we'll get to solve the problem.

    Regards,
    mm
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    @mm1352000 ,

    For the sake of avoiding misunderstandings: Are you asking for simultaneous usage of Tuner 1 and 2?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Are you asking for simultaneous usage of Tuner 1 and 2?
    Yes.

    [edit: Ahhhh, I also should have said: please do the test without the patch.

    To give a bit more information...
    The original problem is that audio streams are not decrypted when they start after the start of timeshifting/recording.
    The patch fixes that problem but introduces a new problem: channel B stops decrypting when the dynamic PMT update is received.

    DD are currently saying that both the original problem and the current problem are probably related to the CAM or NDS.
    We need this test to show that the driver and CAM can decrypt both channels, so the problem must be related to how the dynamic PMT change is handled by the driver.

    Please feel free to ask if anything else is not clear. :)
    ]
     
    Last edited:

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    Tuner 1 start decrypting channel A.
    Tuner 2 start decrypting channel B.
    ***dynamic PMT change for channel A***
    Tuner 1 stop streaming channel A.
    Tuner 1 start streaming channel A.
    What difference do you make between decrypting and streaming?
    How would that translate in terms of use case?

    For instance:
    Setup recording of a channel.
    Watch another channel until recording of the first one starts.
    Switch to recorded channel.
    Check that both German and English audio streams are ok.
    Shutdown MP.
    Get logs.

    I guess we should also try the same testing on Sky Germany but with different hardware.

    Thank you so much for taking the time to get to the bottom of this issue.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    SpudR Missing Page Numbers Website/Forum/Wiki Feedback 11
    g0rsq UK Freesat not tunning BBC HD channels, and lots of other freesat channels missing. Newcomers Forum 4
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    HTPCSourcer Missing series posters/banners MediaPortal 2 11
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    T How to add missing buttons IR Server Suite (IRSS) 0
    T Missing sound in online streaming service (SVTPlay) General Support 3
    D Tuner Suddenly Missing Channels TV-Cards 0
    S Missing plugin for MP2 Plugin Development 1
    L [solved] MP2 doesnt play anything - player missing? General 1
    L Tv series install problem missing file My TVSeries 7
    L [solved] Missing gentle.config file General 6
    CyberSimian TV Server import is missing some settings MediaPortal 1 0
    T Media Portal 2 EPG data missing General 16
    zunixnuz Missing #iswatched property to recorded TV Titan Skin Feedback 5
    Ralph Holmes Missing TV channels after transmitter change (Tacolneston) General 6
    P [Resolved] Missing column in database My TVSeries 7
    Charlie TV [solved] Channels disappeared after transmitter changes (Midhurst) General Support 4
    Stubbie MediaPortal DVB EPG - Partly missing EPG MediaPortal 1 Talk 0
    CyberSimian My network devices sometimes go missing OffTopic 6
    T Missing Some UK Channels (Quest & Quest Red) Television (MyTV frontend and TV-Server) 13
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    Top Bottom