Unable to play any video (1 Viewer)

z3us

Portal Pro
December 4, 2007
1,047
123
40
Spain Spain
I´m always getting a error
" Unable to play...
video codec: AVC
Audio codec: AAC LC"

I think this is not related to MP itself because I had to delete some intro video files to be able to play Civilization 5
Any help?

Thanks
 

Attachments

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello :)

    First, your MovingPictures database appears to be corrupt:
    [2015-10-26 20:11:21,376] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database: movingpictures.db3
    [2015-10-26 20:11:21,378] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database:
    [2015-10-26 20:11:21,380] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database:
    [2015-10-26 20:11:21,382] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database:
    [2015-10-26 20:11:21,384] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database:
    [2015-10-26 20:11:21,385] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database:
    Please fix that according to the instructions here:
    http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/16_Support/Troubleshooting/Repair_SQLite_Database


    Second, your video codec preferences appear to be unset:
    [2015-10-26 20:12:16,835] [Error ] [MPMain ] [ERROR] - Failed filter: not found
    This is a problem because when MP tries to fall back to using the default system codec, the following error occurs:
    [collapse][2015-10-26 20:12:16,839] [Error ] [MPMain ] [ERROR] - VideoPlayer9: Exception loading Source Filter setup in setting in DShow graph , try to load by merit
    [2015-10-26 20:12:16,842] [Error ] [MPMain ] [ERROR] - Exception while releasing COM object (NULL) - stacktrace: en DShowNET.Helper.DirectShowUtil.ReleaseComObject(Object obj)
    en MediaPortal.Player.VideoPlayerVMR9.GetInterfaces()
    en MediaPortal.Player.VideoPlayerVMR7.Play(String strFile)
    en MediaPortal.Player.g_Player.Play(String strFile, MediaType type, TextReader chapters, Boolean fromPictures, Int32 title, Boolean forcePlay, Boolean fromExtTS)
    en MediaPortal.Playlists.PlayListPlayer.FakePlayer.MediaPortal.Playlists.PlayListPlayer.IPlayer.Play(String strFile, MediaType type)
    en MediaPortal.Playlists.PlayListPlayer.Play(Int32 iSong, Boolean setFullScreenVideo)
    en MediaPortal.Playlists.PlayListPlayer.PlayNext(Boolean setFullScreenVideo)
    en MyFilmsPlugin.MyFilms.MyFilmsGUI.MyFilmsDetail.PlayMovieFromPlayList(Boolean noResumeMovie, Int32 iMovieIndex)
    en MyFilmsPlugin.MyFilms.MyFilmsGUI.MyFilmsDetail.Launch_Movie(Int32 select_item, Int32 GetID, GUIAnimation m_SearchAnimation, PlayerOption playeroption)
    en MyFilmsPlugin.MyFilms.MyFilmsGUI.MyFilmsDetail.OnMessage(GUIMessage messageType)
    en MediaPortal.GUI.Library.GUIWindowManager.SendMessage(GUIMessage message)
    en MediaPortal.GUI.Library.GUIWindowManager.DispatchThreadMessages()
    en MediaPortalApp.FrameMove()
    en MediaPortal.D3D.OnIdle(Object sender, EventArgs e)
    en System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
    en System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
    en System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
    en System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
    en System.Windows.Forms.Application.Run(Form mainForm)
    en MediaPortalApp.Main(String[] args)

    [2015-10-26 20:12:16,856] [Error ] [MPMain ] [ERROR] - VideoPlayer9: Exception while creating DShow graph Referencia a objeto no establecida como instancia de un objeto. en DShowNET.Helper.DirectShowUtil.FindPin(IBaseFilter filter, PinDirection dir, String strPinName)
    en MediaPortal.Player.VideoPlayerVMR9.UpdateFilters(String selection)
    en MediaPortal.Player.VideoPlayerVMR9.GetInterfaces()[/collapse]

    Please fix this problem by configuring your video codecs as shown here:
    http://wiki.team-mediaportal.com/1_...guration/9_Codecs_and_Renderer/0_Video_Codecs
    https://forum.team-mediaportal.com/threads/guide-perfect-playback-display-calibration.119610/

    Regards,
    mm
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    V Unable to stream : 10 General Support 0
    M Unable to map virtual sent keys in the input device management General 6
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    M WTV Files does not play on client, MPEG files works well General 0
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    Similar threads

























    Top Bottom