[Updated 27 Mar!] MPExtended Service 0.4.3 | Page 3

Discussion in 'MPExtended' started by Oxan, December 24, 2011.

Thread Status:
Not open for further replies.
  1. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Re: MPExtended Service 0.4



    There should be more details associated with events like this, where the stack trace is listed. Could you please post the full information from the event? Also, which OS do you use? Thanks!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. rich76

    rich76 Portal Pro

    Joined:
    December 3, 2006
    Messages:
    141
    Likes Received:
    20
    Ratings:
    +30 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Re: MPExtended Service 0.4

    Hi Oxan,
    Im using windows 7 ultimate sp1 32bit, on the 2nd pc its windows home premium 7 sp1 64bit,
    Is this what you mean from event viewer?

    Log Name: System
    Source: Service Control Manager
    Date: 29/12/2011 15:42:25
    Event ID: 7034
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: TVPC
    Description:
    The MPExtended Service service terminated unexpectedly. It has done this 3 time(s).
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7034</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-29T15:42:25.013994800Z" />
    <EventRecordID>27501</EventRecordID>
    <Correlation />
    <Execution ProcessID="572" ThreadID="4912" />
    <Channel>System</Channel>
    <Computer>TVPC</Computer>
    <Security />
    </System>
    <EventData>
    <Data Name="param1">MPExtended Service</Data>
    <Data Name="param2">3</Data>
    </EventData>
    </Event>

    If this is not what you needed, can you explain a bit more where and how to get this info for you

    Thanks
    Rich

    I also get this error log in the event viewer too...

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-29T15:42:24.000000000Z" />
    <EventRecordID>8909</EventRecordID>
    <Channel>Application</Channel>
    <Computer>TVPC</Computer>
    <Security />
    </System>
    - <EventData>
    <Data>MPExtended.ServiceHosts.CoreService.exe</Data>
    <Data>1.0.0.0</Data>
    <Data>4ef63c0d</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.1.7601.17651</Data>
    <Data>4e2111c0</Data>
    <Data>e0434352</Data>
    <Data>0000d36f</Data>
    <Data>de0</Data>
    <Data>01ccc640731509ce</Data>
    <Data>C:\Program Files\MPExtended\Service\MPExtended.ServiceHosts.CoreService.exe</Data>
    <Data>C:\Windows\system32\KERNELBASE.dll</Data>
    <Data>b3c52ba3-3233-11e1-a8ab-1c6f655e0c92</Data>
    </EventData>
    </Event>

    :D
     
  4. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Re: MPExtended Service 0.4

    Hmm no. I would expect an event from 'MPExtended Service' somewhere, with a stacktrace in the general information, as in this example:
    [​IMG]
    The part at the bottom in the grey box (Service cannot be started, etc) is the important part.

    I suspect this has something to do with 32-bit/64-bit btw. I'll test it on a 32-bit pc tomorrow.
     
  5. rolls1400

    rolls1400 Portal Pro

    Joined:
    August 26, 2007
    Messages:
    132
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    United States of America United States of America
    Re: MPExtended Service 0.4

    Hi Oxan and thanks for all the hard work.

    In trying to set this up the api doesnt seem to be working.. When in the MPExtended Configurator and under Troubleshooting I select the test link 'Media' and 'Streaming' but got the error "Endpoint not found." in the browser. Any ideas?
     
  6. rich76

    rich76 Portal Pro

    Joined:
    December 3, 2006
    Messages:
    141
    Likes Received:
    20
    Ratings:
    +30 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    From a trail and error process,
    A Fresh install of mp 1.2.2 works and your plugin works, installing the svn mentioned above it works, after installing mustayaluca 4.0.220 skin even if I don't select any plugins to install and then open mediaportal config and close it the problem comes back.
    So it seems to be the installer of mustayaluca causing the problem but don't know why.
    I'm getting the same error on the 32bit and 64bit pc so don't think it's related to that but could be wrong.
    I'm away from the pc so can't get any more logs but if you follow the steps above it should replicate the problem. I haven't tried without installing the svn but you didn't think that would be an issue.
    Thanks for your help
    Rich
     
    • Like Like x 1
  7. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Re: MPExtended Service 0.4

    I'm sorry but I can't reproduce it on a fresh install of MP 1.2.2 with Mustayaluca 0.4.0.220...
     
  8. rich76

    rich76 Portal Pro

    Joined:
    December 3, 2006
    Messages:
    141
    Likes Received:
    20
    Ratings:
    +30 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi oxan,
    Thanks for trying I will keep trying and post any results I find.
    When I get back home I will have a look for the log you mentioned earlier
    Thanks
    Rich
     
  9. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Re: [Updated 30 Dec!] MPExtended Service 0.4

    MPExtended Service 0.4.1

    I just released 0.4.1 with these changes:
    • Improve artwork retrieval for music
    • Be a bit more quiet in the event log
    • Fixed harmless error when shutting down the service
    • Fix starting and stopping service from the configurator
    • Fix crash when starting MediaPortal from the menu of the tray application
    • Fix error when exporting logs while WebMP was running
    • Split out logs of configurator to separate file
    • Fix IDs in search results from MP-TVSeries
    • Fix harmless error in GetPlayerPosition
    • Fix error when loading streaming view in configurator
    • Fix TV logo location in Windows XP
    • Add duration to WebMusicTrackBasic (for Eve)
    Please note that you will lose your settings on upgrade. This has been resolved for all future updates.

    Thanks a lot for all your feedback.
     
    • Like Like x 5
  10. hase23

    hase23 Portal Pro

    Joined:
    May 24, 2009
    Messages:
    131
    Likes Received:
    18
    Gender:
    Male
    Location:
    Espenau
    Ratings:
    +19 / 0
    Home Country:
    Germany Germany
    AW: [Updated 30 Dec!] MPExtended Service 0.4

    Hello I have the problem that I get the error after the setup

    1-12-30 20:37:53.8863 [host thread (4)] INFO: Could not find MediaPortal installation path in registry key, MediaPortal is installed?:(

    greeting
    Sascha
     
  11. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Re: AW: [Updated 30 Dec!] MPExtended Service 0.4

    Which windows version do you use? And, 32-bit or 64-bit? Anyway, it's just an info message, the service should work without problems.
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!